QGIS 3.2 installer doesn't find Python 3.6 on Mac?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS 3.2 installer doesn't find Python 3.6 on Mac?

MacQueen, Don
Hi,

I have (finally) upgraded my MacOS to 10.13.5, and am reinstalling/updating various apps, including QGIS.

When I try to install QGIS (step 3 on the QGIS dmg, after having done steps 1 and 2 in order), I get the message
   "QGIS requires Python 3.6"

Apparently, the QGIS installer isn't finding the newly installed Python 3.7.
Strikes me as a path problem. I'd appreciate help solving it.

Thanks!
-Don


More detail:

I downloaded
   QGIS-macOS-3.2.0-1.dmg
from the QGIS website, and followed its instructions in order, including
  1. install Python 3
  2. Install GDAL complete

I first installed Python from
   python-3.7.0-macosx10.9.pkg
which I found following the links in the step 1 readme.
I ran the
   "Update Shell Profile.command"
script provided with Python3.
I then installed GDAL complete.

After having done all that:

In Terminal.app, I get

[8]% which python3
/Library/Frameworks/Python.framework/Versions/3.7/bin/python3

[9]% which python
/usr/bin/python
[10]% python --version
Python 2.7.10

I have tried logging out and logging in, and even restarting. Didn't help.


--
Don MacQueen
Lawrence Livermore National Laboratory
7000 East Ave., L-627
Livermore, CA 94550
925-423-1062
Lab cell 925-724-7509
 
 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 3.2 installer doesn't find Python 3.6 on Mac?

Rémi Desgrange
You need python3.6. Not 3.7.

Cordialement, Rémi Desgrange
 

Le 09/07/2018 18:45, « Qgis-user au nom de MacQueen, Don » <[hidden email] au nom de [hidden email]> a écrit :

    Hi,
   
    I have (finally) upgraded my MacOS to 10.13.5, and am reinstalling/updating various apps, including QGIS.
   
    When I try to install QGIS (step 3 on the QGIS dmg, after having done steps 1 and 2 in order), I get the message
       "QGIS requires Python 3.6"
   
    Apparently, the QGIS installer isn't finding the newly installed Python 3.7.
    Strikes me as a path problem. I'd appreciate help solving it.
   
    Thanks!
    -Don
   
   
    More detail:
   
    I downloaded
       QGIS-macOS-3.2.0-1.dmg
    from the QGIS website, and followed its instructions in order, including
      1. install Python 3
      2. Install GDAL complete
   
    I first installed Python from
       python-3.7.0-macosx10.9.pkg
    which I found following the links in the step 1 readme.
    I ran the
       "Update Shell Profile.command"
    script provided with Python3.
    I then installed GDAL complete.
   
    After having done all that:
   
    In Terminal.app, I get
   
    [8]% which python3
    /Library/Frameworks/Python.framework/Versions/3.7/bin/python3
   
    [9]% which python
    /usr/bin/python
    [10]% python --version
    Python 2.7.10
   
    I have tried logging out and logging in, and even restarting. Didn't help.
   
   
    --
    Don MacQueen
    Lawrence Livermore National Laboratory
    7000 East Ave., L-627
    Livermore, CA 94550
    925-423-1062
    Lab cell 925-724-7509
     
     
   
    _______________________________________________
    Qgis-user mailing list
    [hidden email]
    List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
    Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 3.2 installer doesn't find Python 3.6 on Mac?

William Kyngesburye
More specifically, QGIS links to the Python binary, and a specific major version (ie 3.6 at this time), so a newer major version cannot be dropped in as an upgrade.

On Jul 10, 2018, at 1:46 AM, Rémi Desgrange <[hidden email]> wrote:

You need python3.6. Not 3.7.

Cordialement, Rémi Desgrange


Le 09/07/2018 18:45, « Qgis-user au nom de MacQueen, Don » <[hidden email] au nom de [hidden email]> a écrit :

   Hi,

   I have (finally) upgraded my MacOS to 10.13.5, and am reinstalling/updating various apps, including QGIS.

   When I try to install QGIS (step 3 on the QGIS dmg, after having done steps 1 and 2 in order), I get the message
      "QGIS requires Python 3.6"

   Apparently, the QGIS installer isn't finding the newly installed Python 3.7.
   Strikes me as a path problem. I'd appreciate help solving it.

   Thanks!
   -Don


   More detail:

   I downloaded
      QGIS-macOS-3.2.0-1.dmg
   from the QGIS website, and followed its instructions in order, including
     1. install Python 3
     2. Install GDAL complete

   I first installed Python from
      python-3.7.0-macosx10.9.pkg
   which I found following the links in the step 1 readme.
   I ran the
      "Update Shell Profile.command"
   script provided with Python3.
   I then installed GDAL complete.

   After having done all that:

   In Terminal.app, I get

   [8]% which python3
   /Library/Frameworks/Python.framework/Versions/3.7/bin/python3

   [9]% which python
   /usr/bin/python
   [10]% python --version
   Python 2.7.10

   I have tried logging out and logging in, and even restarting. Didn't help.


   --
   Don MacQueen
   Lawrence Livermore National Laboratory
   7000 East Ave., L-627
   Livermore, CA 94550
   925-423-1062
   Lab cell 925-724-7509



   _______________________________________________
   Qgis-user mailing list
   [hidden email]
   List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
   Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

-----
William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>

"This is a question about the past, is it? ... How can I tell that the past isn't a fiction designed to account for the discrepancy between my immediate physical sensations and my state of mind?"

- The Ruler of the Universe



_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user