QGIS 2 master: Identify tool and highlights

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS 2 master: Identify tool and highlights

Andreas Neumann-4

Hi,

I am sure that in a past QGIS 2x version, when the identify tool was set to "layer choice" that one would have gotten a highlight of the selected feature from the context menu.

Now, with the current 2.x master (and with 2.16 and 2.14) on Windows, the highlight of the object is gone ;-( so now there is no way to find out what feature I am selecting. The highlight now only displays after I selected the entry, which is not so useful than the previous behavior.

Can someone confirm? Or is it just a misconfiguration on my side?

Thank you for any hints,

Andreas

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2 master: Identify tool and highlights

DelazJ
Hi,
Andreas, I can't confirm (windows 10 and 2.16.3)
Features are highlighted when I hover over their id in the context menu.

Regards,
Harrissou

2016-09-27 17:36 GMT+02:00 Neumann, Andreas <[hidden email]>:

Hi,

I am sure that in a past QGIS 2x version, when the identify tool was set to "layer choice" that one would have gotten a highlight of the selected feature from the context menu.

Now, with the current 2.x master (and with 2.16 and 2.14) on Windows, the highlight of the object is gone ;-( so now there is no way to find out what feature I am selecting. The highlight now only displays after I selected the entry, which is not so useful than the previous behavior.

Can someone confirm? Or is it just a misconfiguration on my side?

Thank you for any hints,

Andreas

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2 master: Identify tool and highlights

Andreas Neumann-4

Thanks for checking. Is there some configuration that might disable this highlighting?

I was sure I had this working, but now it doesn't. I checked all my versions I have: 2.14, 2.16, master 2. Neither one works.

Andreas

On 2016-09-27 17:43, DelazJ wrote:

Hi,
Andreas, I can't confirm (windows 10 and 2.16.3)
Features are highlighted when I hover over their id in the context menu.

Regards,
Harrissou

2016-09-27 17:36 GMT+02:00 Neumann, Andreas <[hidden email]>:

Hi,

I am sure that in a past QGIS 2x version, when the identify tool was set to "layer choice" that one would have gotten a highlight of the selected feature from the context menu.

Now, with the current 2.x master (and with 2.16 and 2.14) on Windows, the highlight of the object is gone ;-( so now there is no way to find out what feature I am selecting. The highlight now only displays after I selected the entry, which is not so useful than the previous behavior.

Can someone confirm? Or is it just a misconfiguration on my side?

Thank you for any hints,

Andreas

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

 

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2 master: Identify tool and highlights

TylerVeinot
Settings > Options > Map Tools (Left Hand Side Panel) At the top you should see identify and a drop down for highlight color. If this color is set to 100% Transparent then it would work as if there was no highlight. Other than that I see no other way to turn off the highlight so check there; maybe you accidentally made your highlight transparent. To add to that, white would look like there was no highlight on if the background color was also white, its effect is a very light ghosting of the feature when identified; easily missed.
Tyler

On Tue, Sep 27, 2016 at 12:50 PM, Neumann, Andreas <[hidden email]> wrote:

Thanks for checking. Is there some configuration that might disable this highlighting?

I was sure I had this working, but now it doesn't. I checked all my versions I have: 2.14, 2.16, master 2. Neither one works.

Andreas

On 2016-09-27 17:43, DelazJ wrote:

Hi,
Andreas, I can't confirm (windows 10 and 2.16.3)
Features are highlighted when I hover over their id in the context menu.

Regards,
Harrissou

2016-09-27 17:36 GMT+02:00 Neumann, Andreas <[hidden email]>:

Hi,

I am sure that in a past QGIS 2x version, when the identify tool was set to "layer choice" that one would have gotten a highlight of the selected feature from the context menu.

Now, with the current 2.x master (and with 2.16 and 2.14) on Windows, the highlight of the object is gone ;-( so now there is no way to find out what feature I am selecting. The highlight now only displays after I selected the entry, which is not so useful than the previous behavior.

Can someone confirm? Or is it just a misconfiguration on my side?

Thank you for any hints,

Andreas

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

 

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2 master: Identify tool and highlights

Andreas Neumann-4

 

Hi and thank you for testing,

I think I found out what the issue is. My geometries contain circular arcs (WKB Types CompoundCurve or CurvePolygon). Quite likely, the highlight does not work with this WKB type.

Using Simple feature geometry types works fine. One more place in QGIS where Circular Arcs cause troubles ... sigh! 

I'll file a bug report.

Andreas

On 2016-09-27 18:16, Tyler Veinot wrote:

Settings > Options > Map Tools (Left Hand Side Panel) At the top you should see identify and a drop down for highlight color. If this color is set to 100% Transparent then it would work as if there was no highlight. Other than that I see no other way to turn off the highlight so check there; maybe you accidentally made your highlight transparent. To add to that, white would look like there was no highlight on if the background color was also white, its effect is a very light ghosting of the feature when identified; easily missed.
Tyler

On Tue, Sep 27, 2016 at 12:50 PM, Neumann, Andreas <[hidden email]> wrote:

Thanks for checking. Is there some configuration that might disable this highlighting?

I was sure I had this working, but now it doesn't. I checked all my versions I have: 2.14, 2.16, master 2. Neither one works.

Andreas

On 2016-09-27 17:43, DelazJ wrote:

Hi,
Andreas, I can't confirm (windows 10 and 2.16.3)
Features are highlighted when I hover over their id in the context menu.

Regards,
Harrissou

2016-09-27 17:36 GMT+02:00 Neumann, Andreas <[hidden email]>:

Hi,

I am sure that in a past QGIS 2x version, when the identify tool was set to "layer choice" that one would have gotten a highlight of the selected feature from the context menu.

Now, with the current 2.x master (and with 2.16 and 2.14) on Windows, the highlight of the object is gone ;-( so now there is no way to find out what feature I am selecting. The highlight now only displays after I selected the entry, which is not so useful than the previous behavior.

Can someone confirm? Or is it just a misconfiguration on my side?

Thank you for any hints,

Andreas

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

 

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user

 

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: http://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: http://lists.osgeo.org/mailman/listinfo/qgis-user