QGIS 2.6 - Open postgis raster: decimal separator problem?

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS 2.6 - Open postgis raster: decimal separator problem?

Jorge Gustavo Rocha
Hi devs,

I'm unable to open Postgis rasters using the default language setting,
which is pt_PT.UTF-8 in my case. By overriding language settings, I can
open Postgis rasters. Maybe something related with the decimal_point
setting in LC_NUMERIC?

I didn't find any bug related with this issue. Can some else confirm
this problem? Should I submit a bug?

How to reproduce the problem (if decimal_point == ',' and not '.'):

0) Download raster from https://bo5r0b.s.cld.pt or use your own raster

i) Insert raster in to Postgis
raster2pgsql -d -I -C -M -s 3763 001972Argb_12.tif -F -t 1000x1000 orto
| psql -h localhost -U geobox -d orto

ii) Open QGIS with default language settings.
Add raster to QGIS using DB Manager

iii) The raster does not show properly. Raster properties are not
extract/calculated correctly.

How to solve the problem:

i) Start QGIS overriding all language specific settings:

LC_ALL=C qgis

ii) The Postgis raster shows properly and all properties are loaded with
correct values.

I'm using:
Ubuntu 14.04.1 LTS

"PostgreSQL 9.3.5 on x86_64-unknown-linux-gnu, compiled by gcc (Ubuntu
4.8.2-19ubuntu1) 4.8.2, 64-bit"

"POSTGIS="2.1.2 r12389" GEOS="3.4.2-CAPI-1.8.2 r3921" PROJ="Rel. 4.8.0,
6 March 2012" GDAL="GDAL 1.10.1, released 2013/08/26" LIBXML="2.9.1"
LIBJSON="UNKNOWN" RASTER"

QGIS version 2.6.0-Brighton QGIS code revision exported
Compiled against Qt 4.8.6 Running against Qt 4.8.6
Compiled against GDAL/OGR 1.10.1 Running against GDAL/OGR 1.10.1
Compiled against GEOS 3.4.2-CAPI-1.8.2 Running against GEOS
3.4.2-CAPI-1.8.2 r3921
PostgreSQL Client Version 9.3.4 SpatiaLite Version 4.1.1
QWT Version 5.2.3 PROJ.4 Version 480
QScintilla2 Version 2.8.1

Additional feedback is appreciated.

Regards,

J. Gustavo
--
Jorge Gustavo Rocha
Departamento de Informática
Universidade do Minho
4710-057 Braga
Tel: +351 253604480
Fax: +351 253604471
Móvel: +351 910333888
skype: nabocudnosor
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6 - Open postgis raster: decimal separator problem?

Giovanni Manghi-2
> Hi devs,
>
> I'm unable to open Postgis rasters using the default language setting,
> which is pt_PT.UTF-8 in my case. By overriding language settings, I can
> open Postgis rasters. Maybe something related with the decimal_point
> setting in LC_NUMERIC?
>
> I didn't find any bug related with this issue. Can some else confirm
> this problem? Should I submit a bug?
>
> How to reproduce the problem (if decimal_point == ',' and not '.'):


it may be unrelated, but I recall a ticket about systems (Windows in
that case) were using the "," instead of "." for decimal separator
cause(d) issues at many levels. I can't find the ticket now and I
can't remember if the issue was fixed or not.

cheers!


--
Giovanni Manghi
Faunalia.pt
Sistemas de Informação Geográfica Open Source
Portugal

Web: http://www.faunalia.pt
Email & Jabber: [hidden email]
PGP Key available
Tel. + 351 96 7058216
--
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6 - Open postgis raster: decimal separator problem?

Yves Jacolin
Le vendredi 14 novembre 2014, 10:24:36 Giovanni Manghi a écrit :

> > Hi devs,
> >
> > I'm unable to open Postgis rasters using the default language setting,
> > which is pt_PT.UTF-8 in my case. By overriding language settings, I can
> > open Postgis rasters. Maybe something related with the decimal_point
> > setting in LC_NUMERIC?
> >
> > I didn't find any bug related with this issue. Can some else confirm
> > this problem? Should I submit a bug?
>
> > How to reproduce the problem (if decimal_point == ',' and not '.'):
> it may be unrelated, but I recall a ticket about systems (Windows in
> that case) were using the "," instead of "." for decimal separator
> cause(d) issues at many levels. I can't find the ticket now and I
> can't remember if the issue was fixed or not.
>
> cheers!
I can confirm that there was such bug in gdal/ogr but it shoud be closed in
recent release.

I have a mail in my archive explaining this sent by Even rouault in gdal-dev
list the 22/10/2013.

Y.
--
Yves Jacolin
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6 - Open postgis raster: decimal separator problem?

Jorge Gustavo Rocha
Thanks, Yves.

I found the thread in gdal-dev from almost a year ago (Oct. 2013).
This is fixed now:
http://trac.osgeo.org/gdal/ticket/5731 but only for gdal 2.0. I was
hoping to see this fixed in gdal 1.11.

Thanks in advance,

J. Gustavo

On 18-11-2014 21:19, Yves Jacolin wrote:

> Le vendredi 14 novembre 2014, 10:24:36 Giovanni Manghi a écrit :
>>> Hi devs,
>>>
>>> I'm unable to open Postgis rasters using the default language setting,
>>> which is pt_PT.UTF-8 in my case. By overriding language settings, I can
>>> open Postgis rasters. Maybe something related with the decimal_point
>>> setting in LC_NUMERIC?
>>>
>>> I didn't find any bug related with this issue. Can some else confirm
>>> this problem? Should I submit a bug?
>>
>>> How to reproduce the problem (if decimal_point == ',' and not '.'):
>> it may be unrelated, but I recall a ticket about systems (Windows in
>> that case) were using the "," instead of "." for decimal separator
>> cause(d) issues at many levels. I can't find the ticket now and I
>> can't remember if the issue was fixed or not.
>>
>> cheers!
> I can confirm that there was such bug in gdal/ogr but it shoud be closed in
> recent release.
>
> I have a mail in my archive explaining this sent by Even rouault in gdal-dev
> list the 22/10/2013.
>
> Y.
>

J. Gustavo
--
Jorge Gustavo Rocha
Departamento de Informática
Universidade do Minho
4710-057 Braga
Tel: +351 253604480
Fax: +351 253604471
Móvel: +351 910333888
skype: nabocudnosor
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer