QGIS 2.6.1 update problem [Ubuntu]

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

QGIS 2.6.1 update problem [Ubuntu]

Slawomir Bienias
Hello,
I have a problem with 2.6.1 update (Ubuntu 14.04 64bit, Debian repo for trusty).
I do the update and there is a problem with dependencies for qgis-python, with "libqgis-customwidgets2.6.1". Now I have all upgrades blocked because this package is broken... :)

"apt-get -f install" is not working. It shows me an error (Polish comments):
# dpkg: error processing archive /var/cache/apt/archives/libqgis-
# customwidgets2.6.1_2.6.1+trusty1_amd64.deb (--unpack):
#   próba nadpisania "/usr/lib/x86_64-linux-gnu/qt4/plugins/designer/libqgis_customwidgets.so", który
#   istnieje także w pakiecie libqgis-customwidgets2.6.0 2.6.0+trusty1
# Wystąpiły błędy podczas przetwarzania:
# /var/cache/apt/archives/libqgis-customwidgets2.6.1_2.6.1+trusty1_amd64.deb
# E: Sub-process /usr/bin/dpkg returned an error code (1)

Maybe you know how to solve this problem..


And funny thing, my QGIS is upgraded to v. 2.6.1, but problem with dependencies still remain...


Regards,
Slawomir Bienias
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6.1 update problem [Ubuntu]

Filipe Dias-2
The solution is to delete qgis and reinstall:

sudo apt-get purge qgis*
sudo apt-get autoremove
sudo apt-get autoclean

sudo apt-get install qgis python-qgis

HTH

On Sat, Nov 29, 2014 at 11:21 PM, SaekBinko <[hidden email]> wrote:
Hello,
I have a problem with 2.6.1 update (Ubuntu 14.04 64bit, Debian repo for
trusty).
I do the update and there is a problem with dependencies for qgis-python,
with "libqgis-customwidgets2.6.1". Now I have all upgrades blocked because
this package is broken... :)

"apt-get -f install" is not working. It shows me an error (Polish comments):
# dpkg: error processing archive /var/cache/apt/archives/libqgis-
# customwidgets2.6.1_2.6.1+trusty1_amd64.deb (--unpack):
#   próba nadpisania
"/usr/lib/x86_64-linux-gnu/qt4/plugins/designer/libqgis_customwidgets.so",
który
#   istnieje także w pakiecie libqgis-customwidgets2.6.0 2.6.0+trusty1
# Wystąpiły błędy podczas przetwarzania:
# /var/cache/apt/archives/libqgis-customwidgets2.6.1_2.6.1+trusty1_amd64.deb
# E: Sub-process /usr/bin/dpkg returned an error code (1)

Maybe you know how to solve this problem..


And funny thing, my QGIS is upgraded to v. 2.6.1, but problem with
dependencies still remain...


Regards,
Slawomir Bienias



--
View this message in context: http://osgeo-org.1560.x6.nabble.com/QGIS-2-6-1-update-problem-Ubuntu-tp5175632.html
Sent from the Quantum GIS - User mailing list archive at Nabble.com.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6.1 update problem [Ubuntu]

H. S. Sudhira
This solution works for ubuntu. 

Thanks,
Sudhira.

On Sun, Nov 30, 2014 at 5:03 AM, Filipe Dias <[hidden email]> wrote:
The solution is to delete qgis and reinstall:

sudo apt-get purge qgis*
sudo apt-get autoremove
sudo apt-get autoclean

sudo apt-get install qgis python-qgis

HTH

On Sat, Nov 29, 2014 at 11:21 PM, SaekBinko <[hidden email]> wrote:
Hello,
I have a problem with 2.6.1 update (Ubuntu 14.04 64bit, Debian repo for
trusty).
I do the update and there is a problem with dependencies for qgis-python,
with "libqgis-customwidgets2.6.1". Now I have all upgrades blocked because
this package is broken... :)

"apt-get -f install" is not working. It shows me an error (Polish comments):
# dpkg: error processing archive /var/cache/apt/archives/libqgis-
# customwidgets2.6.1_2.6.1+trusty1_amd64.deb (--unpack):
#   próba nadpisania
"/usr/lib/x86_64-linux-gnu/qt4/plugins/designer/libqgis_customwidgets.so",
który
#   istnieje także w pakiecie libqgis-customwidgets2.6.0 2.6.0+trusty1
# Wystąpiły błędy podczas przetwarzania:
# /var/cache/apt/archives/libqgis-customwidgets2.6.1_2.6.1+trusty1_amd64.deb
# E: Sub-process /usr/bin/dpkg returned an error code (1)

Maybe you know how to solve this problem..


And funny thing, my QGIS is upgraded to v. 2.6.1, but problem with
dependencies still remain...


Regards,
Slawomir Bienias



--
View this message in context: http://osgeo-org.1560.x6.nabble.com/QGIS-2-6-1-update-problem-Ubuntu-tp5175632.html
Sent from the Quantum GIS - User mailing list archive at Nabble.com.
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user


_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6.1 update problem [Ubuntu]

olagato
Same issue in my Kubuntu 14.10 installation: it seems that a Python downgrade from 2.7.8-1 to 2.7.1 is required in order to run QGIS 2.6.1

The following packages have unmet dependencies:
python-qgis-common: Depends: libqgis-customwidgets2.6.1 but it is not installed
                    Depends: python (>= 2.7) but 2.7.8-1 is installed
                    Depends: python:any (>= 2.7.1-0ubuntu2) but it is a virtual package

Fixed broken updates in Kubuntu in this way:
sudo dpkg --force-depends --purge "python-qgis-common"
sudo dpkg --force-depends --purge "python-qgis"
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get update && sudo apt-get upgrade
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6.1 update problem [Ubuntu]

olagato
Forget my last post, Filipe-Dias' workaround is working in Kubuntu 14.10 (w/Python 2.7.8.-1 no problem with Python versions)

sudo apt-get purge "qgis*" <-- double quotes needed
sudo apt-get autoremove
sudo apt-get autoclean
sudo apt-get install qgis python-qgis
sudo apt-get update && sudo apt-get upgrade
Reply | Threaded
Open this post in threaded view
|

Re: QGIS 2.6.1 update problem [Ubuntu]

Samy Mezani
In reply to this post by Filipe Dias-2
The solution is only to remove libqgis-customwidgets2.6.0 (python-qgis
and python-qgis-common depend on it) and to install python-qgis :

sudo aptitude purge libqgis-customwidgets2.6.0
sudo aptitude install python-qgis

Samy

Le 30/11/2014 00:33, Filipe Dias a écrit :
> The solution is to delete qgis and reinstall:
>
> sudo apt-get purge qgis*
> sudo apt-get autoremove
> sudo apt-get autoclean
>
> sudo apt-get install qgis python-qgis
_______________________________________________
Qgis-user mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-user