Python plugins in QGIS_PLUGINPATH not appearing in Plugin Manager

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Python plugins in QGIS_PLUGINPATH not appearing in Plugin Manager

Lauri Kajan
Hi,

I'm developing a python plugin and I found a "bug" in Plugin Manager.
I found out that QGIS is not loading the plugin from QGIS_PLUGINPATH. That's because that plugin is not enabled and mentioned in QSettings().
The actual problem is that plugins in QGIS_PLUGINPATH are not appearing in the Plugin Manager so those cannot be enabled.

Do you confirm this? Do I file a bug report?


I managed to get my plugin loaded when I manually added the needed setting in windows registry.


BR,

Lauri

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Python plugins in QGIS_PLUGINPATH not appearing in Plugin Manager

Régis Haubourg
Hi all,
we encounter that bug. It is a blocker to me.for 2.0
Has anyone solved it or should we file a bug?
Reply | Threaded
Open this post in threaded view
|

Re: Python plugins in QGIS_PLUGINPATH not appearing in Plugin Manager

Régis Haubourg
This seems to be urgent,
bug filed here:
http://hub.qgis.org/issues/8376

Cheers
Régis
Reply | Threaded
Open this post in threaded view
|

Re: Python plugins in QGIS_PLUGINPATH not appearing in Plugin Manager

Borys Jurgiel-4
Fixed, thanks!

Dnia poniedziałek, 29 lipca 2013 o 15:03:32 Régis Haubourg napisał(a):
> This seems to be urgent,
> bug filed here:
> http://hub.qgis.org/issues/8376 <http://hub.qgis.org/issues/8376>
> Cheers
> Régis
>
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer