[PyWPS-dev] Response document of a stored job is not updated (pywps 4.2)

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[PyWPS-dev] Response document of a stored job is not updated (pywps 4.2)

ddallery
Hello devs,

I make a asynchronous process that works perfectly when the job is alone (parallelprocesses=1). So, to test the maxprocesses=10, i send two requests to my server. The second job is stored and a document has built. But, when the first job is finished and the second is released, the document response of second wasn't updated, but the database sqlite and log file are updated and files are produced in work directory. The response document remains stuck with <wps:ProcessAccepted percentCompleted="0">PyWPS Process waterFlowSimulation accepted</wps:ProcessAccepted>.

I don't understand the problem because the response document of the first job is updated <wps:ProcessSucceeded>PyWPS Process Estimation  waterFlowSimulation finished</wps:ProcessSucceeded>.

Do you have any idea where the problem may come from ? Does the PyWPS 4.2.1 has a problem with stored job in async process ?
If you need information about code or logs, I can give you them.

Thanks,
Donatien

_______________________________________________
pywps-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/pywps-dev
Reply | Threaded
Open this post in threaded view
|

Re: Response document of a stored job is not updated (pywps 4.2)

Carsten Ehbrecht-3
Hi Donatien,

This might be an issue. Would like to open an issue on GitHub?

My guessing is, we can’t fix this for sqlite. But I have made a quick check with one of my PyWPS services using a Postgres DB and it looks the “queueing” is also not working as expected.

Thanks,
Carsten

On 21 Jan 2019, at 4:17 pm, Donatien Dallery <[hidden email]> wrote:

Hello devs,

I make a asynchronous process that works perfectly when the job is alone (parallelprocesses=1). So, to test the maxprocesses=10, i send two requests to my server. The second job is stored and a document has built. But, when the first job is finished and the second is released, the document response of second wasn't updated, but the database sqlite and log file are updated and files are produced in work directory. The response document remains stuck with <wps:ProcessAccepted percentCompleted="0">PyWPS Process waterFlowSimulation accepted</wps:ProcessAccepted>.

I don't understand the problem because the response document of the first job is updated <wps:ProcessSucceeded>PyWPS Process Estimation  waterFlowSimulation finished</wps:ProcessSucceeded>.

Do you have any idea where the problem may come from ? Does the PyWPS 4.2.1 has a problem with stored job in async process ?
If you need information about code or logs, I can give you them.

Thanks,
Donatien
_______________________________________________
pywps-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/pywps-dev


_______________________________________________
pywps-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/pywps-dev

smime.p7s (6K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Response document of a stored job is not updated (pywps 4.2)

ddallery
Hi Carsten,

Thanks for your investigation, I'll open an issue on GitHub to inform people about this problem.

Thanks,
Donatien

Le mercredi 23 janvier 2019 à 18:05:30 UTC+1, Carsten Ehbrecht <[hidden email]> a écrit :


Hi Donatien,

This might be an issue. Would like to open an issue on GitHub?

My guessing is, we can’t fix this for sqlite. But I have made a quick check with one of my PyWPS services using a Postgres DB and it looks the “queueing” is also not working as expected.

Thanks,
Carsten

On 21 Jan 2019, at 4:17 pm, Donatien Dallery <[hidden email]> wrote:

Hello devs,

I make a asynchronous process that works perfectly when the job is alone (parallelprocesses=1). So, to test the maxprocesses=10, i send two requests to my server. The second job is stored and a document has built. But, when the first job is finished and the second is released, the document response of second wasn't updated, but the database sqlite and log file are updated and files are produced in work directory. The response document remains stuck with <wps:ProcessAccepted percentCompleted="0">PyWPS Process waterFlowSimulation accepted</wps:ProcessAccepted>.

I don't understand the problem because the response document of the first job is updated <wps:ProcessSucceeded>PyWPS Process Estimation  waterFlowSimulation finished</wps:ProcessSucceeded>.

Do you have any idea where the problem may come from ? Does the PyWPS 4.2.1 has a problem with stored job in async process ?
If you need information about code or logs, I can give you them.

Thanks,
Donatien
_______________________________________________
pywps-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/pywps-dev


_______________________________________________
pywps-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/pywps-dev