Publicar shp no Geoserver

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Publicar shp no Geoserver

Pedro Henriques-2

Bom dia,
Estou a tentar publicar uma shape file no Geoserver e não estou a conseguir...cada que faço a layer preview 
nas open layers, cria me um ficheiro wms e não consigo visualizar.

As shapes que já existem por defeito no data dir do opengeo, consigo visualizar sem problema, as que eu adiciono..nada...



_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal
Reply | Threaded
Open this post in threaded view
|

Re: Publicar shp no Geoserver

Miguel Torres
O ficheiro WMS diz qual o erro. Envia o que está lá escrito.

No dia 2 de Março de 2012 11:42, Pedro Henriques <[hidden email]> escreveu:

Bom dia,
Estou a tentar publicar uma shape file no Geoserver e não estou a conseguir...cada que faço a layer preview 
nas open layers, cria me um ficheiro wms e não consigo visualizar.

As shapes que já existem por defeito no data dir do opengeo, consigo visualizar sem problema, as que eu adiciono..nada...



_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal



_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal
Reply | Threaded
Open this post in threaded view
|

Re: Publicar shp no Geoserver

Pedro Henriques-2
Aparece esta mensagem:

<?xml version="1.0" encoding="UTF-8" standalone="no"?><!DOCTYPE ServiceExceptionReport SYSTEM 

"http://localhost:8080/geoserver/schemas/wms/1.1.1/WMS_exception_1_1_1.dtd"> <ServiceExceptionReport version="1.1.1" >   <ServiceException>

      The requested Style can not be used with this layer.  The style specifies an attribute of iso2 and the layer is: Arqueosig:Cartograma25k_sde_Project
</ServiceException></ServiceExceptionReport>



No dia 2 de Março de 2012 12:05, Miguel Torres <[hidden email]> escreveu:
O ficheiro WMS diz qual o erro. Envia o que está lá escrito.

No dia 2 de Março de 2012 11:42, Pedro Henriques <[hidden email]> escreveu:

Bom dia,
Estou a tentar publicar uma shape file no Geoserver e não estou a conseguir...cada que faço a layer preview 
nas open layers, cria me um ficheiro wms e não consigo visualizar.

As shapes que já existem por defeito no data dir do opengeo, consigo visualizar sem problema, as que eu adiciono..nada...



_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal



_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal




--


Pedro Henriques


_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal
Reply | Threaded
Open this post in threaded view
|

Re: Publicar shp no Geoserver

pedrocostaarma
Em 02-03-2012 14:08, Pedro Henriques escreveu:
  The requested Style can not be used with this layer.
Provavelmente é um erro com o estilo associado

_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal
Reply | Threaded
Open this post in threaded view
|

Re: Publicar shp no Geoserver

Luís de Sousa
Pedro,

A mensagem é bem explícita (para quem conhece o Geoserver), o estilo
está a usar o atributo "iso2" mas pelos visto esse tema não tem tal
atributo. Verifica o nome correcto do atributo no tema e depois o muda
o estilo de acordo.

Boa sorte,

Luís
_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal
Reply | Threaded
Open this post in threaded view
|

Re: Publicar shp no Geoserver

Miguel Torres
Atençao que é case sensitive!

No dia 2 de Março de 2012 15:00, Luís de Sousa <[hidden email]> escreveu:
Pedro,

A mensagem é bem explícita (para quem conhece o Geoserver), o estilo
está a usar o atributo "iso2" mas pelos visto esse tema não tem tal
atributo. Verifica o nome correcto do atributo no tema e depois o muda
o estilo de acordo.

Boa sorte,

Luís
_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal


_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal
Reply | Threaded
Open this post in threaded view
|

Re: Publicar shp no Geoserver

pmgmendes
As referências a atributos de FeatureTypes deve ser sempre em maísculas. Exemplo:

<PropertyName>ISO2</PropertyName>

2012/3/2 Miguel Torres <[hidden email]>
Atençao que é case sensitive!

No dia 2 de Março de 2012 15:00, Luís de Sousa <[hidden email]> escreveu:

Pedro,

A mensagem é bem explícita (para quem conhece o Geoserver), o estilo
está a usar o atributo "iso2" mas pelos visto esse tema não tem tal
atributo. Verifica o nome correcto do atributo no tema e depois o muda
o estilo de acordo.

Boa sorte,

Luís
_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal


_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal



_______________________________________________
Portugal mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/portugal