Projection problems using Mapserver 4.6

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Projection problems using Mapserver 4.6

VictoriaH
Hello,

I am using Mapserver 4.6 and Proj 4.4.7 on Fedora Core 3. I am using a
map file where map and layer projections are defined as:
 
 PROJECTION
   "init=epsg:4326"
 END
 
 My WMS GetMap requests look like this:
 

http://falstaff.unm.edu/cgi-bin/mapserv?
map=reason/dream_map.map&VERSION=1.1.1&REQUEST=GetMap&BBox=-120.000,26.000,-97.000,44.000&SRS=EPSG:4326&Width=570&Height=446.086956522&Layers=GRASS_SHADED_RELIEF
 
 And, regardless of which map layer I call, I get the following error.
 

 msProcessProjection(): Projection library error. projection not named
 
 I would much appreciate any enlightenment!
 
 Thanks, Bill




_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj
Reply | Threaded
Open this post in threaded view
|

Re: Projection problems using Mapserver 4.6

Frank Warmerdam
On 10/26/05, William Hudspeth <[hidden email]> wrote:

> Hello,
>
> I am using Mapserver 4.6 and Proj 4.4.7 on Fedora Core 3. I am using a
> map file where map and layer projections are defined as:
>
>  PROJECTION
>    "init=epsg:4326"
>  END
>
>  My WMS GetMap requests look like this:
>
>
> http://falstaff.unm.edu/cgi-bin/mapserv?
> map=reason/dream_map.map&VERSION=1.1.1&REQUEST=GetMap&BBox=-120.000,26.000,-97.000,44.000&SRS=EPSG:4326&Width=570&Height=446.086956522&Layers=GRASS_SHADED_RELIEF
>
>  And, regardless of which map layer I call, I get the following error.
>
>
>  msProcessProjection(): Projection library error. projection not named
>
>  I would much appreciate any enlightenment!

Bill,

My guess is that the projection initialization file is not being
found.  Where is your "epsg" file?  On unix it would normally
be in /usr/local/share/proj or perhaps /usr/share/proj.  You
might try setting the PROJ_LIB environment variable to point
to the appropriate directory and see if that helps.

Other than that, I would suggest upgrading to PROJ 4.4.9
though I can't immediately think of any reason that should be
necessary.

Best regards,
--
---------------------------------------+--------------------------------------
I set the clouds in motion - turn up   | Frank Warmerdam, [hidden email]
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | Geospatial Programmer for Rent

_______________________________________________
Proj mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/proj