[Processing] - error in "get models from on-line scripts collection"

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[Processing] - error in "get models from on-line scripts collection"

Stefano Campus
hi,
i get this error when i try to launh this module:


An error has occured while executing Python code:


Traceback (most recent call last):
  File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\ProcessingToolbox.py", line 214, in executeAlgorithm
    action.execute()
  File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py", line 77, in execute
    dlg = GetScriptsAndModelsDialog(GetScriptsAndModelsDialog.MODELS)
  File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py", line 124, in __init__
    self.populateTree()
  File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py", line 140, in populateTree
    resources = readUrl(self.urlBase + 'list.txt').splitlines()
  File "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py", line 90, in readUrl
    return urllib2.urlopen(url).read()
  File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 127, in urlopen
    return _opener.open(url, data, timeout)
  File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 404, in open
    response = self._open(req, data)
  File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 422, in _open
    '_open', req)
  File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 382, in _call_chain
    result = func(*args)
  File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 1222, in https_open
    return self.do_open(httplib.HTTPSConnection, req)
  File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 1184, in do_open
    raise URLError(err)
URLError:


Python version:
2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]


QGIS version:
2.7.0-Master Master, 0b9e1f6
Reply | Threaded
Open this post in threaded view
|

Re: [Processing] - error in "get models from on-line scripts collection"

volaya
hmm, strange

It basically tries to get the content from
https://raw.githubusercontent.com/qgis/QGIS-Processing/master/models/list.txt,
but in your case it seems to be failing...

Any additional info you can provide about your system?

Thanks!

2014-11-17 13:22 GMT+01:00 skampus <[hidden email]>:

> hi,
> i get this error when i try to launh this module:
>
>
> An error has occured while executing Python code:
>
>
> Traceback (most recent call last):
>   File
> "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\ProcessingToolbox.py",
> line 214, in executeAlgorithm
>     action.execute()
>   File
> "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py",
> line 77, in execute
>     dlg = GetScriptsAndModelsDialog(GetScriptsAndModelsDialog.MODELS)
>   File
> "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py",
> line 124, in __init__
>     self.populateTree()
>   File
> "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py",
> line 140, in populateTree
>     resources = readUrl(self.urlBase + 'list.txt').splitlines()
>   File
> "C:/OSGeo4W/apps/qgis-dev/./python/plugins\processing\gui\GetScriptsAndModels.py",
> line 90, in readUrl
>     return urllib2.urlopen(url).read()
>   File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 127, in urlopen
>     return _opener.open(url, data, timeout)
>   File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 404, in open
>     response = self._open(req, data)
>   File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 422, in _open
>     '_open', req)
>   File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 382, in _call_chain
>     result = func(*args)
>   File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 1222, in https_open
>     return self.do_open(httplib.HTTPSConnection, req)
>   File "C:\OSGeo4W\apps\Python27\lib\urllib2.py", line 1184, in do_open
>     raise URLError(err)
> URLError:
>
>
> Python version:
> 2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]
>
>
> QGIS version:
> 2.7.0-Master Master, 0b9e1f6
>
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/Processing-error-in-get-models-from-on-line-scripts-collection-tp5173288.html
> Sent from the Quantum GIS - Developer mailing list archive at Nabble.com.
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: [Processing] - error in "get models from on-line scripts collection"

Stefano Campus
hi victor,
i'm on win8 64 under proxy, but all operations that need internet connection are working, like wms, plugins installations ecc.

qgis installation is 32

thank you

s.