Problems with base layers.

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems with base layers.

maherich

Hi all,

We have one project on MapGuide where we use more base layers. We have found 2 problems that occurs in Fusion client.

  1. It looks like there is some problem with the order of base layers. We have 3 base layers - Plan, Parcels_1, Parcels_2 (defined in this order). But they are displayed in following order Parcels_2, Plan, Parcels_1 (Parcels_2 are on the top). Why it’s not in the correct order?
  2. In Fusion we have multiple maps, that we can switch using the Menu item “Maps”. The both maps consist only of base layers. If we switch to another map, the base layers from previous map are still loading, even though they are not defined for the new map. If the maps don’t contain base layers, the switch works correctly. What should we do so that it works correctly also with base layers?

We use MapGuide Version 2.6.

We have tested this project also on Version 3.0 with the same results.

Martin


_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems with base layers.

maherich
Hi any solution to this? Specially point 2?
It looks like the Fusion has a couple of problems that prevent us from using it in this scenario?
What other clients would you suggest?
Martin
Reply | Threaded
Open this post in threaded view
|

Re: Problems with base layers.

RenoSun
This post was updated on .
Hi Martin,

Same here with AIMS 2014. I noticed that when I switched the map by using Map Fusion.Widget.MapMenu, somehow the Fusion was still trying to load every maps that I switched to as basemaps, and also the Base Layers from previous maps.

I switched to three different maps, and Fusion request the single tiles of every map that I switched to all the time.

Header
Header
Cookies - PHPSESSID
Cookies - PHPSESSID
Property Map - Initial Map of Fusion
Property Map - Initial Map of Fusion
Utility Map - One of the maps of Fusion
Utility Map - One of the maps of Fusion
Recreation Map - One of the maps of Fusion
Recreation Map - One of the maps of Fusion

I will keep digging for solutions, but hope others may find the solutions for this problem too.

Cheers

Reply | Threaded
Open this post in threaded view
|

RE: Problems with base layers.

maherich

Hi,

We didn’t dig very deep into it as we didn’t have so much time. What we did is that we created two maps:

1.       One for public where we put all the layers into one Basemap that is not transparent. So even though the previous maps are loaded after switching the map they are displayed under the map that is selected J. Of course this is only a hack and not a solution. And we transfer lot more data as needed.

2.       Second map for authorities. In this map we use no Base Layers anymore. It is not so fast, but there is no problem with switching of maps.

Thank you for your input. If you find any solution, we will very appreciate it.

Martin

 

From: RenoSun [via OSGeo.org] [mailto:ml-node+[hidden email]]
Sent: Monday, December 19, 2016 9:17 PM
To: Martin Herich <[hidden email]>
Subject: Re: Problems with base layers.

 

Hi Martin,

Same here with AIMS 2014. I noticed that when I switched the map by using Map Fusion.Widget.MapMenu, somehow the Fusion was still trying to load every maps that I switched to as basemaps, and also the Base Layers from previous maps.

I switched to three different maps, and Fusion request the single tiles of every map that I switched to all the time.

Header
Cookies - PHPSESSID
Property Map - Initial Map of Fusion
Utility Map - One of the maps of Fusion
Recreation Map - One of the maps of Fusion

I will keep digging for solutions, but hope others may find the solutions for this problem too.

Cheers



If you reply to this email, your message will be added to the discussion below:

http://osgeo-org.1560.x6.nabble.com/Problems-with-base-layers-tp5298092p5300545.html

To start a new topic under MapGuide Users, email [hidden email]
To unsubscribe from Problems with base layers., click here.
NAML

Reply | Threaded
Open this post in threaded view
|

RE: Problems with base layers.

RenoSun
Hi Martin,

I actually tried the method you mentioned before.

My temporary solution is to put only one map on each fusion layout, and I switch fusion layout by calling fusion through iframe.

However, if you would like to see the same extent, you will have to customize FusionSF.js to achieve that.

It's on our public GIS :)
Property Map

Will let you know if I find a real solution for this issue.

Cheers,
Reno
Reply | Threaded
Open this post in threaded view
|

Re: Problems with base layers.

GordonL
In reply to this post by maherich
Yes, this is common, especially when you combine Base Layers with Tiled Layers.

Have you found a work-around yet?

I am looking to re-work the OpenLayers layers (visible and display order) to work around this bug ...

gordon
Reply | Threaded
Open this post in threaded view
|

Re: Problems with base layers.

Henning van Wyk
Good Day Gordon,

No have not found a way around it.
I see the township layer works but none of the other like erf size, house nr, erf nr.
Also if you select arial image you cannot use the search function with layers.

Thank you for the feedback.

Regards,
Henning

> On 13 Jul 2017, at 3:11 PM, GordonL <[hidden email]> wrote:
>
> Yes, this is common, especially when you combine Base Layers with Tiled
> Layers.
>
> Have you found a work-around yet?
>
> I am looking to re-work the OpenLayers layers (visible and display order) to
> work around this bug ...
>
> gordon
>
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.nabble.com/Problems-with-base-layers-tp5298092p5327781.html
> Sent from the MapGuide Users mailing list archive at Nabble.com.
> _______________________________________________
> mapguide-users mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapguide-users

_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users