Problems with Label (TextSymbolizer)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems with Label (TextSymbolizer)

dblasby
Ben,

1. You can use different fonts - I've done this quite a bit.  You can
even just specifically reference a font (.ttf) file directly like this:
<Font>
        <CssParameter
name="font-family">/usr/local/share/fonts/truetype/esri_4.ttf</CssParameter>
        <CssParameter name="font-style">Normal</CssParameter>
        <CssParameter name="font-size">16</CssParameter>
</Font>

(use c:\... if you are using windows)

Here's an example using a named font:
<Font>
        <CssParameter name="font-family">Times New Roman</CssParameter>
        <CssParameter name="font-style">Normal</CssParameter>
        <CssParameter name="font-size">14</CssParameter>
        <CssParameter name="font-weight">bold</CssParameter>
</Font>


2. The labeling algorithms need work.  I've had lots of discussions on
the geotools and udig list about this.

dave




----------------------------------------------------------
This mail sent through IMP: https://webmail.limegroup.com/


-------------------------------------------------------
SF.Net email is sponsored by: Discover Easy Linux Migration Strategies
from IBM. Find simple to follow Roadmaps, straightforward articles,
informative Webcasts and more! Get everything you need to get up to
speed, fast. http://ads.osdn.com/?ad_id=7477&alloc_id=16492&op=click
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users