Problems with Image Mosaic

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems with Image Mosaic

big_z
I've been trying to solve this for a week now.

I've downloaded NASA's 500m Blue Marble imagery (July 2004 with bathymetry, to be specific).  NASA distributes them in 8 PNG tiles with no world files or anything else.  I used a site online ( http://egb13.net/2009/03/worldfile-calculator/ ) to calculate world files for each tile based on their coordinates, 500m/pixel, and their size of 21600x21600 px.  Then I swiped the projection file from the mosaic demo and copied it for each tile:
GEOGCS["WGS 84",
  DATUM["World Geodetic System 1984",
    SPHEROID["WGS 84", 6378137.0, 298.257223563, AUTHORITY["EPSG","7030"]],
    AUTHORITY["EPSG","6326"]],
  PRIMEM["Greenwich", 0.0, AUTHORITY["EPSG","8901"]],
  UNIT["degree", 0.017453292519943295],
  AXIS["Geodetic longitude", EAST],
  AXIS["Geodetic latitude", NORTH],
  AUTHORITY["EPSG","4326"]]

I used gdal_translate to make tiled compressed (deflate) geotiffs with the -a_srs "EPSG:4326" option.  Then I made external compressed overviews at 2,4,8,16 levels with gdaladdo.  Then I made a tile index with gdaltindex.  

When I try to create a layer using this new shapefile, I get the "Could not list layers for this store, an error occurred retrieving them: Unable to acquire test coverage for format:ImageMosaic" error.  I can add each of the geotiffs as individual layers and create a layer group out of them with no problem; the coordinates are right and everything.  The mosaic won't take it though.

I'm running the latest Geoserver on Tomcat6 on Ubuntu Natty; GDAL version 1.6.something.  I know about the memory leak listener/JAI issue; I tried the "copy imageio and jai jars to tomcat/shared/lib" solution but that prevented Geoserver from even deploying, so I turned off that leak listener in the xml file instead.  

I had used Mapserver in a previous job with the above technique and it worked like a charm.  I've been curious about Geoserver for a long time, even tried it out for that job but was never able to solve this issue.  

Can someone help me?