Problems opening sqlite files in 3.2.2 through Spatialite connection.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems opening sqlite files in 3.2.2 through Spatialite connection.

b.j.kobben

Hi all,

 

In QGIS 3.2.2, when trying to open the NaturalEarthData .sqlite file from the file-browser or by right-clicking in the Finder (Mac OSX ) it works fine.

 

But through  Add Layer > Add spatialite layer, using Connect to the same file I get an error :

 

Failure getting table metadata... is /Users/barendkobben/Documents/GEOBASEFILES/world/Natural Earth 4.1/natural_earth_vector.sqlite really a SpatiaLite database?

 

Is this expected, or specific for my platform? Should I file a bug...?

 

Yours,

--

Barend Köbben

Senior Lecturer – ITC-University of Twente & ATLAS

PO Box 217, 7500 AE Enschede (Netherlands)

ITC Building (room 1-065)

@barendkobben

+31-(0)53 4874 253

 

 


_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
DT
Reply | Threaded
Open this post in threaded view
|

Re: Problems opening sqlite files in 3.2.2 through Spatialite connection.

DT
OSX 10.13.6
QGIS 3.2.1

Not sure if it's a platform thing, but I can confirm that using Add Layer > Add spatialite layer errors out.  But dragging the file into QGIS or using the File Browser will get you a layer selection prompt and correctly load the layer.

DT

On Thu, Sep 13, 2018 at 10:26 AM <[hidden email]> wrote:

Hi all,

 

In QGIS 3.2.2, when trying to open the NaturalEarthData .sqlite file from the file-browser or by right-clicking in the Finder (Mac OSX ) it works fine.

 

But through  Add Layer > Add spatialite layer, using Connect to the same file I get an error :

 

Failure getting table metadata... is /Users/barendkobben/Documents/GEOBASEFILES/world/Natural Earth 4.1/natural_earth_vector.sqlite really a SpatiaLite database?

 

Is this expected, or specific for my platform? Should I file a bug...?

 

Yours,

--

Barend Köbben

Senior Lecturer – ITC-University of Twente & ATLAS

PO Box 217, 7500 AE Enschede (Netherlands)

ITC Building (room 1-065)

@barendkobben

+31-(0)53 4874 253

 

 

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user