Problems deploying on Tomcat 6

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Problems deploying on Tomcat 6

Erik Näsström
Hello everyone

I'm trying to get geoserver deployed on the same tomcat install that I have CMDBuild on but I've run into some problems.
I put the war file in the webapps folder and it extracts the geoserver folder correctly, but when I go to server:8181/geoserver I get a message that the service is not available.
In the tomcat manager I can't see the geoserver instance either so I think something must have one wrong, I've tried stopping the service and deleting the file and the folder and doing it again but to the same result

Anyone have some ideas?

Best Regards
Erik
--

 
Erik Näsström

IT-Ansvarig, Datakunskap, I&L, Webbdesign
Work: +46 (0)470 74 21 84
Mobile: +46 (0)731 52 47 42
[hidden email]


Följ oss på Sociala Medier

        


------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

Stefano Iacovella

2014-10-08 13:18 GMT+02:00 Erik Näsström <[hidden email]>:
Anyone have some ideas?

Did you already check for the logs in CATALINA_HOME/logs ?
If, as I guess, the deploy failed something should be output in stderr

Cheers,

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

Erik Näsström
Hi Stefano

Didn't think of checking there earlier, not that used to running a server like this. Looked at them now tough and found this part regarding geoserver. Anyone know what Unsupported major.minor version 51.0 (unable to load class org.geoserver.GeoserverInitStartupListener)  means?

Best Regards
Erik

<---- From the logs---->


INFO: Deploying web application archive geoserver.war
2014-okt-08 07:44:50 org.apache.tomcat.util.modeler.Registry registerComponent
ALLVARLIG: Null component Catalina:type=JspMonitor,name=jsp,WebModule=//localhost/geoserver,J2EEApplication=none,J2EEServer=none
2014-okt-08 07:44:50 org.apache.catalina.startup.HostConfig deployWAR
ALLVARLIG: Error deploying web application archive geoserver.war
java.lang.UnsupportedClassVersionError: org/geoserver/GeoserverInitStartupListener : Unsupported major.minor version 51.0 (unable to load class org.geoserver.GeoserverInitStartupListener)
at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2858)
at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1159)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1647)
at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1526)
at org.apache.catalina.startup.WebAnnotationSet.loadClassAnnotation(WebAnnotationSet.java:145)
at org.apache.catalina.startup.WebAnnotationSet.loadApplicationListenerAnnotations(WebAnnotationSet.java:73)
at org.apache.catalina.startup.WebAnnotationSet.loadApplicationAnnotations(WebAnnotationSet.java:56)
at org.apache.catalina.startup.ContextConfig.applicationAnnotationsConfig(ContextConfig.java:294)
at org.apache.catalina.startup.ContextConfig.start(ContextConfig.java:1047)
at org.apache.catalina.startup.ContextConfig.lifecycleEvent(ContextConfig.java:265)
at org.apache.catalina.util.LifecycleSupport.fireLifecycleEvent(LifecycleSupport.java:142)
at org.apache.catalina.core.StandardContext.start(StandardContext.java:4616)
at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:799)
at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:779)
at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:583)
at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:943)
at org.apache.catalina.startup.HostConfig.deployApps(HostConfig.java:563)
at org.apache.catalina.startup.HostConfig.check(HostConfig.java:1399)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.apache.tomcat.util.modeler.BaseModelMBean.invoke(BaseModelMBean.java:297)
at com.sun.jmx.interceptor.DefaultMBeanServerInterceptor.invoke(Unknown Source)
at com.sun.jmx.mbeanserver.JmxMBeanServer.invoke(Unknown Source)
at org.apache.catalina.manager.ManagerServlet.check(ManagerServlet.java:1500)
at org.apache.catalina.manager.HTMLManagerServlet.doPost(HTMLManagerServlet.java:252)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:643)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:723)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.filters.CsrfPreventionFilter.doFilter(CsrfPreventionFilter.java:194)
at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235)
at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233)
at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:191)
at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:563)
at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:103)
at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:293)
at org.apache.coyote.http11.Http11AprProcessor.process(Http11AprProcessor.java:879)
at org.apache.coyote.http11.Http11AprProtocol$Http11ConnectionHandler.process(Http11AprProtocol.java:617)
at org.apache.tomcat.util.net.AprEndpoint$Worker.run(AprEndpoint.java:1774)
at java.lang.Thread.run(Unknown Source)

2014-10-08 14:57 GMT+02:00 Stefano Iacovella <[hidden email]>:

2014-10-08 13:18 GMT+02:00 Erik Näsström <[hidden email]>:
Anyone have some ideas?

Did you already check for the logs in CATALINA_HOME/logs ?
If, as I guess, the deploy failed something should be output in stderr

Cheers,

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas



--

 
Erik Näsström

IT-Ansvarig, Datakunskap, I&L, Webbdesign
Work: +46 (0)470 74 21 84
Mobile: +46 (0)731 52 47 42
[hidden email]


Följ oss på Sociala Medier

        


------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

Stefano Iacovella

2014-10-08 15:44 GMT+02:00 Erik Näsström <[hidden email]>:
Hi Stefano

Didn't think of checking there earlier, not that used to running a server like this. Looked at them now tough and found this part regarding geoserver. Anyone know what Unsupported major.minor version 51.0 (unable to load class org.geoserver.GeoserverInitStartupListener)  means?

What JDK/JRE version are you using for running Tomcat?
And what GeoServer release did you deploy?
Mind that as for 2.6.0 the requirements is Java 7

Cheers

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas

------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

Erik Näsström
Java 7 update 67
Tomcat 6
Geoserver 2.6.0

I'll try and reinstall java and see if that helps


2014-10-08 15:48 GMT+02:00 Stefano Iacovella <[hidden email]>:

2014-10-08 15:44 GMT+02:00 Erik Näsström <[hidden email]>:
Hi Stefano

Didn't think of checking there earlier, not that used to running a server like this. Looked at them now tough and found this part regarding geoserver. Anyone know what Unsupported major.minor version 51.0 (unable to load class org.geoserver.GeoserverInitStartupListener)  means?

What JDK/JRE version are you using for running Tomcat?
And what GeoServer release did you deploy?
Mind that as for 2.6.0 the requirements is Java 7

Cheers

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas



--

 
Erik Näsström

IT-Ansvarig, Datakunskap, I&L, Webbdesign
Work: +46 (0)470 74 21 84
Mobile: +46 (0)731 52 47 42
[hidden email]


Följ oss på Sociala Medier

        


------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

Justin Deoliveira-6
The error indicates that you are running tomcat on an older version of Java, most likely Java 6. I would double check what version of java is actually being used to run Tomcat. What platform/os are you on?

On Wed, Oct 8, 2014 at 8:22 AM, Erik Näsström <[hidden email]> wrote:
Java 7 update 67
Tomcat 6
Geoserver 2.6.0

I'll try and reinstall java and see if that helps


2014-10-08 15:48 GMT+02:00 Stefano Iacovella <[hidden email]>:

2014-10-08 15:44 GMT+02:00 Erik Näsström <[hidden email]>:
Hi Stefano

Didn't think of checking there earlier, not that used to running a server like this. Looked at them now tough and found this part regarding geoserver. Anyone know what Unsupported major.minor version 51.0 (unable to load class org.geoserver.GeoserverInitStartupListener)  means?

What JDK/JRE version are you using for running Tomcat?
And what GeoServer release did you deploy?
Mind that as for 2.6.0 the requirements is Java 7

Cheers

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas



--

 
Erik Näsström

IT-Ansvarig, Datakunskap, I&L, Webbdesign
Work: <a href="tel:%2B46%20%280%29470%2074%2021%2084" value="+46470742184" target="_blank">+46 (0)470 74 21 84
Mobile: +46 (0)731 52 47 42
[hidden email]


Följ oss på Sociala Medier

        


------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users




--
Justin Deoliveira
VP Engineering | Boundless
[hidden email]
@boundlessgeo



------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

Erik Näsström
Ah indeed, it seems that CMDBuild that I'm running only can use Java 1.6 so that's the reason I get the problems. Will Geoserver 2.4.8 run on older java or do I have to go even further back?

2014-10-08 16:32 GMT+02:00 Justin Deoliveira <[hidden email]>:
The error indicates that you are running tomcat on an older version of Java, most likely Java 6. I would double check what version of java is actually being used to run Tomcat. What platform/os are you on?

On Wed, Oct 8, 2014 at 8:22 AM, Erik Näsström <[hidden email]> wrote:
Java 7 update 67
Tomcat 6
Geoserver 2.6.0

I'll try and reinstall java and see if that helps


2014-10-08 15:48 GMT+02:00 Stefano Iacovella <[hidden email]>:

2014-10-08 15:44 GMT+02:00 Erik Näsström <[hidden email]>:
Hi Stefano

Didn't think of checking there earlier, not that used to running a server like this. Looked at them now tough and found this part regarding geoserver. Anyone know what Unsupported major.minor version 51.0 (unable to load class org.geoserver.GeoserverInitStartupListener)  means?

What JDK/JRE version are you using for running Tomcat?
And what GeoServer release did you deploy?
Mind that as for 2.6.0 the requirements is Java 7

Cheers

Stefano

---------------------------------------------------
41.95581N 12.52854E


http://www.linkedin.com/in/stefanoiacovella

http://twitter.com/#!/Iacovellas



--

 
Erik Näsström

IT-Ansvarig, Datakunskap, I&L, Webbdesign
Work: <a href="tel:%2B46%20%280%29470%2074%2021%2084" value="+46470742184" target="_blank">+46 (0)470 74 21 84
Mobile: +46 (0)731 52 47 42
[hidden email]


Följ oss på Sociala Medier

        


------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users




--
Justin Deoliveira
VP Engineering | Boundless
[hidden email]
@boundlessgeo





--

 
Erik Näsström

IT-Ansvarig, Datakunskap, I&L, Webbdesign
Work: +46 (0)470 74 21 84
Mobile: +46 (0)731 52 47 42
[hidden email]


Följ oss på Sociala Medier

        


------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems deploying on Tomcat 6

geowolf
On Wed, Oct 8, 2014 at 7:17 PM, Erik Näsström <[hidden email]> wrote:
Ah indeed, it seems that CMDBuild that I'm running only can use Java 1.6 so that's the reason I get the problems. Will Geoserver 2.4.8 run on older java or do I have to go even further back?

The 2.5.x series is the last one supporting java 6, you should probably use that one, 2.4.x is no longer supported

Cheers
Andrea
--
==
GeoServer Professional Services from the experts! Visit
http://goo.gl/NWWaa2 for more information.
==

Ing. Andrea Aime 
@geowolf
Technical Lead

GeoSolutions S.A.S.
Via Poggio alle Viti 1187
55054  Massarosa (LU)
Italy
phone: +39 0584 962313
fax: +39 0584 1660272
mob: +39  339 8844549


AVVERTENZE AI SENSI DEL D.Lgs. 196/2003

Le informazioni contenute in questo messaggio di posta elettronica e/o nel/i file/s allegato/i sono da considerarsi strettamente riservate. Il loro utilizzo è consentito esclusivamente al destinatario del messaggio, per le finalità indicate nel messaggio stesso. Qualora riceviate questo messaggio senza esserne il destinatario, Vi preghiamo cortesemente di darcene notizia via e-mail e di procedere alla distruzione del messaggio stesso, cancellandolo dal Vostro sistema. Conservare il messaggio stesso, divulgarlo anche in parte, distribuirlo ad altri soggetti, copiarlo, od utilizzarlo per finalità diverse, costituisce comportamento contrario ai principi dettati dal D.Lgs. 196/2003.

 

The information in this message and/or attachments, is intended solely for the attention and use of the named addressee(s) and may be confidential or proprietary in nature or covered by the provisions of privacy act (Legislative Decree June, 30 2003, no.196 - Italy's New Data Protection Code).Any use not in accord with its purpose, any disclosure, reproduction, copying, distribution, or either dissemination, either whole or partial, is strictly forbidden except previous formal approval of the named addressee(s). If you are not the intended recipient, please contact immediately the sender by telephone, fax or e-mail and delete the information in this message that has been received in error. The sender does not give any warranty or accept liability as the content, accuracy or completeness of sent messages and accepts no responsibility  for changes made after they were sent or for other risks which arise as a result of e-mail transmission, viruses, etc.


-------------------------------------------------------

------------------------------------------------------------------------------
Meet PCI DSS 3.0 Compliance Requirements with EventLog Analyzer
Achieve PCI DSS 3.0 Compliant Status with Out-of-the-box PCI DSS Reports
Are you Audit-Ready for PCI DSS 3.0 Compliance? Download White paper
Comply to PCI DSS 3.0 Requirement 10 and 11.5 with EventLog Analyzer
http://pubads.g.doubleclick.net/gampad/clk?id=154622311&iu=/4140/ostg.clktrk
_______________________________________________
Geoserver-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geoserver-users