Problema al usar el plugin rt_mapserver_exporter-0.4.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema al usar el plugin rt_mapserver_exporter-0.4.0

Francisco D. Salas Rosette

Hola a todos ,

tengo instalado Qgis 2.8.2 en Windows 7 64bit , descargue recientemente el plugin para exportar a  mapserver,  “rt_mapserver_exporter-0.4.0”, cuando trato de usarlo me da este error :

****************************************************************

Ha ocurrido un error mientras se ejecutaba el código de Python:

Traceback (most recent call last):

  File "C:/PROGRA~2/QGISWI~1/apps/qgis/./python/plugins\rt_mapserver_exporter\plugin.py", line 65, in run

    from .mapfileexportdlg import MapfileExportDlg

  File "C:/PROGRA~2/QGISWI~1/apps/qgis/./python\qgis\utils.py", line 478, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

  File "C:/PROGRA~2/QGISWI~1/apps/qgis/./python/plugins\rt_mapserver_exporter\mapfileexportdlg.py", line 30, in

    import mapscript

  File "C:/PROGRA~2/QGISWI~1/apps/qgis/./python\qgis\utils.py", line 478, in _import

    mod = _builtin_import(name, globals, locals, fromlist, level)

ImportError: No module named mapscript

 

 

Versión de Python:

2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]

 

 

Versión de QGIS:

2.8.2-Wien Wien, 1b929ef

**************************************************

Seguí estas instrucciones para tratar de solucionarlo “Installing Python MapScript Bindings on Windows  y me sale este error

**********************************

python setup.py install

running install

running bdist_egg

running egg_info

writing requirements to mapscript.egg-info\requires.txt

writing mapscript.egg-info\PKG-INFO

writing top-level names to mapscript.egg-info\top_level.txt

writing dependency_links to mapscript.egg-info\dependency_links.txt

reading manifest file 'mapscript.egg-info\SOURCES.txt'

writing manifest file 'mapscript.egg-info\SOURCES.txt'

installing library code to build\bdist.win32\egg

running install_lib

running build_py

creating build

creating build\lib.win32-2.7

copying mapscript.py -> build\lib.win32-2.7

running build_ext

building '_mapscript' extension

error: Unable to find vcvarsall.bat

*************************

O sea es un problema detras de otro , ¿ Alguien puede orientarme como solucionar estos problemas?

 

Saludos

Francisco Salas

 

 


----------------------------------------------------------------------------------------------------
Anuncie sus servicios en ANDARIEGO… aplicación para celulares sobre mapas de toda Cuba.  
Visite el sitio http://andariego.geocuba.cu o http://www.andariego.cu, contáctenos por el correo [hidden email] o por el teléfono 8817400. 
Ponga su información al servicio de todos.




_______________________________________________
QGIS-es mailing list
[hidden email]
http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-es
Reply | Threaded
Open this post in threaded view
|

Re: Problema al usar el plugin rt_mapserver_exporter-0.4.0

ginetto
Hola Francisco...

1) estas mexclando las cosas... el entorno de instalación de QGIS
lleva consigo Python y no puede (en forma sencilla) mexclar el python
de Windows con el Python que usa QGIS

2) se instalaste QGIS con el Standalone installaer... tiralo y instala
QGIS con el OSGeo4W installer

3) desde el OSGeo installer (en el advanced configuration) puede
instalar mapscript (lo busca en el buscador del installer)
esto te instalera' mapscript en el sitio justo del python que lleva OSGeo4W

y ya esta'!

ciao
Luigi Pirelli

**************************************************************************************************
* LinkedIn: https://www.linkedin.com/in/luigipirelli
* Elance: https://www.elance.com/s/edit/luigipirelli/
* GitHub: https://github.com/luipir
* Stackexchange: http://gis.stackexchange.com/users/19667/luigi-pirelli
* Mastering QGIS:
https://www.packtpub.com/application-development/mastering-qgis
**************************************************************************************************


On 8 July 2015 at 17:28, Francisco Salas Rosette
<[hidden email]> wrote:

> Hola a todos ,
>
> tengo instalado Qgis 2.8.2 en Windows 7 64bit , descargue recientemente el
> plugin para exportar a  mapserver,  “rt_mapserver_exporter-0.4.0”, cuando
> trato de usarlo me da este error :
>
> ****************************************************************
>
> Ha ocurrido un error mientras se ejecutaba el código de Python:
>
> Traceback (most recent call last):
>
>   File
> "C:/PROGRA~2/QGISWI~1/apps/qgis/./python/plugins\rt_mapserver_exporter\plugin.py",
> line 65, in run
>
>     from .mapfileexportdlg import MapfileExportDlg
>
>   File "C:/PROGRA~2/QGISWI~1/apps/qgis/./python\qgis\utils.py", line 478, in
> _import
>
>     mod = _builtin_import(name, globals, locals, fromlist, level)
>
>   File
> "C:/PROGRA~2/QGISWI~1/apps/qgis/./python/plugins\rt_mapserver_exporter\mapfileexportdlg.py",
> line 30, in
>
>     import mapscript
>
>   File "C:/PROGRA~2/QGISWI~1/apps/qgis/./python\qgis\utils.py", line 478, in
> _import
>
>     mod = _builtin_import(name, globals, locals, fromlist, level)
>
> ImportError: No module named mapscript
>
>
>
>
>
> Versión de Python:
>
> 2.7.4 (default, Apr  6 2013, 19:54:46) [MSC v.1500 32 bit (Intel)]
>
>
>
>
>
> Versión de QGIS:
>
> 2.8.2-Wien Wien, 1b929ef
>
> **************************************************
>
> Seguí estas instrucciones para tratar de solucionarlo “Installing Python
> MapScript Bindings on Windows”  y me sale este error
>
> **********************************
>
> python setup.py install
>
> running install
>
> running bdist_egg
>
> running egg_info
>
> writing requirements to mapscript.egg-info\requires.txt
>
> writing mapscript.egg-info\PKG-INFO
>
> writing top-level names to mapscript.egg-info\top_level.txt
>
> writing dependency_links to mapscript.egg-info\dependency_links.txt
>
> reading manifest file 'mapscript.egg-info\SOURCES.txt'
>
> writing manifest file 'mapscript.egg-info\SOURCES.txt'
>
> installing library code to build\bdist.win32\egg
>
> running install_lib
>
> running build_py
>
> creating build
>
> creating build\lib.win32-2.7
>
> copying mapscript.py -> build\lib.win32-2.7
>
> running build_ext
>
> building '_mapscript' extension
>
> error: Unable to find vcvarsall.bat
>
> *************************
>
> O sea es un problema detras de otro , ¿ Alguien puede orientarme como
> solucionar estos problemas?
>
>
>
> Saludos
>
> Francisco Salas
>
>
>
>
>
>
> ----------------------------------------------------------------------------------------------------
> Anuncie sus servicios en ANDARIEGO… aplicación para celulares sobre mapas de
> toda Cuba.
> Visite el sitio http://andariego.geocuba.cu o http://www.andariego.cu,
> contáctenos por el correo [hidden email] o por el teléfono
> 8817400.
> Ponga su información al servicio de todos.
>
>
>
>
> _______________________________________________
> QGIS-es mailing list
> [hidden email]
> http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-es
>
_______________________________________________
QGIS-es mailing list
[hidden email]
http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-es