Problema al cargar leyenda

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problema al cargar leyenda

Alex Irmel Oviedo Solis
Buenos dias, estoy cargando leyendas desde un archivo gvsleg pero tengo una leyenda que no puedo cargar y me sale este error:
----
Caused by: java.lang.ClassCastException: org.gvsig.symbology.fmap.rendering.VectorFilterExpressionLegend cannot be cast to org.gvsig.symbology.fmap.mapcontext.rendering.legend.impl.SingleSymbolLegend
----

Claramente es un problema de dependencias que no logro encontrar,¿que paquete es el que tendria que agregar a mi pom para que me pueda compilar esto?

Saludos y gracias de antemano

_______________________________________________
gvSIG_desarrolladores mailing list
[hidden email]
Para ver histórico de mensajes, editar sus preferencias de usuario o darse de baja en esta lista, acuda a la siguiente dirección: https://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_desarrolladores
Reply | Threaded
Open this post in threaded view
|

Re: Problema al cargar leyenda

Joaquin Jose del Cerro Murciano


El 19 de mayo de 2017, 18:14, Alex Irmel Oviedo Solis <[hidden email]> escribió:
Buenos dias, estoy cargando leyendas desde un archivo gvsleg pero tengo una leyenda que no puedo cargar y me sale este error:
----
Caused by: java.lang.ClassCastException: org.gvsig.symbology.fmap.rendering.VectorFilterExpressionLegend cannot be cast to org.gvsig.symbology.fmap.mapcontext.rendering.legend.impl.SingleSymbolLegend
----

Claramente es un problema de dependencias que no logro encontrar,¿que paquete es el que tendria que agregar a mi pom para que me pueda compilar esto?


No tiene pinta de ser un problema de dependencias.
Necesitaria ver el stack completo del error, pero yo apuntaria hacia que estas cargando un leyenda de una capa de un tipo, sobre otra capa que no acepta ese tipo de leyenda.
Tambien podria ser que no tienes cargada en gvSIG el plugin que aporta el tipo de leyenda que estas instentando cargar.
Aunque lo dicho, es stack, o el log completo mejor, ayudaria bastante.

Un saludo
Joaquin

Saludos y gracias de antemano

_______________________________________________
gvSIG_desarrolladores mailing list
[hidden email]
Para ver histórico de mensajes, editar sus preferencias de usuario o darse de baja en esta lista, acuda a la siguiente dirección: https://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_desarrolladores




--
--------------------------------------
Joaquin Jose del Cerro Murciano
Development and software arquitecture manager at gvSIG Team
[hidden email]
[hidden email]
gvSIG Association
www.gvsig.com
www.gvsig.org

_______________________________________________
gvSIG_desarrolladores mailing list
[hidden email]
Para ver histórico de mensajes, editar sus preferencias de usuario o darse de baja en esta lista, acuda a la siguiente dirección: https://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_desarrolladores
Reply | Threaded
Open this post in threaded view
|

Re: Problema al cargar leyenda

Alex Irmel Oviedo Solis
Hola, gracias por responder, el plugin org.gvsig.legend.vectorfilterexpression.app.mainplugin esta cargado en el gvSIG, pero resolvi el problema instalando el jar de éste plugin en maven local y funciono. Saludos.

El dom., 21 de may. de 2017 a la(s) 10:52, Joaquin Jose del Cerro Murciano <[hidden email]> escribió:
El 19 de mayo de 2017, 18:14, Alex Irmel Oviedo Solis <[hidden email]> escribió:
Buenos dias, estoy cargando leyendas desde un archivo gvsleg pero tengo una leyenda que no puedo cargar y me sale este error:
----
Caused by: java.lang.ClassCastException: org.gvsig.symbology.fmap.rendering.VectorFilterExpressionLegend cannot be cast to org.gvsig.symbology.fmap.mapcontext.rendering.legend.impl.SingleSymbolLegend
----

Claramente es un problema de dependencias que no logro encontrar,¿que paquete es el que tendria que agregar a mi pom para que me pueda compilar esto?


No tiene pinta de ser un problema de dependencias.
Necesitaria ver el stack completo del error, pero yo apuntaria hacia que estas cargando un leyenda de una capa de un tipo, sobre otra capa que no acepta ese tipo de leyenda.
Tambien podria ser que no tienes cargada en gvSIG el plugin que aporta el tipo de leyenda que estas instentando cargar.
Aunque lo dicho, es stack, o el log completo mejor, ayudaria bastante.

Un saludo
Joaquin

Saludos y gracias de antemano

_______________________________________________
gvSIG_desarrolladores mailing list
[hidden email]
Para ver histórico de mensajes, editar sus preferencias de usuario o darse de baja en esta lista, acuda a la siguiente dirección: https://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_desarrolladores




--
--------------------------------------
Joaquin Jose del Cerro Murciano
Development and software arquitecture manager at gvSIG Team
[hidden email]
[hidden email]
gvSIG Association
www.gvsig.com
www.gvsig.org
_______________________________________________
gvSIG_desarrolladores mailing list
[hidden email]
Para ver histórico de mensajes, editar sus preferencias de usuario o darse de baja en esta lista, acuda a la siguiente dirección: https://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_desarrolladores

_______________________________________________
gvSIG_desarrolladores mailing list
[hidden email]
Para ver histórico de mensajes, editar sus preferencias de usuario o darse de baja en esta lista, acuda a la siguiente dirección: https://listserv.gva.es/cgi-bin/mailman/listinfo/gvsig_desarrolladores