Problem using Geonetwork with large catalog

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem using Geonetwork with large catalog

Leo Rocher
This post has NOT been accepted by the mailing list yet.
Dear Geonetwork users,

I've currently a problem when using a catalog with more than 1 Million entries. It seem that the number of records matched for a query can't go past 1000001.

Here are a screen with a search for approximately 1.4M results



Versions :

Geonetwork v2.10.1
postgresql v9.1
postgis v1.5

Configuration :

I've follow the steps on : (http://geonetwork-opensource.org/manuals/trunk/eng/users/admin/advanced-configuration/index.html) :

-config.xml (using postgis)

        <resource enabled="true">
                        <name>main-db</name>
                        <provider>jeeves.resources.dbms.ApacheDBCPool</provider>
                        <config>
                                <user>....</user>
                                <password>....</password>
                                <driver>org.postgis.DriverWrapper</driver>
                                <url>jdbc:postgresql_postGIS://..../geonetwork</url>
                                <poolSize>10</poolSize>
                                <validationQuery>SELECT 1</validationQuery>
                                <maxActive>70</maxActive>
                                <provideDataStore>true</provideDataStore>
                        </config>
        </resource>

-Java heap space : -Xmx4g

-ulimit -n : 4096

-ulimit -s : 262140

-df -i :
Iutil : 125194
ILibre : 19494646



Regards

Leo Rocher
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem using Geonetwork with large catalog

Olyster
This post was updated on .
Leo,

although your post is very old, I can confirm that I have the same problem in 2.10.3 but I can also confirm that all the records are searched/evaluated. It's a display bug "only".

I'm also trying to correct this problem so if anyone knows the solution, I'd appreciate your help

Thanks
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem using Geonetwork with large catalog

Florent gravin-2
Hi,

Have you looked in Lucene configuration ?

On Fri, May 5, 2017 at 4:36 PM, Olyster <[hidden email]> wrote:

> Leo,
>
> altough your post is very old, I can confirm that I have the same problem
> in
> 2.10.3 but I can also confirm that all the results are searched. It's a
> display bug "only".
>
> I'm also trying to correct this problem so if anyone knows the solution,
> I'd
> appreciate your help
>
> Thanks
>
>
>
> --
> View this message in context: http://osgeo-org.1560.x6.
> nabble.com/Problem-using-Geonetwork-with-large-catalog-
> tp5081409p5319518.html
> Sent from the GeoNetwork users mailing list archive at Nabble.com.
>
> ------------------------------------------------------------
> ------------------
> Check out the vibrant tech community on one of the world's most
> engaging tech sites, Slashdot.org! http://sdm.link/slashdot
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at http://sourceforge.net/
> projects/geonetwork
>



--
*camptocamp*
INNOVATIVE SOLUTIONS
BY OPEN SOURCE EXPERTS

*Florent Gravin*
0479444492
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Loading...