Problem running on Ubuntu Cosmic

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem running on Ubuntu Cosmic

Charlie Davies
Hi There.

I am having the error while loading:

Couldn't load SIP module.
Python support will be disabled.


Traceback (most recent call last):
  File "", line 1, in
  File "/usr/lib/python3/dist-packages/qgis/__init__.py", line 72, in
    from qgis.PyQt import QtCore
  File "/usr/lib/python3/dist-packages/qgis/PyQt/QtCore.py", line 26, in
    from PyQt5.QtCore import *
ModuleNotFoundError: No module named 'PyQt5.QtCore'


Python version:
3.6.8 (default, Apr  9 2019, 04:59:38)
[GCC 8.3.0]

QGIS version:
3.6.3-Noosa 'Noosa', 0c5774c

Python path:
['/usr/share/qgis/python', '/home/charlie/.local/share/QGIS/QGIS3/profiles/default/python', '/home/charlie/.local/share/QGIS/QGIS3/profiles/default/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python36.zip', '/usr/lib/python3.6', '/usr/lib/python3.6/lib-dynload', '/usr/lib/python3/dist-packages']

and
An error occurred during execution of following code:
qgis.utils.uninstallErrorHook()


Traceback (most recent call last):
  File "", line 1, in
NameError: name 'qgis' is not defined


Python version:
3.6.8 (default, Apr  9 2019, 04:59:38)
[GCC 8.3.0]

QGIS version:
3.6.3-Noosa 'Noosa', 0c5774c

Python path:
['/usr/share/qgis/python', '/home/charlie/.local/share/QGIS/QGIS3/profiles/default/python', '/home/charlie/.local/share/QGIS/QGIS3/profiles/default/python/plugins', '/usr/share/qgis/python/plugins', '/usr/lib/python36.zip', '/usr/lib/python3.6', '/usr/lib/python3.6/lib-dynload', '/usr/lib/python3/dist-packages']


I have tried removing and re-installing. 

{19-05-29 12:19}[]CharlieThink:~ charlie% pip3 install PyQt5
Requirement already satisfied: PyQt5 in /usr/lib/python3/dist-packages (5.12.1)

{19-05-29 12:21}[]CharlieThink:~ charlie% sudo apt-get install python3-pip
Reading package lists... Done
Building dependency tree      
Reading state information... Done
python3-pip is already the newest version (18.1-5).
0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.
{19-05-29 12:21}[]CharlieThink:~ charlie% 

Python == ```Python 3.7.3```

Any one see my issue?
--
sent from gmail

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user
Reply | Threaded
Open this post in threaded view
|

Re: Problem running on Ubuntu Cosmic

Andre Joost
Am 29.05.19 um 13:39 schrieb Charlie Davies:

>
> {19-05-29 12:21}[]CharlieThink:~ charlie% sudo apt-get install python3-pip
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> python3-pip is already the newest version (18.1-5).
> 0 to upgrade, 0 to newly install, 0 to remove and 21 not to upgrade.

You should get rid of the 21 packages that are held back. Did you
upgrade sip using pip?

Cosmic has version 4.19.12 of python3-sip, and you should stick to that.

HTH,
Andre Joost

_______________________________________________
Qgis-user mailing list
[hidden email]
List info: https://lists.osgeo.org/mailman/listinfo/qgis-user
Unsubscribe: https://lists.osgeo.org/mailman/listinfo/qgis-user