Problem ogr

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem ogr

Moacir Netto
I have the ms4w installed, and I have the connection with the oracle non spatial, in oracle I have the fields x and y and I have to display using mapserver and show the message
 
msDrawMap() : failed to draw layer named teste
 
the connection don't have problem i test using ogrinfo and display the data  - ok
the shp2img -m mapfile -o img.png  display the point - ok
 
the mapfile
 

LAYER

NAME teste # ok

TYPE point

STATUS ON

TEMPLATE "estados.htm"

# CONNECTION "<OGRVRTDataSource>

# <OGRVRTLayer name='layerogr'>

# <SrcDataSource>ODBC:postgres/123@pg,pe</SrcDataSource>

# <SrcLayer>pe</SrcLayer>

# <GeometryType>wkbPoint</GeometryType>

# <GeometryField encoding='PointFromColumns' x='coordenada' y='coordena_1'/>

# </OGRVRTLayer>

# </OGRVRTDataSource>"

CONNECTION "c:\temp\teste.ovf"

CONNECTIONTYPE OGR

DATA "layerogr"

PROJECTION

"init=epsg:29181"

END

METADATA

ITENS "coordenada"

ITENSDESC "coordenada"

TEMA "OGR"

ESCALA "50000"

CLASSE "SIm"

TEXTO "SIM"

ESCALA "50000"

END

CLASS

NAME 'Represas'

#SYMBOL 'capital'

COLOR 0 77 217

SIZE 8

END # CLASS

TRANSPARENCY 100

END # LAYER

 

the teste with wms

 

 



Novidade no Yahoo! Mail: receba alertas de novas mensagens no seu celular. Registre seu aparelho agora!
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

Re: Problem ogr

Jeff McKenna-2
I'm not sure exactly.  I would:

   - make sure to use a System DSN (not a "User")
   - maybe set whatever Oracle environment variables are currently set
on your system in Apache as well (see bottom of Apache/conf/httpd.conf
for syntax)

Other than that maybe others have suggestions.

jeff



M_Becker wrote:

> I have the ms4w installed, and I have the connection with the oracle non
> spatial, in oracle I have the fields x and y and I have to display using
> mapserver and show the message
>  
> msDrawMap() : failed to draw layer named teste
>  
> the connection don't have problem i test using ogrinfo and display the
> data  - ok
> the shp2img -m mapfile -o img.png  display the point - ok
>  
> the mapfile
>  
>
> LAYER
>
> NAME teste # ok
>
> TYPE point
>
> STATUS ON
>
> TEMPLATE "estados.htm"
>
> # CONNECTION "<OGRVRTDataSource>
>
> # <OGRVRTLayer name='layerogr'>
>
> # <SrcDataSource>ODBC:postgres/123@pg,pe</SrcDataSource>
>
> # <SrcLayer>pe</SrcLayer>
>
> # <GeometryType>wkbPoint</GeometryType>
>
> # <GeometryField encoding='PointFromColumns' x='coordenada' y='coordena_1'/>
>
> # </OGRVRTLayer>
>
> # </OGRVRTDataSource>"
>
> CONNECTION "c:\temp\teste.ovf"
>
> CONNECTIONTYPE OGR
>
> DATA "layerogr"
>
> PROJECTION
>
> "init=epsg:29181"
>
> END
>
> METADATA
>
> ITENS "coordenada"
>
> ITENSDESC "coordenada"
>
> TEMA "OGR"
>
> ESCALA "50000"
>
> CLASSE "SIm"
>
> TEXTO "SIM"
>
> ESCALA "50000"
>
> END
>
> CLASS
>
> NAME 'Represas'
>
> #SYMBOL 'capital'
>
> COLOR 0 77 217
>
> SIZE 8
>
> END # CLASS
>
> TRANSPARENCY 100
>
> END # LAYER
>
>  
>
> the teste with wms
>

--
Jeff McKenna
DM Solutions Group Inc.
http://www.dmsolutions.ca
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users