Problem moving tilecache to a new server

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Problem moving tilecache to a new server

Stephen Woodbridge
Hi all,

I'm new to tilecache and I'm upgrading a tilecache-2.01 instance to a
new server and have it running under apache2 but I keep getting errors
like this for all requests:

An error occurred: Current x value -78.200000 is too far from tile
corner x -79.800000

My google-foo is weak today and failing to find an answer.

I get this error from both the tilecache-2.01 code and the
tilecache-2.11 code.

I take a URL from the old server that works and do nothing but change
the host to point to the new server and get this error.

I'm using the same tilecache.cfg file and I rsync'd the cache to the new
server.

I'm at a total loss as to what is going on or how to debug this.

http://74.208.78.238/tilecache-2.01/tilecache.py?LAYERS=bathy_contours&FORMAT=image%2Fpng&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_inimage&OLRELOADSALT=0.4349490585549216&SRS=EPSG%3A4326&BBOX=-78.20000000000002,31.199999999999996,-76.60000000000002,32.8&WIDTH=256&HEIGHT=256

This is my Apache config (NOTE: this is actually running tilecache-2.11
not 2.01 code, but I get the same error using 2.01 code):

         Alias /tilecache-2.01 /var/lib/python-support/python2.7/
         <Directory /var/lib/python-support/python2.7/>
                 SetHandler python-program
                 PythonHandler TileCache.Service
                 PythonOption TileCacheConfig /etc/tilecache.cfg
         </Directory>

and the tilecache.cfg file for this layer is:

[bathy_contours]
type=MapServerLayer
mapfile=/maps/wms/bathymetry.map
layers=contours
extension=png
bbox=-131.00, 12.00, -66.00, 49.00
maxResolution=0.10
srs=EPSG:4326
levels=15
extent_type=loose
debug=false

Why would this work on the old server and not on the new server?
Did I forget to move or configure something?

Help would be appreciated.

Thanks,
   -Steve
_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache
Reply | Threaded
Open this post in threaded view
|

Re: Problem moving tilecache to a new server

Brian Case
http://osgeo-org.1560.x6.nabble.com/random-errors-in-tilecache-2-11-td3965019.html



On Fri, 2014-01-31 at 19:00 -0500, Stephen Woodbridge wrote:

> Hi all,
>
> I'm new to tilecache and I'm upgrading a tilecache-2.01 instance to a
> new server and have it running under apache2 but I keep getting errors
> like this for all requests:
>
> An error occurred: Current x value -78.200000 is too far from tile
> corner x -79.800000
>
> My google-foo is weak today and failing to find an answer.
>
> I get this error from both the tilecache-2.01 code and the
> tilecache-2.11 code.
>
> I take a URL from the old server that works and do nothing but change
> the host to point to the new server and get this error.
>
> I'm using the same tilecache.cfg file and I rsync'd the cache to the new
> server.
>
> I'm at a total loss as to what is going on or how to debug this.
>
> http://74.208.78.238/tilecache-2.01/tilecache.py?LAYERS=bathy_contours&FORMAT=image%2Fpng&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_inimage&OLRELOADSALT=0.4349490585549216&SRS=EPSG%3A4326&BBOX=-78.20000000000002,31.199999999999996,-76.60000000000002,32.8&WIDTH=256&HEIGHT=256
>
> This is my Apache config (NOTE: this is actually running tilecache-2.11
> not 2.01 code, but I get the same error using 2.01 code):
>
>          Alias /tilecache-2.01 /var/lib/python-support/python2.7/
>          <Directory /var/lib/python-support/python2.7/>
>                  SetHandler python-program
>                  PythonHandler TileCache.Service
>                  PythonOption TileCacheConfig /etc/tilecache.cfg
>          </Directory>
>
> and the tilecache.cfg file for this layer is:
>
> [bathy_contours]
> type=MapServerLayer
> mapfile=/maps/wms/bathymetry.map
> layers=contours
> extension=png
> bbox=-131.00, 12.00, -66.00, 49.00
> maxResolution=0.10
> srs=EPSG:4326
> levels=15
> extent_type=loose
> debug=false
>
> Why would this work on the old server and not on the new server?
> Did I forget to move or configure something?
>
> Help would be appreciated.
>
> Thanks,
>    -Steve
> _______________________________________________
> Tilecache mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/tilecache


_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache
Reply | Threaded
Open this post in threaded view
|

Re: Problem moving tilecache to a new server

Stephen Woodbridge
Thanks. After changing that, I had to recompile the py to pyc and
restart apache2 because I'm using mod_python. But after that it seems to
be working now.

Many thanks,
   -Steve

On 2/1/2014 10:48 AM, Brian Case wrote:

> http://osgeo-org.1560.x6.nabble.com/random-errors-in-tilecache-2-11-td3965019.html
>
>
>
> On Fri, 2014-01-31 at 19:00 -0500, Stephen Woodbridge wrote:
>> Hi all,
>>
>> I'm new to tilecache and I'm upgrading a tilecache-2.01 instance to a
>> new server and have it running under apache2 but I keep getting errors
>> like this for all requests:
>>
>> An error occurred: Current x value -78.200000 is too far from tile
>> corner x -79.800000
>>
>> My google-foo is weak today and failing to find an answer.
>>
>> I get this error from both the tilecache-2.01 code and the
>> tilecache-2.11 code.
>>
>> I take a URL from the old server that works and do nothing but change
>> the host to point to the new server and get this error.
>>
>> I'm using the same tilecache.cfg file and I rsync'd the cache to the new
>> server.
>>
>> I'm at a total loss as to what is going on or how to debug this.
>>
>> http://74.208.78.238/tilecache-2.01/tilecache.py?LAYERS=bathy_contours&FORMAT=image%2Fpng&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&STYLES=&EXCEPTIONS=application%2Fvnd.ogc.se_inimage&OLRELOADSALT=0.4349490585549216&SRS=EPSG%3A4326&BBOX=-78.20000000000002,31.199999999999996,-76.60000000000002,32.8&WIDTH=256&HEIGHT=256
>>
>> This is my Apache config (NOTE: this is actually running tilecache-2.11
>> not 2.01 code, but I get the same error using 2.01 code):
>>
>>           Alias /tilecache-2.01 /var/lib/python-support/python2.7/
>>           <Directory /var/lib/python-support/python2.7/>
>>                   SetHandler python-program
>>                   PythonHandler TileCache.Service
>>                   PythonOption TileCacheConfig /etc/tilecache.cfg
>>           </Directory>
>>
>> and the tilecache.cfg file for this layer is:
>>
>> [bathy_contours]
>> type=MapServerLayer
>> mapfile=/maps/wms/bathymetry.map
>> layers=contours
>> extension=png
>> bbox=-131.00, 12.00, -66.00, 49.00
>> maxResolution=0.10
>> srs=EPSG:4326
>> levels=15
>> extent_type=loose
>> debug=false
>>
>> Why would this work on the old server and not on the new server?
>> Did I forget to move or configure something?
>>
>> Help would be appreciated.
>>
>> Thanks,
>>     -Steve
>> _______________________________________________
>> Tilecache mailing list
>> [hidden email]
>> http://lists.osgeo.org/mailman/listinfo/tilecache
>
>

_______________________________________________
Tilecache mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/tilecache