Problem installing GN v3.2.1 on Tomcat 7

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Problem installing GN v3.2.1 on Tomcat 7

IvanST
Hi everyone

I'm trying to install GN v3.2.1 war on Tomcat 7.0.28 (Debian 7, Apache 2) and always get the same problem.

This is report from catalina.out :

INFO: Deploying configuration descriptor /etc/tomcat7/Catalina/localhost/geonetwork.xml
May 09, 2017 9:30:12 AM org.apache.catalina.startup.HostConfig deployDescriptor
WARNING: A docBase /var/lib/tomcat7/webapps/geonetwork inside the host appBase has been specified, and will be ignored
May 09, 2017 9:30:15 AM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/var/lib/tomcat7/webapps/geonetwork/WEB-INF/lib/geronimo-servlet_3.0_spec-1.0.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
May 09, 2017 9:30:15 AM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/var/lib/tomcat7/webapps/geonetwork/WEB-INF/lib/javax.servlet-api-3.1.0.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
May 09, 2017 9:30:15 AM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/var/lib/tomcat7/webapps/geonetwork/WEB-INF/lib/jsp-api-2.1-6.1.14.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/el/Expression.class
May 09, 2017 9:30:15 AM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/var/lib/tomcat7/webapps/geonetwork/WEB-INF/lib/servlet-api-2.5-20081211.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
May 09, 2017 9:30:15 AM org.apache.catalina.loader.WebappClassLoader validateJarFile
INFO: validateJarFile(/var/lib/tomcat7/webapps/geonetwork/WEB-INF/lib/servlet-api-2.5-6.1.14.jar) - jar not loaded. See Servlet Spec 2.3, section 9.7.2. Offending class: javax/servlet/Servlet.class
May 09, 2017 9:30:16 AM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Error configuring application listener of class jeeves.config.springutil.JeevesContextLoaderListener
java.lang.UnsupportedClassVersionError: jeeves/config/springutil/JeevesContextLoaderListener : Unsupported major.minor version 52.0 (unable to load class jeeves.config.springutil.JeevesContextLoaderListener)
        at org.apache.catalina.loader.WebappClassLoader.findClassInternal(WebappClassLoader.java:2927)
        at org.apache.catalina.loader.WebappClassLoader.findClass(WebappClassLoader.java:1171)
        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1679)
        at org.apache.catalina.loader.WebappClassLoader.loadClass(WebappClassLoader.java:1557)
        at org.apache.catalina.core.DefaultInstanceManager.loadClass(DefaultInstanceManager.java:532)
        at org.apache.catalina.core.DefaultInstanceManager.loadClassMaybePrivileged(DefaultInstanceManager.java:514)
        at org.apache.catalina.core.DefaultInstanceManager.newInstance(DefaultInstanceManager.java:133)
        at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4763)
        at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5321)
        at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
        at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:899)
        at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:875)
        at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:618)
        at org.apache.catalina.startup.HostConfig.deployDescriptor(HostConfig.java:650)
        at org.apache.catalina.startup.HostConfig$DeployDescriptor.run(HostConfig.java:1582)
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
        at java.util.concurrent.FutureTask.run(FutureTask.java:262)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
        at java.lang.Thread.run(Thread.java:745)

May 09, 2017 9:30:16 AM org.apache.catalina.core.StandardContext listenerStart
SEVERE: Skipped installing application listeners due to previous error(s)
May 09, 2017 9:30:16 AM org.apache.catalina.core.StandardContext startInternal
SEVERE: Error listenerStart
May 09, 2017 9:30:16 AM org.apache.catalina.core.StandardContext startInternal
SEVERE: Context [/geonetwork] startup failed due to previous errors

Any sugestions on my next step to solve this problem?

Thank you.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem installing GN v3.2.1 on Tomcat 7

Pierre Mauduit-2
Hi,

jeeves/config/springutil/JeevesContextLoaderListener : Unsupported
> major.minor version 52.0 (unable to load class
> jeeves.config.springutil.JeevesContextLoaderListener)
>
>
This is due to the fact that you are using Java 1.7 instead of 1.8
(mandatory since version 3.2 of GeoNetwork). You can probably upgrade to
Java 8 using the backports (true for debian8, but it should also be the
case for debian7 with a little bit of luck).

regards,


-- Pierre
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem installing GN v3.2.1 on Tomcat 7

IvanST
Thank You for your reply.
I'll try to install Java 1.8 and do it all over again.
Regards,
Ivan

      From: Pierre Mauduit <[hidden email]>
 To: IvanST <[hidden email]>
Cc: [hidden email]
 Sent: Tuesday, May 9, 2017 1:32 PM
 Subject: Re: [GeoNetwork-users] Problem installing GN v3.2.1 on Tomcat 7
   
Hi,

jeeves/config/springutil/ JeevesContextLoaderListener : Unsupported
major.minor version 52.0 (unable to load class
jeeves.config.springutil. JeevesContextLoaderListener)



This is due to the fact that you are using Java 1.7 instead of 1.8 (mandatory since version 3.2 of GeoNetwork). You can probably upgrade to Java 8 using the backports (true for debian8, but it should also be the case for debian7 with a little bit of luck).
regards,

-- PierreĀ 

   
------------------------------------------------------------------------------
Check out the vibrant tech community on one of the world's most
engaging tech sites, Slashdot.org! http://sdm.link/slashdot
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Problem installing GN v3.2.1 on Tomcat 7

IvanST
Finally I've installed it on CentOS 7 with Tomcat 7 and OpenJDK 1.8 without any problems.

Thanks for all the help.

Regards,

Ivan
Loading...