Postgress.app + pointcloud

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Postgress.app + pointcloud

Puneet Kishor
As advised, I downloaded and installed Postgress.app (Mac OS X Sierra with Xcode 8.1). All works well.

However, I'd like to install and experiment with the pointcloud extension as I have a bunch of data from a 3D scan. Since I don't have the dev version of Pg, I can't really compile Pc against my Postgress.app. Is it possible to find a pointcloud binary somewhere? Or is there another suggested path forward?

--
Puneet Kishor
Just Another Creative Commoner

_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: Postgress.app + pointcloud

Giuseppe Broccolo
Hi,

2016-12-18 21:40 GMT+01:00 Puneet Kishor <[hidden email]>:
As advised, I downloaded and installed Postgress.app (Mac OS X Sierra with Xcode 8.1). All works well.

However, I'd like to install and experiment with the pointcloud extension as I have a bunch of data from a 3D scan. Since I don't have the dev version of Pg, I can't really compile Pc against my Postgress.app. Is it possible to find a pointcloud binary somewhere? Or is there another suggested path forward?

I generally work just with sources in Mac OS. I'd suggest to compile PostgreSQL, and then pgPointCloud. I use this:

that is able to install and configure different PostgreSQL versions instances, including dev tools, debug symbols, etc., useful if you have to develop something related with PostgreSQL. I already used PostgreSQL 9.6 + pgPointCloud 1.1 in my Mac OS X Sierra laptop in this way.

Regards,
Giuseppe.

--
Giuseppe Broccolo - 2ndQuadrant Italy
PostgreSQL & PostGIS Training, Services and Support
[hidden email] | www.2ndQuadrant.it

_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users
Reply | Threaded
Open this post in threaded view
|

Re: Postgress.app + pointcloud

Puneet Kishor

> On Dec 19, 2016, at 10:20 AM, Giuseppe Broccolo <[hidden email]> wrote:
>
> Hi,
>
> 2016-12-18 21:40 GMT+01:00 Puneet Kishor <[hidden email]>:
>> As advised, I downloaded and installed Postgress.app (Mac OS X Sierra with Xcode 8.1). All works well.
>>
>> However, I'd like to install and experiment with the pointcloud extension as I have a bunch of data from a 3D scan. Since I don't have the dev version of Pg, I can't really compile Pc against my Postgress.app. Is it possible to find a pointcloud binary somewhere? Or is there another suggested path forward?
>
> I generally work just with sources in Mac OS. I'd suggest to compile PostgreSQL, and then pgPointCloud. I use this:
>
> https://github.com/mnencia/pgenv 
>
> that is able to install and configure different PostgreSQL versions instances, including dev tools, debug symbols, etc., useful if you have to develop something related with PostgreSQL. I already used PostgreSQL 9.6 + pgPointCloud 1.1 in my Mac OS X Sierra laptop in this way.
>



Ouch, I was hoping to avoid this path as it means not using my Postgress.app instance anymore, but I may have to do this if I can’t find a binary that works with Postgress.app. Thanks anyway.

Puneet
_______________________________________________
postgis-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/postgis-users