Postgis layers won't reopen with modified display properties

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Postgis layers won't reopen with modified display properties

icosa atropa
Dear qgis devs,

I haven't been able to keep up with the list lately or build form
source - sorry if this has already been addressed.

Using the most recent ubuntu gutsy release of qgis (0.9.1), I get the
following replicable bug:

Adding postgis point and line layers works.  When I save the project
and reopen, everything reloads fine.

When I modify any display property of a postgis layer such as symbol
color or label, save the project, and reopen the project, then i get
the following error box with ok and cancel buttons.  Clicking either
button does not affect the outcome.

"Unable to open one or more project layers
Try to find missing layers?"

Once open, the modified layer is missing but all other layers load properly.

In the terminal, the only difference i can see between runs is:

bad run:
Warning: QPainter::end: Painter not active, aborted
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
row number 0 is out of range 0..-1
Warning: QPainter::begin: Cannot paint on a null pixmap
Warning: QPainter::end: Painter not active, aborted

good run:
Warning: QPainter::begin: Cannot paint on a null pixmap
Warning: QPainter::end: Painter not active, aborted

hope this helps!
christian
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Postgis layers won't reopen with modified display properties

Jürgen E. Fischer
Hi Christian,

On Wed, 09. Jan 2008 at 19:41:25 -0700, icosa atropa wrote:
> "Unable to open one or more project layers
> Try to find missing layers?"

Could be bug #860.  see https://svn.qgis.org/trac/ticket/860.

Jürgen

--
Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-0
Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
Software Engineer         D-26506 Norden               http://www.norbit.de

--
norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
Rheinstrasse 13, 26506 Norden
GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: Postgis layers won't reopen with modified display properties

icosa atropa
thanks.  I'll try 0.9.2 and report if it's not fixed, i.e. new bug.

On Jan 10, 2008 2:06 AM, Jürgen E. Fischer <[hidden email]> wrote:

> Hi Christian,
>
> On Wed, 09. Jan 2008 at 19:41:25 -0700, icosa atropa wrote:
> > "Unable to open one or more project layers
> > Try to find missing layers?"
>
> Could be bug #860.  see https://svn.qgis.org/trac/ticket/860.
>
> Jürgen
>
> --
> Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-0
> Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
> Software Engineer         D-26506 Norden               http://www.norbit.de
>
> --
> norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
> Rheinstrasse 13, 26506 Norden
> GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502
>
>



--
Far better an approximate answer to the right question, which is often
vague, than the exact answer to the wrong question, which can always
be made precise -- j.w. tukey
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-developer