Oracle with MS4W

classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Oracle with MS4W

Zack Stauber

Hi all, I’m running MS4W on IIS6, and I can talk to PostGIS just fine, but I followed the instructions to move the DLL’s so I can get into Oracle Spatial, and I get an error about php_mapscript.dll not being able to be loaded anymore, even if I am not yet trying to load anything from Oracle.  I know this problem existed in the past with version 1.5.4, but I wonder if anyone has gotten it to work yet.  The error has to do when I move the libmap.dll to cgi-bin.  Then it stops working and I get the following error:

 

Warning: dl() [function.dl]: Unable to load dynamic library 'C:\ms4w\Apache\php\ext\php_mapscript.dll' - The specified module could not be found. in C:\Inetpub\wwwroot\TX17\index.phtml on line 135

Fatal error: Call to undefined function ms_newMapObj() in C:\Inetpub\wwwroot\TX17\index.phtml on line 138
PHP Warning: dl() [function.dl]: Unable to load dynamic library 'C:\ms4w\Apache\php\ext\php_mapscript.dll' - The specified module could not be found. in C:\Inetpub\wwwroot\TX17\index.phtml on line 135 PHP Fatal error: Call to undefined function ms_newMapObj() in C:\Inetpub\wwwroot\TX17\index.phtml on line 138

 

Zachary L. Stauber

Certified Mapping Scientist

BohannanHuston

Courtyard One, 7500 Jefferson N.E.

Albuquerque, New Mexico  87109

Office: 505-823-1000

Direct: 505-798-7970

Fax: 505-798-7932

Email: [hidden email]

 

 


_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

Re: Oracle with MS4W

Jeff McKenna-2
I can tell you that I have Oracle10g locally and can view data stored in
Oracle Spatial through MS4W 2.2.2, following those MS4W instructions
(http://www.maptools.org/ms4w/index.phtml?page=README_INSTALL.html#oracle-10g).

jeff


Zachary Stauber wrote:

> Hi all, I’m running MS4W on IIS6, and I can talk to PostGIS just fine,
> but I followed the instructions to move the DLL’s so I can get into
> Oracle Spatial, and I get an error about php_mapscript.dll not being
> able to be loaded anymore, even if I am not yet trying to load anything
> from Oracle.  I know this problem existed in the past with version
> 1.5.4, but I wonder if anyone has gotten it to work yet.  The error has
> to do when I move the libmap.dll to cgi-bin.  Then it stops working and
> I get the following error:
>
>  
>
> *Warning*: dl() [function.dl <http://tx17.bhinc.com/function.dl>]:
> Unable to load dynamic library
> 'C:\ms4w\Apache\php\ext\php_mapscript.dll' - The specified module could
> not be found. in *C:\Inetpub\wwwroot\TX17\index.phtml* on line *135*
>
> *Fatal error*: Call to undefined function ms_newMapObj() in
> *C:\Inetpub\wwwroot\TX17\index.phtml* on line *138*
> PHP Warning: dl() [function.dl <http://tx17.bhinc.com/function.dl>]:
> Unable to load dynamic library
> 'C:\ms4w\Apache\php\ext\php_mapscript.dll' - The specified module could
> not be found. in C:\Inetpub\wwwroot\TX17\index.phtml on line 135 PHP
> Fatal error: Call to undefined function ms_newMapObj() in
> C:\Inetpub\wwwroot\TX17\index.phtml on line 138
>
>  
>
> *Zachary L. Stauber*
>
> **Certified Mapping Scientist**
>
> *Bohannan**▲**Huston*
>
> Courtyard One, 7500 Jefferson N.E.
>
> Albuquerque, New Mexico  87109
>
> Office: 505-823-1000
>
> Direct: 505-798-7970
>
> Fax: 505-798-7932
>
> Email: [hidden email] <mailto:[hidden email]>
>
>

--
Jeff McKenna
DM Solutions Group Inc.
http://www.dmsolutions.ca
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

RE: Oracle with MS4W

Zack Stauber
Hmm, yeah that's what I did, too.  Except for the Apache part.  I'm using Oracle XE client (the free one) instead of Oracle 10g and IIS 6 instead of Apache.  I work in a Windows only company, but I know the server end is working because I can see Oracle Spatial data from FME and from GeoMedia.  But loading up the libmap.dll seems to be where it fails.  As soon as I replace that one, it dies.  Maybe I can narrow it down.

1. Is there something particular to Apache that uses libmap.dll?
2. Or is there something in the regular Oracle 10g client (as opposed to Oracle XE) that libmap.dll needs?

        -Zack

-----Original Message-----
From: [hidden email] [mailto:[hidden email]] On Behalf Of Jeff McKenna
Sent: Friday, January 19, 2007 11:33 AM
To: [hidden email]
Subject: Re: [ms4w-users] Oracle with MS4W

I can tell you that I have Oracle10g locally and can view data stored in
Oracle Spatial through MS4W 2.2.2, following those MS4W instructions
(http://www.maptools.org/ms4w/index.phtml?page=README_INSTALL.html#oracle-10g).

jeff


Zachary Stauber wrote:

> Hi all, I’m running MS4W on IIS6, and I can talk to PostGIS just fine,
> but I followed the instructions to move the DLL’s so I can get into
> Oracle Spatial, and I get an error about php_mapscript.dll not being
> able to be loaded anymore, even if I am not yet trying to load anything
> from Oracle.  I know this problem existed in the past with version
> 1.5.4, but I wonder if anyone has gotten it to work yet.  The error has
> to do when I move the libmap.dll to cgi-bin.  Then it stops working and
> I get the following error:
>
>  
>
> *Warning*: dl() [function.dl <http://tx17.bhinc.com/function.dl>]:
> Unable to load dynamic library
> 'C:¥ms4w¥Apache¥php¥ext¥php_mapscript.dll' - The specified module could
> not be found. in *C:¥Inetpub¥wwwroot¥TX17¥index.phtml* on line *135*
>
> *Fatal error*: Call to undefined function ms_newMapObj() in
> *C:¥Inetpub¥wwwroot¥TX17¥index.phtml* on line *138*
> PHP Warning: dl() [function.dl <http://tx17.bhinc.com/function.dl>]:
> Unable to load dynamic library
> 'C:¥ms4w¥Apache¥php¥ext¥php_mapscript.dll' - The specified module could
> not be found. in C:¥Inetpub¥wwwroot¥TX17¥index.phtml on line 135 PHP
> Fatal error: Call to undefined function ms_newMapObj() in
> C:¥Inetpub¥wwwroot¥TX17¥index.phtml on line 138
>
>  
>
> *Zachary L. Stauber*
>
> **Certified Mapping Scientist**
>
> *Bohannan**▲**Huston*
>
> Courtyard One, 7500 Jefferson N.E.
>
> Albuquerque, New Mexico  87109
>
> Office: 505-823-1000
>
> Direct: 505-798-7970
>
> Fax: 505-798-7932
>
> Email: [hidden email] <mailto:[hidden email]>
>
>

--
Jeff McKenna
DM Solutions Group Inc.
http://www.dmsolutions.ca
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

Re: Oracle with MS4W

Jeff McKenna-2
Zak,

I admit that before MS4W 2.1 there were problems with this plugin, but
as of 2.1 I have been testing this plugin myself and many users have
reported successful connections to Oracle since v2.1.  However, since
MS4W 2.2.2 was released only a few days ago (and there has been no other
feedback), you might also test with a little older version (2.2.1 from
http://dl.maptools.org/dl/ms4w/).

> 1. Is there something particular to Apache that uses libmap.dll?

No.

> 2. Or is there something in the regular Oracle 10g client (as opposed to Oracle XE) that libmap.dll needs?
>

I don't think so.  But I use the regular Oracle 10g client.  All of the
libmap.dll requirements should already be included in the cgi-bin folder.

Sorry I am of no real help.

jeff




--
Jeff McKenna
DM Solutions Group Inc.
http://www.dmsolutions.ca
_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users