Opacity in ColorMaps with SLD raster styling - 2.1.3

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Opacity in ColorMaps with SLD raster styling - 2.1.3

Ian Tangert
This post was updated on .
greetings,

i cannot get opacity working correctly with colormap styles for rasters. the only opacity levels that will work are 1 or 0.  I  get opacity rendering between 1 and 0 with the <Opacity> tag but then colormap is disabled.  i thought the following SLD would render the whole map with .5 opacity, but it renders at opacity=1.  is this because i'm using the [type="intervals"] or do i have another syntax error or something? using 2.1.3 on ubuntu 11.10 from an opengeo deb package for lucid, is that bad?

<?xml version="1.0" encoding="UTF-8"?>
<StyledLayerDescriptor xmlns="http://www.opengis.net/sld" xmlns:ogc="http://www.opengis.net/ogc" xmlns:xlink="http://www.w3.org/1999/xlink" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.opengis.net/sld
http://schemas.opengis.net/sld/1.0.0/StyledLayerDescriptor.xsd" version="1.0.0">
  <NamedLayer>
    <Name>test</Name>
    <UserStyle>
      <Name>raster</Name>
      <Title>test raster style</Title>
      <Abstract>testing raster styling</Abstract>
      <FeatureTypeStyle>
        <Rule>
          <RasterSymbolizer>
            <ColorMap type="intervals" extended="true"> 
              <ColorMapEntry color="#e0f6ff" quantity="0" opacity="0.5" />
              <ColorMapEntry color="#87accc" quantity="601" opacity="0.5" />
              <ColorMapEntry color="#4e7699" quantity="1166" opacity="0.5" />             
              <ColorMapEntry color="#2b6699" quantity="1730" opacity="0.5" />
              <ColorMapEntry color="#053783" quantity="2300" opacity="0.5" />
            </ColorMap>
          </RasterSymbolizer>       
        </Rule>
      </FeatureTypeStyle>
    </UserStyle>
  </NamedLayer>
</StyledLayerDescriptor>