OSGeo4W: Qgis 1.0.1

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

OSGeo4W: Qgis 1.0.1

Stephan Holl
Dear QGIS-devs,

currently I am using QGIS 1.0.1 from the OSGeo4W-packagefor a beginner cource.
I did not try the points with the recent releases of QGIS.

Some oddities were found:
* Transparent WMS-layers. The WMS-layers are not transparent, even if I force  
  TRANSPARENT=true within the Connection-parameter-URL. With QGIS 1.0.0 it was
  possible though (both with PNG-formats).
* Using *.qml-files with saved styles work perfectly with shapefiles. If I
  place the saved *.qml-file with the identical name as the shapefile it gets
  picked up as soon as I load the shapefile. Where do I need to put
  the *.qml-file for a PostGIS-layer?
* Are the linetypes for classifying a boundary of a polygon extendable? The
  filling-pattern are extendable though.
* When I accidently delete the buttonbar of the printcomposer I cannot enable
  it again unless I restart the complete project again. Starting the
  printcomposer does not solve the problem.
* Projected shapefiles (with .prj-file) do not show the correct projection
  inside the metadata tab within the properties-dialog.

If you feel that some points above mentioned are bugs I am happy to create a
trac-ticket soon.

TIA for your comments.

Best regards

        Stephan
--
Stephan Holl <[hidden email]>, http://intevation.de/~stephan
Tel: +49 (0)541-33 50 8 32 | Intevation GmbH | AG Osnabrück - HR B 18998
Geschäftsführer:  Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

AW: OSGeo4W: Qgis 1.0.1

Hugentobler  Marco
Hi Stephan

>* When I accidently delete the buttonbar of the printcomposer I cannot enable
>  it again unless I restart the complete project again. Starting the
>  printcomposer does not solve the problem.

This is a bug.

>* Transparent WMS-layers. The WMS-layers are not transparent, even if I force  
>  TRANSPARENT=true within the Connection-parameter-URL. With QGIS 1.0.0 it was
>  possible though (both with PNG-formats).

Transparent=True in WMS only refers to background transparency (e.g. if you have a line layer, the lines will not be transparent, only the areas not covered by lines).
I think that the WMS transparency in the raster properties dialog is fixed in newer versions. Please try with 1.2 and fill a bug if the problem still persists.

Regards,
Marco

-----Ursprüngliche Nachricht-----
Von: [hidden email] im Auftrag von Stephan Holl
Gesendet: Mi 20.05.2009 08:01
An: [hidden email]
Betreff: [Qgis-developer] OSGeo4W: Qgis 1.0.1
 
Dear QGIS-devs,

currently I am using QGIS 1.0.1 from the OSGeo4W-packagefor a beginner cource.
I did not try the points with the recent releases of QGIS.

Some oddities were found:
* Transparent WMS-layers. The WMS-layers are not transparent, even if I force  
  TRANSPARENT=true within the Connection-parameter-URL. With QGIS 1.0.0 it was
  possible though (both with PNG-formats).
* Using *.qml-files with saved styles work perfectly with shapefiles. If I
  place the saved *.qml-file with the identical name as the shapefile it gets
  picked up as soon as I load the shapefile. Where do I need to put
  the *.qml-file for a PostGIS-layer?
* Are the linetypes for classifying a boundary of a polygon extendable? The
  filling-pattern are extendable though.
* When I accidently delete the buttonbar of the printcomposer I cannot enable
  it again unless I restart the complete project again. Starting the
  printcomposer does not solve the problem.
* Projected shapefiles (with .prj-file) do not show the correct projection
  inside the metadata tab within the properties-dialog.

If you feel that some points above mentioned are bugs I am happy to create a
trac-ticket soon.

TIA for your comments.

Best regards

        Stephan
--
Stephan Holl <[hidden email]>, http://intevation.de/~stephan
Tel: +49 (0)541-33 50 8 32 | Intevation GmbH | AG Osnabrück - HR B 18998
Geschäftsführer:  Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: OSGeo4W: Qgis 1.0.1

Stephan Holl
Hallo Marco,

"Hugentobler  Marco" <[hidden email]>, [20090520
- 22:00:12]

> Hi Stephan
>
> >* When I accidently delete the buttonbar of the printcomposer I
> >cannot enable
> >  it again unless I restart the complete project again. Starting the
> >  printcomposer does not solve the problem.
>
> This is a bug.

OK, please find it here: http://trac.osgeo.org/qgis/ticket/1711 (I have
taken the liberty to assign it to you)
 
> >* Transparent WMS-layers. The WMS-layers are not transparent, even
> >if I force  
> >  TRANSPARENT=true within the Connection-parameter-URL. With QGIS
> > 1.0.0 it was possible though (both with PNG-formats).
>
> Transparent=True in WMS only refers to background transparency (e.g.
> if you have a line layer, the lines will not be transparent, only the
> areas not covered by lines).

Yes, that is exactly what we needed (and I knew it was working once in
an earlier release).

> I think that the WMS transparency in the
> raster properties dialog is fixed in newer versions. Please try with
> 1.2 and fill a bug if the problem still persists.

The transparency inside the raster dialog works as expected, but the
WMS-image did not come as a transparent PNG.
However, I tried with trunk (r10835) and it worked (on linux though).

Any other ideas on the other topics I posted? Especially the
*.qml-thingy I am interested to get solved/answered.

TIA

Best

        Stephan

>
> -----Ursprüngliche Nachricht-----
> Von: [hidden email] im Auftrag von Stephan
> Holl Gesendet: Mi 20.05.2009 08:01
> An: [hidden email]
> Betreff: [Qgis-developer] OSGeo4W: Qgis 1.0.1
>  
> Dear QGIS-devs,
>
> currently I am using QGIS 1.0.1 from the OSGeo4W-packagefor a
> beginner cource. I did not try the points with the recent releases of
> QGIS.
>
> Some oddities were found:
> * Transparent WMS-layers. The WMS-layers are not transparent, even if
> I force TRANSPARENT=true within the Connection-parameter-URL. With
> QGIS 1.0.0 it was possible though (both with PNG-formats).
> * Using *.qml-files with saved styles work perfectly with shapefiles.
> If I place the saved *.qml-file with the identical name as the
> shapefile it gets picked up as soon as I load the shapefile. Where do
> I need to put the *.qml-file for a PostGIS-layer?
> * Are the linetypes for classifying a boundary of a polygon
> extendable? The filling-pattern are extendable though.
> * When I accidently delete the buttonbar of the printcomposer I
> cannot enable it again unless I restart the complete project again.
> Starting the printcomposer does not solve the problem.
> * Projected shapefiles (with .prj-file) do not show the correct
> projection inside the metadata tab within the properties-dialog.
>
> If you feel that some points above mentioned are bugs I am happy to
> create a trac-ticket soon.
>
> TIA for your comments.
>
> Best regards
>
> Stephan

--
Stephan Holl <[hidden email]> | Tel.: +49 (0)541-33 508 3663
Intevation GmbH, Neuer Graben 17, 49074 OS  |  AG Osnabrück - HR B 18998
Geschäftsführer:  Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer

signature.asc (204 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OSGeo4W: Qgis 1.0.1

Jürgen E. Fischer
In reply to this post by Stephan Holl
Hi Stephan,

On Wed, 20. May 2009 at 08:01:52 +0200, Stephan Holl wrote:
> * Using *.qml-files with saved styles work perfectly with shapefiles. If I
>   place the saved *.qml-file with the identical name as the shapefile it gets
>   picked up as soon as I load the shapefile. Where do I need to put
>   the *.qml-file for a PostGIS-layer?

QML files are only for file based layers.  The defaults for other layers are
stored to the qgis.qmldb SQLite database in the .qgis directory
(%USERPROFILE%\.qgis on Windows and ~/.qgis on *x).

When a non file based layer qgis tries to load the defaults from the above
file, a file named like the project, but ending on .qmldb or the qgis.qmldb in
the qgis resources directory.

There's no UI to transfer the settings from the user's qgis.qmldb into the
project or resources database.


Jürgen

--
Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-20
Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
Software Engineer         D-26506 Norden               http://www.norbit.de

--
norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
Rheinstrasse 13, 26506 Norden
GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: OSGeo4W: Qgis 1.0.1

Stephan Holl
Hallo Jürgen,

Jürgen E. Fischer <[hidden email]>, [20090522 - 12:07:11]

> Hi Stephan,
>
> On Wed, 20. May 2009 at 08:01:52 +0200, Stephan Holl wrote:
> > * Using *.qml-files with saved styles work perfectly with
> > shapefiles. If I place the saved *.qml-file with the identical name
> > as the shapefile it gets picked up as soon as I load the shapefile.
> > Where do I need to put the *.qml-file for a PostGIS-layer?
>
> QML files are only for file based layers.  The defaults for other
> layers are stored to the qgis.qmldb SQLite database in the .qgis
> directory (%USERPROFILE%\.qgis on Windows and ~/.qgis on *x).
Ah, thanks for the clarifications.
 
> When a non file based layer qgis tries to load the defaults from the
> above file, a file named like the project, but ending on .qmldb or
> the qgis.qmldb in the qgis resources directory.

ok, thank you very much.

>
> There's no UI to transfer the settings from the user's qgis.qmldb
> into the project or resources database.

Ok, is is sufficient to create a qgis.qmldb and copy it to the global
ressources-folder? Would it be picked up as the fallback (for a global
installation)?

Best regards

        Stephan

--
Stephan Holl <[hidden email]> | Tel.: +49 (0)541-33 508 3663
Intevation GmbH, Neuer Graben 17, 49074 OS  |  AG Osnabrück - HR B 18998
Geschäftsführer:  Frank Koormann, Bernhard Reiter, Dr. Jan-Oliver Wagner

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer

signature.asc (204 bytes) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: OSGeo4W: Qgis 1.0.1

Jürgen E. Fischer
Hi Stephan,

On Fri, 22. May 2009 at 13:51:22 +0200, Stephan Holl wrote:
> > When a non file based layer qgis tries to load the defaults from the
> > above file, a file named like the project, but ending on .qmldb or
> > the qgis.qmldb in the qgis resources directory.

> > There's no UI to transfer the settings from the user's qgis.qmldb
> > into the project or resources database.
 
> Ok, is is sufficient to create a qgis.qmldb and copy it to the global
> ressources-folder? Would it be picked up as the fallback (for a global
> installation)?

Yes.

BTW the uri of the data source is used as key to the qmldb.  That means that if
you add a layer from the same table, but with a changed parameters (ie.
different credentials, sslmode or anything else) the defaults won't be found.


Jürgen

--
Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-20
Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
Software Engineer         D-26506 Norden               http://www.norbit.de

--
norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
Rheinstrasse 13, 26506 Norden
GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer