[OSGeo] #2455: certbot-auto on osgeo6 is not working

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

[OSGeo] #2455: certbot-auto on osgeo6 is not working

OSGeo
#2455: certbot-auto on osgeo6 is not working
---------------------------+--------------------------------------
 Reporter:  robe           |      Owner:  sac@…
     Type:  task           |     Status:  new
 Priority:  normal         |  Milestone:  Sysadmin Contract 2020-I
Component:  Systems Admin  |   Keywords:
---------------------------+--------------------------------------
 Just got a notice from letsencrypt that all domains on osgeo6 their ssl is
 about to expire.

 I see the certbot auto in the cronjob.

 {{{
 We recommend renewing certificates automatically when they have a third of
 their total lifetime left. For Let's Encrypt's current 90-day
 certificates, that means renewing 30 days before expiration. See
 https://letsencrypt.org/docs/integration-guide/ for details.

 docs.geotools.org
 drone.osgeo.org
 geos.osgeo.org
 geotools.org
 grass.osgeo.org
 grasswiki.osgeo.org
 lists.osgeo.org
 mapserver.gis.umn.edu
 mapserver.org
 osgeo6.osgeo.osuosl.org
 www.geotools.org
 www.mapserver.org
 www3.mapserver.org

 }}}

--
Ticket URL: <https://trac.osgeo.org/osgeo/ticket/2455>
OSGeo <https://osgeo.org/>
OSGeo committee and general foundation issue tracker.

_______________________________________________
Sac mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/sac
Reply | Threaded
Open this post in threaded view
|

Re: [OSGeo] #2455: certbot-auto on osgeo6 is not working

OSGeo
#2455: certbot-auto on osgeo6 is not working
---------------------------+---------------------------------------
 Reporter:  robe           |       Owner:  sac@…
     Type:  task           |      Status:  new
 Priority:  normal         |   Milestone:  Sysadmin Contract 2020-I
Component:  Systems Admin  |  Resolution:
 Keywords:                 |
---------------------------+---------------------------------------

Comment (by robe):

 I went into osgeo6 and did a manual


 {{{
 certbot renew
 }}}

 All renewed except for gdal.org

 that is expected since gdal.org letsencrypt was moved to osgeo7.  I've
 removed gdal domain from the server with these commands


 {{{
 a2dissite www.gdal.org.conf
 a2dissite www.gdal.org-le-ssl.conf
 service apache2 reload
 certbot-auto delete --cert-name=gdal.org
 }}}


 strk can we shut off drone.osgeo.org


 I'm not sure what's wrong with the cronjob for renewal.  At a glance looks
 right.

--
Ticket URL: <https://trac.osgeo.org/osgeo/ticket/2455#comment:1>
OSGeo <https://osgeo.org/>
OSGeo committee and general foundation issue tracker.

_______________________________________________
Sac mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/sac
Reply | Threaded
Open this post in threaded view
|

Re: [OSGeo] #2455: certbot-auto cronjob on osgeo6 is not working (was: certbot-auto on osgeo6 is not working)

OSGeo
In reply to this post by OSGeo
#2455: certbot-auto cronjob on osgeo6 is not working
---------------------------+---------------------------------------
 Reporter:  robe           |       Owner:  sac@…
     Type:  task           |      Status:  new
 Priority:  normal         |   Milestone:  Sysadmin Contract 2020-I
Component:  Systems Admin  |  Resolution:
 Keywords:                 |
---------------------------+---------------------------------------

--
Ticket URL: <https://trac.osgeo.org/osgeo/ticket/2455#comment:2>
OSGeo <https://osgeo.org/>
OSGeo committee and general foundation issue tracker.

_______________________________________________
Sac mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/sac
Reply | Threaded
Open this post in threaded view
|

Re: [OSGeo] #2455: certbot-auto cronjob on osgeo6 is not working

OSGeo
In reply to this post by OSGeo
#2455: certbot-auto cronjob on osgeo6 is not working
---------------------------+---------------------------------------
 Reporter:  robe           |       Owner:  sac@…
     Type:  task           |      Status:  new
 Priority:  normal         |   Milestone:  Sysadmin Contract 2020-I
Component:  Systems Admin  |  Resolution:
 Keywords:                 |
---------------------------+---------------------------------------

Comment (by strk):

 > strk can we shut off drone.osgeo.org

 It looks like php-geos still uses it, I'll have a look
 about removing it.

--
Ticket URL: <https://trac.osgeo.org/osgeo/ticket/2455#comment:3>
OSGeo <https://osgeo.org/>
OSGeo committee and general foundation issue tracker.

_______________________________________________
Sac mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/sac
Reply | Threaded
Open this post in threaded view
|

Re: [OSGeo] #2455: certbot-auto cronjob on osgeo6 is not working

OSGeo
In reply to this post by OSGeo
#2455: certbot-auto cronjob on osgeo6 is not working
---------------------------+---------------------------------------
 Reporter:  robe           |       Owner:  sac@…
     Type:  task           |      Status:  closed
 Priority:  normal         |   Milestone:  Sysadmin Contract 2020-I
Component:  Systems Admin  |  Resolution:  fixed
 Keywords:                 |
---------------------------+---------------------------------------
Changes (by robe):

 * status:  new => closed
 * resolution:   => fixed


Comment:

 oops strk missed this note -- I shut it off :(

 also now I release I had already deleted gdal.org not sure why it came
 back again.

 At anyrate hoping my changes in #2470  finally fixed this.  Going to
 assume it did and close this out.

--
Ticket URL: <https://trac.osgeo.org/osgeo/ticket/2455#comment:4>
OSGeo <https://osgeo.org/>
OSGeo committee and general foundation issue tracker.

_______________________________________________
Sac mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/sac