Need help configuring geonetwork to use WMS

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Need help configuring geonetwork to use WMS

Willem Nieuwenhuis
I have Mapserver and Geonetwork (v2.0.2) running (both locally still).

I use the following WMS request to display some data:
http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map&SERVIC
E=WMS&VERSION=1.1.1&REQUEST=GetMap&SRS=EPSG:4326&BBOX=-18,25,52,55&FORMA
T=image/gif&WIDTH=640&HEIGHT=480&LAYERS=region,gdi

I want to add a link in geonetwork to this request.

1. I tried to add it as interactive map (OpenGIS Map service (ver
1.1.1)) in the linkage field.
   The Intermap window is opened, the layer is populated, but no image
is displayed (small red cross in the
   internet explorer). Now I read in an earlier E-mail that the WMS
server should be put in the linkage field
   and the layer in the Name field;
   But in that case where do all the other parameters go? Do I need to
configure Intermap for this? If so, how?

   BTW: if I put the server in the linkage and the layer in the name
field the request generated by
        geonetwork is:
http:/localhost/cgi-bin/mapserv.exe&service=region&type=2': I thought
service should
        be "WMS".

2. I also tried to add it as an online resource (Web Address (URL)) and
using the complete request as the URL. Unfortunately geonetworks
prepends http://localhost:8080/ in front of the URL

Appreciate any help

W. Nieuwenhuis
System Developer
IT-Department, Sector Remote Sensing & GIS
International Institute for Geo-information Science and Earth
Observation (ITC)
P.O. Box 6, NL 7500 AA, Enschede, The Netherlands
Phone +31 (0)53 4874 458, Telefax +31 (0)53 4874 385
e-mail [hidden email], Internet http://www.itc.nl
 


Reply | Threaded
Open this post in threaded view
|

Re: Need help configuring geonetwork to use WMS

François-Xavier PRUNAYRE
Hi Willem,
 
You're right, WMS server base url should be put in the linkage field and the
layer in the Name field. So in your case,
Linkage = http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map
Name = region,gdi
Select protocol = Open GIS WMS 1.1.1.

All other wms parameters will be defined by Intermap

I think problem come from your "?map=C:/" parameter in the url parameter.
Try to create an alias for your WMS in your web server.
RewriteEngine on
RewriteRule ^/mapservice(.*)
http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map&$1

If you use "Add Layer" button in intermap does it work ?

HTH. Francois

-----Message d'origine-----
De : [hidden email]
[mailto:[hidden email]] De la part de Willem
Nieuwenhuis
Envoyé : jeudi 19 octobre 2006 17:08
À : [hidden email]
Objet : [GeoNetwork-users] Need help configuring geonetwork to use WMS

I have Mapserver and Geonetwork (v2.0.2) running (both locally still).

I use the following WMS request to display some data:
http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map&SERVIC
E=WMS&VERSION=1.1.1&REQUEST=GetMap&SRS=EPSG:4326&BBOX=-18,25,52,55&FORMA
T=image/gif&WIDTH=640&HEIGHT=480&LAYERS=region,gdi

I want to add a link in geonetwork to this request.

1. I tried to add it as interactive map (OpenGIS Map service (ver
1.1.1)) in the linkage field.
   The Intermap window is opened, the layer is populated, but no image is
displayed (small red cross in the
   internet explorer). Now I read in an earlier E-mail that the WMS server
should be put in the linkage field
   and the layer in the Name field;
   But in that case where do all the other parameters go? Do I need to
configure Intermap for this? If so, how?

   BTW: if I put the server in the linkage and the layer in the name field
the request generated by
        geonetwork is:
http:/localhost/cgi-bin/mapserv.exe&service=region&type=2': I thought
service should
        be "WMS".

2. I also tried to add it as an online resource (Web Address (URL)) and
using the complete request as the URL. Unfortunately geonetworks prepends
http://localhost:8080/ in front of the URL

Appreciate any help

W. Nieuwenhuis
System Developer
IT-Department, Sector Remote Sensing & GIS International Institute for
Geo-information Science and Earth Observation (ITC) P.O. Box 6, NL 7500 AA,
Enschede, The Netherlands Phone +31 (0)53 4874 458, Telefax +31 (0)53 4874
385 e-mail [hidden email], Internet http://www.itc.nl
 

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job
easier Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at
http://sourceforge.net/projects/geonetwork

--
Ce message a ete verifie par MailScanner pour des virus ou des polluriels et
rien de suspect n'a ete trouve.

Les donnees et renseignements contenus dans ce message sont personnels,
confidentiels et prives. Toute publication, utilisation ou diffusion, meme
partielle, doit etre autorisee.

Any data and information contained in this electronic mail is personal,
confidential and secret. Any total or partial publication, use or
distribution must be authorized.


--
Ce message a ete verifie par MailScanner pour des virus ou des polluriels et rien de suspect n'a ete trouve.

Les donnees et renseignements contenus dans ce message sont personnels, confidentiels et prives. Toute publication, utilisation ou diffusion, meme partielle, doit etre autorisee.

Any data and information contained in this electronic mail is personal, confidential and secret. Any total or partial publication, use or distribution must be authorized.



Reply | Threaded
Open this post in threaded view
|

Re: Need help configuring geonetwork to use WMS

Willem Nieuwenhuis
Hi Francois,

Your information did help me out partly.
We have a very simple WMS setup without an application build around
the data. I followed your info and changed the linkage field to include
the link to the map-file. This allowed me to see what Mapserver received
as a request. It turns out that Intermap sends the request as:
  /gdi/index.html?SERVIVE=WMS&...
But because we do not have an index.html this of course fails.

The "Add Layer" in Intermap does work: it will add the layer, but
again the request fails (same problem)

As to your suggestion about configuring MapServer to translate the
request URL: I must admit that this is completely new to me. I think
I rather create a simple WMS application to handle the Intermap requests
sometime soon.

Thanks

Willem

-----Original Message-----
From: François Prunayre [mailto:[hidden email]]
Sent: Monday, October 23, 2006 10:25
To: Willem Nieuwenhuis
Cc: [hidden email]
Subject: RE: [GeoNetwork-users] Need help configuring geonetwork to use WMS

Hi Willem,
 
You're right, WMS server base url should be put in the linkage field and the
layer in the Name field. So in your case,
Linkage = http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map
Name = region,gdi
Select protocol = Open GIS WMS 1.1.1.

All other wms parameters will be defined by Intermap

I think problem come from your "?map=C:/" parameter in the url parameter.
Try to create an alias for your WMS in your web server.
RewriteEngine on
RewriteRule ^/mapservice(.*)
http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map&$1

If you use "Add Layer" button in intermap does it work ?

HTH. Francois

-----Message d'origine-----
De : [hidden email]
[mailto:[hidden email]] De la part de Willem
Nieuwenhuis
Envoyé : jeudi 19 octobre 2006 17:08
À : [hidden email]
Objet : [GeoNetwork-users] Need help configuring geonetwork to use WMS

I have Mapserver and Geonetwork (v2.0.2) running (both locally still).

I use the following WMS request to display some data:
http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/apps/GDI/gdi.map&SERVIC
E=WMS&VERSION=1.1.1&REQUEST=GetMap&SRS=EPSG:4326&BBOX=-18,25,52,55&FORMA
T=image/gif&WIDTH=640&HEIGHT=480&LAYERS=region,gdi

I want to add a link in geonetwork to this request.

1. I tried to add it as interactive map (OpenGIS Map service (ver
1.1.1)) in the linkage field.
   The Intermap window is opened, the layer is populated, but no image is
displayed (small red cross in the
   internet explorer). Now I read in an earlier E-mail that the WMS server
should be put in the linkage field
   and the layer in the Name field;
   But in that case where do all the other parameters go? Do I need to
configure Intermap for this? If so, how?

   BTW: if I put the server in the linkage and the layer in the name field
the request generated by
        geonetwork is:
http:/localhost/cgi-bin/mapserv.exe&service=region&type=2': I thought
service should
        be "WMS".

2. I also tried to add it as an online resource (Web Address (URL)) and
using the complete request as the URL. Unfortunately geonetworks prepends
http://localhost:8080/ in front of the URL

Appreciate any help

W. Nieuwenhuis
System Developer
IT-Department, Sector Remote Sensing & GIS International Institute for
Geo-information Science and Earth Observation (ITC) P.O. Box 6, NL 7500 AA,
Enschede, The Netherlands Phone +31 (0)53 4874 458, Telefax +31 (0)53 4874
385 e-mail [hidden email], Internet http://www.itc.nl
 

-------------------------------------------------------------------------
Using Tomcat but need to do more? Need to support web services, security?
Get stuff done quickly with pre-integrated technology to make your job
easier Download IBM WebSphere Application Server v.1.0.1 based on Apache
Geronimo
http://sel.as-us.falkag.net/sel?cmd=lnk&kid=120709&bid=263057&dat=121642
_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at
http://sourceforge.net/projects/geonetwork

--
Ce message a ete verifie par MailScanner pour des virus ou des polluriels et
rien de suspect n'a ete trouve.

Les donnees et renseignements contenus dans ce message sont personnels,
confidentiels et prives. Toute publication, utilisation ou diffusion, meme
partielle, doit etre autorisee.

Any data and information contained in this electronic mail is personal,
confidential and secret. Any total or partial publication, use or
distribution must be authorized.


--
Ce message a ete verifie par MailScanner pour des virus ou des polluriels et rien de suspect n'a ete trouve.

Les donnees et renseignements contenus dans ce message sont personnels, confidentiels et prives. Toute publication, utilisation ou diffusion, meme partielle, doit etre autorisee.

Any data and information contained in this electronic mail is personal, confidential and secret. Any total or partial publication, use or distribution must be authorized.