Missing required parameter: ApplicationDefinition

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Missing required parameter: ApplicationDefinition

maabas
Hi,

I tried the 3.1.2 version of mapguide, play around it from feature source,
layer, map and web layout. All is successful nonetheless. But when I created
a ApplicationDefinition (fusion / flexi layout), I get the this error:
Missing required parameter: ApplicationDefinition.

I tried creating it multiple times but still the same error. What am I doing
wrong?
Thanks in advance.



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: Missing required parameter: ApplicationDefinition

RenoSun
This post was updated on .
I noticed some wired error using Maestro creating fusion/flexible layout. You
need to manually making sure the preview URL is correct.

https://yoursite/mapguide/fusion/templates/mapguide/index.php?template=limegold?ApplicationDefinition=Library://QualicumBeach/FlexibleLayouts/Property.ApplicationDefinition&locale=en

It has two "?" for URL parameters, but it should only be "?" for the first
URL parameter, and using & for the rest URL parameter such as
APplicationDefinition.

https://yoursite/mapguide/fusion/templates/mapguide/index.php?template=limegold&ApplicationDefinition=Library://QualicumBeach/FlexibleLayouts/Property.ApplicationDefinition&locale=en

Hope this help you!




--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
mapguide-users@lists.osgeo.org
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: Missing required parameter: ApplicationDefinition

maabas
Wow!!! Thanks for the fast response and the pinpoint answer! That really
solved my problem haha. Now I need to make the google map work with my old
layers once again in 3.1.2. Thanks again RenoSun!



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users