MetaSearch dependencies

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

MetaSearch dependencies

Matthias Kuhn
Hi,

When starting my freshly packaged QGIS 2.6 builds on Fedora I get
warnings about missing packages:

mpl_toolkits
zope

As MetaSearch is now installed as core plugin and therefore by the
systems package management system it should take care of these
dependencies. However, I am not sure, which packages exactly are
required. I have python-matplotlib installed, so that cannot be the
missing part. For zope there are a lot of different options available.

I have pasted the search results here: http://pastebin.com/AmW2BTBe

What could it be? And are there any other dependencies I might need to
satisfy for a properly working MetaSearch plugin.

Regards,
Matthias
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: MetaSearch dependencies

Jürgen E. Fischer
Hi Matthias,

On Sat, 28. Jun 2014 at 16:52:48 +0200, Matthias Kuhn wrote:
> When starting my freshly packaged QGIS 2.6 builds on Fedora I get
> warnings about missing packages:
>
> mpl_toolkits
> zope

2.6?  That's a bit early. ;)

matplotlib is a dependency of processing now.  Maybe mpl_toolkits is an
dependency of that?  No idea about zope.

The dependencies MetaSearch needs are in python/ext-libs.  No matplotlib or
zope there.  So I doubt that was introduced by MetaSearch.


JÃrgen

--
Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-31
Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
Software Engineer         D-26506 Norden               http://www.norbit.de
QGIS PSC member (RM)      Germany                      IRC: jef on FreeNode                        

--
norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
Rheinstrasse 13, 26506 Norden
GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502

_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: MetaSearch dependencies

Tom Kralidis
Confirm. Those libs are outside of / not required by MetaSearch.

Sent from my iPhone

> On Jun 28, 2014, at 12:42, Jürgen E. Fischer <[hidden email]> wrote:
>
> Hi Matthias,
>
>> On Sat, 28. Jun 2014 at 16:52:48 +0200, Matthias Kuhn wrote:
>> When starting my freshly packaged QGIS 2.6 builds on Fedora I get
>> warnings about missing packages:
>>
>> mpl_toolkits
>> zope
>
> 2.6?  That's a bit early. ;)
>
> matplotlib is a dependency of processing now.  Maybe mpl_toolkits is an
> dependency of that?  No idea about zope.
>
> The dependencies MetaSearch needs are in python/ext-libs.  No matplotlib or
> zope there.  So I doubt that was introduced by MetaSearch.
>
>
> JÃrgen
>
> --
> Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-31
> Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
> Software Engineer         D-26506 Norden               http://www.norbit.de
> QGIS PSC member (RM)      Germany                      IRC: jef on FreeNode                        
>
> --
> norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
> Rheinstrasse 13, 26506 Norden
> GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502
>
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: MetaSearch dependencies

volaya
matplotlib is a dependency of a few algorithms in Processing, but it was giving a lot of problems, so those algorithms are disabled since some time ago. If matplotlib is not used by anything else, I guess it can be removed if needed.


2014-06-28 21:41 GMT+02:00 Tom Kralidis <[hidden email]>:
Confirm. Those libs are outside of / not required by MetaSearch.

Sent from my iPhone

> On Jun 28, 2014, at 12:42, Jürgen E. Fischer <[hidden email]> wrote:
>
> Hi Matthias,
>
>> On Sat, 28. Jun 2014 at 16:52:48 +0200, Matthias Kuhn wrote:
>> When starting my freshly packaged QGIS 2.6 builds on Fedora I get
>> warnings about missing packages:
>>
>> mpl_toolkits
>> zope
>
> 2.6?  That's a bit early. ;)
>
> matplotlib is a dependency of processing now.  Maybe mpl_toolkits is an
> dependency of that?  No idea about zope.
>
> The dependencies MetaSearch needs are in python/ext-libs.  No matplotlib or
> zope there.  So I doubt that was introduced by MetaSearch.
>
>
> JÃrgen
>
> --
> Jürgen E. Fischer         norBIT GmbH               Tel. +49-4931-918175-31
> Dipl.-Inf. (FH)           Rheinstraße 13            Fax. +49-4931-918175-50
> Software Engineer         D-26506 Norden               http://www.norbit.de
> QGIS PSC member (RM)      Germany                      IRC: jef on FreeNode
>
> --
> norBIT Gesellschaft fuer Unternehmensberatung und Informationssysteme mbH
> Rheinstrasse 13, 26506 Norden
> GF: Jelto Buurman, HR: Amtsgericht Emden, HRB 5502
>
> _______________________________________________
> Qgis-developer mailing list
> [hidden email]
> http://lists.osgeo.org/mailman/listinfo/qgis-developer
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer


_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: MetaSearch dependencies

pcav
Il 28/06/2014 23:13, Victor Olaya ha scritto:
> matplotlib is a dependency of a few algorithms in Processing, but it was
> giving a lot of problems, so those algorithms are disabled since some
> time ago. If matplotlib is not used by anything else, I guess it can be

Which algs exactly?
Thanks.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer
Reply | Threaded
Open this post in threaded view
|

Re: MetaSearch dependencies

Matthias Kuhn
In reply to this post by Tom Kralidis
I am not sure exactly if it's really a dependency problem. I pasted the
warnings here, it mentions MetaSearch, that's why I thought it is
related. But as it is complaining about a missing __init__.py in a
python site-packages directory it might as well be a distribution or
local configuration issue. Maybe somebody with more python experience
can shed some light on this.

http://pastebin.com/RiNwcjud
>> On Jun 28, 2014, at 12:42, Jürgen E. Fischer <[hidden email]> wrote:
>>
>> 2.6?  That's a bit early. ;)

Arc is already at 10.2... That puts some pressure on us :)

Matthias
_______________________________________________
Qgis-developer mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/qgis-developer