Mapguide 3.1 Add layer on runtime c#

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Mapguide 3.1 Add layer on runtime c#

makoychan
Hi,

I was able to add a new layer using mapguide api 3.1 c#  hit forcerefresh
and map.save(resource) but when i try to access it on javascript i still
cant see the new layer.

On Mapguide 2.6.1 and fusion 2.6 my code is working fine.

Any thoughts or help? been stuck here for quite a while.

Thanks in advance.



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: Mapguide 3.1 Add layer on runtime c#

Jackie Ng
Call save without parameters.

This API was removed in MGOS 3.0, why this didn't trigger a compilation
error on your end is strange, unless your application code was still
referencing .net assemblies from your MGOS 2.6 install.

- Jackie



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: Mapguide 3.1 Add layer on runtime c#

makoychan
Thanks Jackie. It worked.

For some reason, the function is accepting both with and without parameter.
As soon as i remove the paramter everything worked.



--
Sent from: http://osgeo-org.1560.x6.nabble.com/MapGuide-Users-f4182607.html
_______________________________________________
mapguide-users mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapguide-users