Mapbuilder and Firefox 4.0

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Mapbuilder and Firefox 4.0

Magalie
Hi list,

My web application that uses MapBuilder doesn't work on FF 4.0. I've tried to change my Mapbuilder version with the trunk version without results.

The problem seems to be the file WidgetBaseXSL.js with function ".setAttribute".

I've also tested with new IE9 on Vista and everything is OK with compatibility mode.


Do you have any suggestions?
Thanks in advance.

Magalie
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mapbuilder and Firefox 4.0

Bernhard Kiselka
Hi Magalie!

You were just a few days too early.

I did a change to support WebKit Browsers as well as Firefox 4.0 with revision 4067

See
http://osgeo-org.1803224.n2.nabble.com/Anyone-interested-in-a-new-Mapbuilder-release-tt5662933.html

Bernhard
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Mapbuilder and Firefox 4.0

Magalie
Hi Bernhard,

I've seen your changes to support FF4 and thanks for that !
It works for a large part of my application, unfortunately I must also add changes in widgets that you don't use (in particular custom widgets).
I don't have time at the moment but I'll look that as soon as possible. Moreover I hope I would be able to modify these because I'm not expert in javascript developments !

Anyway, thank you for your work on MapBuilder !
Kind regards
Loading...