[Mapbender] #919: missing group layer leads to map viewer breakdown

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[Mapbender] #919: missing group layer leads to map viewer breakdown

mapbender-dev mailing list
#919: missing group layer leads to map viewer breakdown
------------------------------+-----------------
 Reporter:  SvenLVGL          |      Owner:  dev
     Type:  defect            |     Status:  new
 Priority:  major             |  Milestone:
Component:  core              |    Version:
 Keywords:  viewer wms layer  |
------------------------------+-----------------
 **Describe the bug**

 The entire map viewer breaks down if it tries to load WMS group layer that
 no longer exists.

 **To Reproduce**

 Steps to reproduce the behavior:
 1. Register an WMS in a GUI or WMC
 2. Update the WMS in a way that it replaces a group layer
 3. Open the GUI or WMC containing the missing group layer
 4. See error: map viewer fail loading any content and break down the
 entire browser window

 **Expected behavior**

 The viewer should still be able to function. The missing layergroup or
 entire WMS should be deselected, but other WMS / layers should be shown.

 **Desktop (please complete the following information):**
  - Opened in Chrome 75 (and other Platforms
  - Adjusted Mapbender2 Version
  - Debian 8 "Jessie"

 **Additional context**

 GUIs and WMCs should either be able to load the WMS dynamically or be
 updated automatically.

--
Ticket URL: <https://trac.osgeo.org/mapbender/ticket/919>
Mapbender <http://www.mapbender.org/>
Mapbender

_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev