Mapbender 3.0.8 released 2019-04-12

Next Topic
 
classic Classic list List threaded Threaded
11 messages Options
Reply | Threaded
Open this post in threaded view
|

Mapbender 3.0.8 released 2019-04-12

Astrid Emde (WhereGroup)
See german version below

============ english =================

Dear Mapbender-Users and Mapbender-Developers,

on 2018-04-12 we published version 3.0.8 of Mapbender. Thanks to all
people involved!

This version is a long-term-support version (LTS version) with some new
features and several bugfixes. We will provide security fixes for the
LTS verson till 2021-03-31.

Please refer to changelog to find out about the changes [1]

Download: https://mapbender.org/?q=en/download or directly via the link
[2].

Tag v3.0.8 at GitHub [3]
https://github.com/mapbender/mapbender-starter/releases/tag/v3.0.8

There are some changes in the database. So please please call the
doctrine:schema:update command to update the database. See
documentation: https://doc.mapbender.org/en/installation/update.html

If you would like to work and develop with the source code read the
Developer Guide (Contributing.md) [4]:
https://github.com/mapbender/mapbender-starter/blob/master/CONTRIBUTING.md

Report bugs [5]: https://github.com/mapbender/mapbender/issues

Documentation [6]: https://doc.mapbender.org/en/

Installation and Update: https://doc.mapbender.org/en/installation.html

Try Mapbender and follow the Mapbender quickstart
https://doc.mapbender.org/en/quickstart.html

Mapbender-demo [7] https://demo.mapbender.org/

The Mapbender team is working on the next version 3.1. We plan to
publish this version in 2019. This version will use OpenLayers 4 and
will provide a responsive design. This is the biggest change of the last
years for the software. The Team says thank you to all the sponsors for
the financial support and to the community. Sponsors for Mapbender 3.1
are Vattenfall, Stromnetz Hamburg and City of Gütersloh and City of
Troisdorf.

Best regards

Mapbender Team

============= deutsch ===============

Hallo Mapbender-Community,

das Mapbender-Entwicklungsteam hat die Mapbender-Version 3.0.8. am
12.8.2019 veröffentlicht. Herzlichen Dank an alle Beteiligten.

Es handelt sich bei dieser Version um eine Long-Term-Support-Version
(LTS-Version).

Der Schwerpunkt wurde hier auf Stabilität und Performanz gelegt.
Zahlreiche kleinere Bugs wurden gefixt, mehrere neue Features der
letzten Versionen optimiert und alles umfangreich getestet.

Highlights der neuen Version sind u.a. :
Performanz, Sicherheit und Einbindung wurden verbessert für den
Dimensionhandler, das Redlining, die Einbindung von Funktionen in das
Sidepane und das Mobile Template.
Das neue Feature in der Druck-Engine, die Warteschleife für
Druckaufträge, ermöglicht den Druck von A0 auch ohne Print-Server.
Außerdem werden große Legendenbilder besser skaliert und mehrzeilige
Fließtexte in Freifelder und Titel unterstützt.
Layer-Titel können beim WMS-Reload nun automatisch aktualisiert werden.

Alle Überarbeitungen im Detail können dem Change-Log [1] entnommen
werden. Insgesamt handelt es sich um über 50 Enhancements und Fixes.

Die Version 3.0.8. wird als LTS-Version bis zum 31.03.2021 mit
Sicherheitsaktualisierungen versorgt.

Für 2019 ist außerdem die Veröffentlichung der Mapbender-Version 3.1
vorgesehen. Damit verbunden ist die Anhebung des Kartenframeworks auf
OpenLayers 4 und ein Responsive Design geplant. Dies ist die größte
Veränderung der Software der letzten Jahre. Das Team bedankt sich an
dieser Stelle für die finanzielle Unterstützung, die es aus der
Community gab. Dazu gehören u. a. Vattenfall, Stromnetz Hamburg sowie
die Städte Gütersloh und Troisdorf.

Download 3.0.8: http://mapbender.org/?q=de/download oder direkt unter
[2].

Tag v3.0.8 auf GitHub [3]
https://github.com/mapbender/mapbender-starter/releases/tag/v3.0.8

Es liegen ein paar Änderungen in der Datenbank vor. Führen Sie daher
doctrine:schema:update durch. Siehe Dokumentation:
https://doc.mapbender.org/de/installation/update.html

Helfen Sie mit Mapbender weiterzuentwickeln: Developer Guide
(Contributing.md) [4]
https://github.com/mapbender/mapbender-starter/blob/master/CONTRIBUTING.md

Melden Sie Bugs [5]: https://github.com/mapbender/mapbender/issues

Dokumentation [6]: https://doc.mapbender.org/de/

Informationen zur Installation und Aktualisierung auf eine neue Version:
http://doc.mapbender.org/de/installation.html

Probieren Sie Mapbender aus. Es gibt ein Mapbender-Tutorial, das die
ersten Schritte mit Ihnen durchgeht:
https://doc.mapbender.org/de/quickstart.html

Probieren Sie die neue Version direkt aus: Mapbender-Demo [7]
https://demo.mapbender.org/

Viel Spaß mit der neuen Version wünscht

Das Mapbender Team

Links
---------------

[1] https://github.com/mapbender/mapbender/releases

[2] https://www.mapbender.org/builds/mapbender-starter-current.tar.gz

[3] https://github.com/mapbender/mapbender-starter/releases/tag/v3.0.8

[4]
https://github.com/mapbender/mapbender-starter/blob/master/CONTRIBUTING.md

[5] https://github.com/mapbender/mapbender/issues

[6] https://doc.mapbender.org/

[7] Mapbender-Demo: https://demo.mapbender.org/
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

jmckenna
Administrator
The release tags are missing a required file /app/bootstrap.php.cache

-jeff



--
Jeff McKenna
MapServer Consulting and Training Services
https://gatewaygeomatics.com/




On 2019-04-12 7:38 AM, Astrid Emde (WhereGroup) wrote:

> See german version below
>
> ============ english =================
>
> Dear Mapbender-Users and Mapbender-Developers,
>
> on 2018-04-12 we published version 3.0.8 of Mapbender. Thanks to all
> people involved!
>
> This version is a long-term-support version (LTS version) with some new
> features and several bugfixes. We will provide security fixes for the
> LTS verson till 2021-03-31.
>
> Please refer to changelog to find out about the changes [1]
>
> Download: https://mapbender.org/?q=en/download or directly via the link
> [2].
>
> Tag v3.0.8 at GitHub [3]
> https://github.com/mapbender/mapbender-starter/releases/tag/v3.0.8
>
> There are some changes in the database. So please please call the
> doctrine:schema:update command to update the database. See
> documentation: https://doc.mapbender.org/en/installation/update.html
>
> If you would like to work and develop with the source code read the
> Developer Guide (Contributing.md) [4]:
> https://github.com/mapbender/mapbender-starter/blob/master/CONTRIBUTING.md
>
> Report bugs [5]: https://github.com/mapbender/mapbender/issues
>
> Documentation [6]: https://doc.mapbender.org/en/
>
> Installation and Update: https://doc.mapbender.org/en/installation.html
>
> Try Mapbender and follow the Mapbender quickstart
> https://doc.mapbender.org/en/quickstart.html
>
> Mapbender-demo [7] https://demo.mapbender.org/
>
> The Mapbender team is working on the next version 3.1. We plan to
> publish this version in 2019. This version will use OpenLayers 4 and
> will provide a responsive design. This is the biggest change of the last
> years for the software. The Team says thank you to all the sponsors for
> the financial support and to the community. Sponsors for Mapbender 3.1
> are Vattenfall, Stromnetz Hamburg and City of Gütersloh and City of
> Troisdorf.
>
> Best regards
>
> Mapbender Team
>
> ============= deutsch ===============
>
> Hallo Mapbender-Community,
>
> das Mapbender-Entwicklungsteam hat die Mapbender-Version 3.0.8. am
> 12.8.2019 veröffentlicht. Herzlichen Dank an alle Beteiligten.
>
> Es handelt sich bei dieser Version um eine Long-Term-Support-Version
> (LTS-Version).
>
> Der Schwerpunkt wurde hier auf Stabilität und Performanz gelegt.
> Zahlreiche kleinere Bugs wurden gefixt, mehrere neue Features der
> letzten Versionen optimiert und alles umfangreich getestet.
>
> Highlights der neuen Version sind u.a. :
> Performanz, Sicherheit und Einbindung wurden verbessert für den
> Dimensionhandler, das Redlining, die Einbindung von Funktionen in das
> Sidepane und das Mobile Template.
> Das neue Feature in der Druck-Engine, die Warteschleife für
> Druckaufträge, ermöglicht den Druck von A0 auch ohne Print-Server.
> Außerdem werden große Legendenbilder besser skaliert und mehrzeilige
> Fließtexte in Freifelder und Titel unterstützt.
> Layer-Titel können beim WMS-Reload nun automatisch aktualisiert werden.
>
> Alle Überarbeitungen im Detail können dem Change-Log [1] entnommen
> werden. Insgesamt handelt es sich um über 50 Enhancements und Fixes.
>
> Die Version 3.0.8. wird als LTS-Version bis zum 31.03.2021 mit
> Sicherheitsaktualisierungen versorgt.
>
> Für 2019 ist außerdem die Veröffentlichung der Mapbender-Version 3.1
> vorgesehen. Damit verbunden ist die Anhebung des Kartenframeworks auf
> OpenLayers 4 und ein Responsive Design geplant. Dies ist die größte
> Veränderung der Software der letzten Jahre. Das Team bedankt sich an
> dieser Stelle für die finanzielle Unterstützung, die es aus der
> Community gab. Dazu gehören u. a. Vattenfall, Stromnetz Hamburg sowie
> die Städte Gütersloh und Troisdorf.
>
> Download 3.0.8: http://mapbender.org/?q=de/download oder direkt unter [2].
>
> Tag v3.0.8 auf GitHub [3]
> https://github.com/mapbender/mapbender-starter/releases/tag/v3.0.8
>
> Es liegen ein paar Änderungen in der Datenbank vor. Führen Sie daher
> doctrine:schema:update durch. Siehe Dokumentation:
> https://doc.mapbender.org/de/installation/update.html
>
> Helfen Sie mit Mapbender weiterzuentwickeln: Developer Guide
> (Contributing.md) [4]
> https://github.com/mapbender/mapbender-starter/blob/master/CONTRIBUTING.md
>
> Melden Sie Bugs [5]: https://github.com/mapbender/mapbender/issues
>
> Dokumentation [6]: https://doc.mapbender.org/de/
>
> Informationen zur Installation und Aktualisierung auf eine neue Version:
> http://doc.mapbender.org/de/installation.html
>
> Probieren Sie Mapbender aus. Es gibt ein Mapbender-Tutorial, das die
> ersten Schritte mit Ihnen durchgeht:
> https://doc.mapbender.org/de/quickstart.html
>
> Probieren Sie die neue Version direkt aus: Mapbender-Demo [7]
> https://demo.mapbender.org/
>
> Viel Spaß mit der neuen Version wünscht
>
> Das Mapbender Team
>
> Links
> ---------------
>
> [1] https://github.com/mapbender/mapbender/releases
>
> [2] https://www.mapbender.org/builds/mapbender-starter-current.tar.gz
>
> [3] https://github.com/mapbender/mapbender-starter/releases/tag/v3.0.8
>
> [4]
> https://github.com/mapbender/mapbender-starter/blob/master/CONTRIBUTING.md
>
> [5] https://github.com/mapbender/mapbender/issues
>
> [6] https://doc.mapbender.org/
>
> [7] Mapbender-Demo: https://demo.mapbender.org/
> _______________________________________________
> Mapbender_dev mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_dev

_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

Rolf Neuberger
This is generated code. It's not under version control.
The file is automatically generated by the bootstrap script in the
project root, and implicitly also every time a compser package is
installed or updated.

You can explicitly trigger just the rebuild with a shell command:
application$ bin/composer run build-bootstrap

HTH,
-Rolf

On 12.04.19 14:38, Jeff McKenna wrote:
> The release tags are missing a required file /app/bootstrap.php.cache
>
> -jeff
>
>
>

--
Rolf Neuberger
WhereGroup GmbH & Co. KG
Eifelstraße 7
53119 Bonn
Germany

Fon: +49 (0)228 / 90 90 38 - 0
Fax: +49 (0)228 / 90 90 38 - 11

[hidden email]
www.wheregroup.com
Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

jmckenna
Administrator
For example: mapbender3-starter-3.0.7.7.zip contained that missing file
(which I realize is not under version control, but was packaged in
previous releases).

I have never had to run that command in any previous release.  I also
notice that that command is not part of the Mapbender installation
documentation.

So my point is, something has changed with that 3.0.8 archive.

-jeff





On 2019-04-15 5:31 AM, Rolf Neuberger wrote:

> This is generated code. It's not under version control.
> The file is automatically generated by the bootstrap script in the
> project root, and implicitly also every time a compser package is
> installed or updated.
>
> You can explicitly trigger just the rebuild with a shell command:
> application$ bin/composer run build-bootstrap
>
> HTH,
> -Rolf
>
> On 12.04.19 14:38, Jeff McKenna wrote:
>> The release tags are missing a required file /app/bootstrap.php.cache
>>
>> -jeff
>>
>>
>>
>

_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

jmckenna
Administrator
For the record here is the new error with 3.0.8:

{{{
Warning:
require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
failed to open stream: No such file or directory in
C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6

Fatal error: require_once(): Failed opening required
'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
(include_path='.;\ms4w\Apache\php') in
C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
}}}

-jeff




On 2019-04-15 8:45 AM, Jeff McKenna wrote:

> For example: mapbender3-starter-3.0.7.7.zip contained that missing file
> (which I realize is not under version control, but was packaged in
> previous releases).
>
> I have never had to run that command in any previous release.  I also
> notice that that command is not part of the Mapbender installation
> documentation.
>
> So my point is, something has changed with that 3.0.8 archive.
>
> -jeff
>
>
>
>
>
> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>> This is generated code. It's not under version control.
>> The file is automatically generated by the bootstrap script in the
>> project root, and implicitly also every time a compser package is
>> installed or updated.
>>
>> You can explicitly trigger just the rebuild with a shell command:
>> application$ bin/composer run build-bootstrap
>>
>> HTH,
>> -Rolf
>>
>> On 12.04.19 14:38, Jeff McKenna wrote:
>>> The release tags are missing a required file /app/bootstrap.php.cache
>>>
>>> -jeff
>>>
>>>
>>>
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

jmckenna
Administrator
Here is a history of that file being included in past release archives:

- 3.0.8: missing
- 3.0.7.7: included in /app/bootstrap.php.cache
- 3.0.6.3: included in /app/bootstrap.php.cache
- 3.0.6.2: included in /app/bootstrap.php.cache
- 3.0.6.1: included in /app/bootstrap.php.cache
- 3.0.5.3: included in /app/bootstrap.php.cache

-jeff



On 2019-04-15 9:00 AM, Jeff McKenna wrote:

> For the record here is the new error with 3.0.8:
>
> {{{
> Warning:
> require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
> failed to open stream: No such file or directory in
> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>
> Fatal error: require_once(): Failed opening required
> 'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
> (include_path='.;\ms4w\Apache\php') in
> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
> }}}
>
> -jeff
>
>
>
>
> On 2019-04-15 8:45 AM, Jeff McKenna wrote:
>> For example: mapbender3-starter-3.0.7.7.zip contained that missing
>> file (which I realize is not under version control, but was packaged
>> in previous releases).
>>
>> I have never had to run that command in any previous release.  I also
>> notice that that command is not part of the Mapbender installation
>> documentation.
>>
>> So my point is, something has changed with that 3.0.8 archive.
>>
>> -jeff
>>
>>
>>
>>
>>
>> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>>> This is generated code. It's not under version control.
>>> The file is automatically generated by the bootstrap script in the
>>> project root, and implicitly also every time a compser package is
>>> installed or updated.
>>>
>>> You can explicitly trigger just the rebuild with a shell command:
>>> application$ bin/composer run build-bootstrap
>>>
>>> HTH,
>>> -Rolf
>>>
>>> On 12.04.19 14:38, Jeff McKenna wrote:
>>>> The release tags are missing a required file /app/bootstrap.php.cache
>>>>
>>>> -jeff
>>>>
>>>>
>>>>
> _______________________________________________
> Mapbender_dev mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_dev


--
Jeff McKenna
MapServer Consulting and Training Services
https://gatewaygeomatics.com/
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

Rolf Neuberger
Hi again Jeff,
regarding the zip archives, we had some unfinshed packaging work on
Friday, and going by the time stamps, it seems you caught an earlier
version of the download where the build hadn't run properly.
The updated zip package now available from
https://mapbender.org/download does contain the bootstrap.php.cache file
you're missing. Please download again.

The package has been regenerated on Friday 15:42 German summer time.

Sorry for the inconvenience.

On 15.04.19 14:39, Jeff McKenna wrote:

> Here is a history of that file being included in past release archives:
>
> - 3.0.8: missing
> - 3.0.7.7: included in /app/bootstrap.php.cache
> - 3.0.6.3: included in /app/bootstrap.php.cache
> - 3.0.6.2: included in /app/bootstrap.php.cache
> - 3.0.6.1: included in /app/bootstrap.php.cache
> - 3.0.5.3: included in /app/bootstrap.php.cache
>
> -jeff
>
>
>
> On 2019-04-15 9:00 AM, Jeff McKenna wrote:
>> For the record here is the new error with 3.0.8:
>>
>> {{{
>> Warning:
>> require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
>> failed to open stream: No such file or directory in
>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>>
>> Fatal error: require_once(): Failed opening required
>> 'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
>> (include_path='.;\ms4w\Apache\php') in
>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>> }}}
>>
>> -jeff
>>
>>
>>
>>
>> On 2019-04-15 8:45 AM, Jeff McKenna wrote:
>>> For example: mapbender3-starter-3.0.7.7.zip contained that missing
>>> file (which I realize is not under version control, but was packaged
>>> in previous releases).
>>>
>>> I have never had to run that command in any previous release.  I also
>>> notice that that command is not part of the Mapbender installation
>>> documentation.
>>>
>>> So my point is, something has changed with that 3.0.8 archive.
>>>
>>> -jeff
>>>
>>>
>>>
>>>
>>>
>>> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>>>> This is generated code. It's not under version control.
>>>> The file is automatically generated by the bootstrap script in the
>>>> project root, and implicitly also every time a compser package is
>>>> installed or updated.
>>>>
>>>> You can explicitly trigger just the rebuild with a shell command:
>>>> application$ bin/composer run build-bootstrap
>>>>
>>>> HTH,
>>>> -Rolf
>>>>
>>>> On 12.04.19 14:38, Jeff McKenna wrote:
>>>>> The release tags are missing a required file /app/bootstrap.php.cache
>>>>>
>>>>> -jeff
>>>>>
>>>>>
>>>>>
>> _______________________________________________
>> Mapbender_dev mailing list
>> [hidden email]
>> https://lists.osgeo.org/mailman/listinfo/mapbender_dev
>
>

--
Rolf Neuberger
WhereGroup GmbH & Co. KG
Eifelstraße 7
53119 Bonn
Germany

Fon: +49 (0)228 / 90 90 38 - 0
Fax: +49 (0)228 / 90 90 38 - 11

[hidden email]
www.wheregroup.com
Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

jmckenna
Administrator
Hi Rolf,

No problem I definitely understand.  Thanks, will re-download.

-jeff



On 2019-04-15 9:50 AM, Rolf Neuberger wrote:

> Hi again Jeff,
> regarding the zip archives, we had some unfinshed packaging work on
> Friday, and going by the time stamps, it seems you caught an earlier
> version of the download where the build hadn't run properly.
> The updated zip package now available from
> https://mapbender.org/download does contain the bootstrap.php.cache file
> you're missing. Please download again.
>
> The package has been regenerated on Friday 15:42 German summer time.
>
> Sorry for the inconvenience.
>
> On 15.04.19 14:39, Jeff McKenna wrote:
>> Here is a history of that file being included in past release archives:
>>
>> - 3.0.8: missing
>> - 3.0.7.7: included in /app/bootstrap.php.cache
>> - 3.0.6.3: included in /app/bootstrap.php.cache
>> - 3.0.6.2: included in /app/bootstrap.php.cache
>> - 3.0.6.1: included in /app/bootstrap.php.cache
>> - 3.0.5.3: included in /app/bootstrap.php.cache
>>
>> -jeff
>>
>>
>>
>> On 2019-04-15 9:00 AM, Jeff McKenna wrote:
>>> For the record here is the new error with 3.0.8:
>>>
>>> {{{
>>> Warning:
>>> require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
>>> failed to open stream: No such file or directory in
>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>>>
>>> Fatal error: require_once(): Failed opening required
>>> 'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
>>> (include_path='.;\ms4w\Apache\php') in
>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>>> }}}
>>>
>>> -jeff
>>>
>>>
>>>
>>>
>>> On 2019-04-15 8:45 AM, Jeff McKenna wrote:
>>>> For example: mapbender3-starter-3.0.7.7.zip contained that missing
>>>> file (which I realize is not under version control, but was packaged
>>>> in previous releases).
>>>>
>>>> I have never had to run that command in any previous release.  I
>>>> also notice that that command is not part of the Mapbender
>>>> installation documentation.
>>>>
>>>> So my point is, something has changed with that 3.0.8 archive.
>>>>
>>>> -jeff
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>>>>> This is generated code. It's not under version control.
>>>>> The file is automatically generated by the bootstrap script in the
>>>>> project root, and implicitly also every time a compser package is
>>>>> installed or updated.
>>>>>
>>>>> You can explicitly trigger just the rebuild with a shell command:
>>>>> application$ bin/composer run build-bootstrap
>>>>>
>>>>> HTH,
>>>>> -Rolf
>>>>>
>>>>> On 12.04.19 14:38, Jeff McKenna wrote:
>>>>>> The release tags are missing a required file /app/bootstrap.php.cache
>>>>>>
>>>>>> -jeff
>>>>>>
>>>>>>
>>>>>>
>>> _______________________________________________
>>> Mapbender_dev mailing list
>>> [hidden email]
>>> https://lists.osgeo.org/mailman/listinfo/mapbender_dev
>>
>>
>


--
Jeff McKenna
MapServer Consulting and Training Services
https://gatewaygeomatics.com/
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

Astrid Emde (WhereGroup)
Hello Jeff,

thanks for supporting the Mapbender project.

Looking forward to have 3.0.8 on MS4W :)

Feedback from our last Winterschool: Some participants wanted to use the
stack on their windows machines (instead of OSGeoLive). It was so easy
to setup Mapbender & MapServer with MS4W. Great! They were impressed.
Thanks for providing MS4W!

https://ms4w.com/

Astrid


Am 2019-04-15 14:55, schrieb Jeff McKenna:

> Hi Rolf,
>
> No problem I definitely understand.  Thanks, will re-download.
>
> -jeff
>
>
>
> On 2019-04-15 9:50 AM, Rolf Neuberger wrote:
>> Hi again Jeff,
>> regarding the zip archives, we had some unfinshed packaging work on
>> Friday, and going by the time stamps, it seems you caught an earlier
>> version of the download where the build hadn't run properly.
>> The updated zip package now available from
>> https://mapbender.org/download does contain the bootstrap.php.cache
>> file you're missing. Please download again.
>>
>> The package has been regenerated on Friday 15:42 German summer time.
>>
>> Sorry for the inconvenience.
>>
>> On 15.04.19 14:39, Jeff McKenna wrote:
>>> Here is a history of that file being included in past release
>>> archives:
>>>
>>> - 3.0.8: missing
>>> - 3.0.7.7: included in /app/bootstrap.php.cache
>>> - 3.0.6.3: included in /app/bootstrap.php.cache
>>> - 3.0.6.2: included in /app/bootstrap.php.cache
>>> - 3.0.6.1: included in /app/bootstrap.php.cache
>>> - 3.0.5.3: included in /app/bootstrap.php.cache
>>>
>>> -jeff
>>>
>>>
>>>
>>> On 2019-04-15 9:00 AM, Jeff McKenna wrote:
>>>> For the record here is the new error with 3.0.8:
>>>>
>>>> {{{
>>>> Warning:
>>>> require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
>>>> failed to open stream: No such file or directory in
>>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line
>>>> 6
>>>>
>>>> Fatal error: require_once(): Failed opening required
>>>> 'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
>>>> (include_path='.;\ms4w\Apache\php') in
>>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line
>>>> 6
>>>> }}}
>>>>
>>>> -jeff
>>>>
>>>>
>>>>
>>>>
>>>> On 2019-04-15 8:45 AM, Jeff McKenna wrote:
>>>>> For example: mapbender3-starter-3.0.7.7.zip contained that missing
>>>>> file (which I realize is not under version control, but was
>>>>> packaged in previous releases).
>>>>>
>>>>> I have never had to run that command in any previous release.  I
>>>>> also notice that that command is not part of the Mapbender
>>>>> installation documentation.
>>>>>
>>>>> So my point is, something has changed with that 3.0.8 archive.
>>>>>
>>>>> -jeff
>>>>>
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>>>>>> This is generated code. It's not under version control.
>>>>>> The file is automatically generated by the bootstrap script in the
>>>>>> project root, and implicitly also every time a compser package is
>>>>>> installed or updated.
>>>>>>
>>>>>> You can explicitly trigger just the rebuild with a shell command:
>>>>>> application$ bin/composer run build-bootstrap
>>>>>>
>>>>>> HTH,
>>>>>> -Rolf
>>>>>>
>>>>>> On 12.04.19 14:38, Jeff McKenna wrote:
>>>>>>> The release tags are missing a required file
>>>>>>> /app/bootstrap.php.cache
>>>>>>>
>>>>>>> -jeff
>>>>>>>
>>>>>>>
>>>>>>>
>>>> _______________________________________________
>>>> Mapbender_dev mailing list
>>>> [hidden email]
>>>> https://lists.osgeo.org/mailman/listinfo/mapbender_dev
>>>
>>>
>>

--
Mit freundlichen Grüßen

Astrid Emde
GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------

   Astrid Emde
   WhereGroup GmbH & Co.KG
   Eifelstraße 7
   53119 Bonn
   Germany

   Fon: +49(0)228 90 90 38 - 22
   Fax: +49(0)228 90 90 38 - 11

   [hidden email]
   www.wheregroup.com

   Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

jmckenna
Administrator
Thanks for the great feedback Astrid!

The MS4W 4.0.0 installer now includes Mapbender 3.0.8  https://ms4w.com


--

Thank you for using MS4W.
"MS4W: open doors as well as windows"


-jeff


--
Jeff McKenna
MapServer Consulting and Training Services
https://gatewaygeomatics.com/



On 2019-04-17 3:37 AM, Astrid Emde (WhereGroup) wrote:

> Hello Jeff,
>
> thanks for supporting the Mapbender project.
>
> Looking forward to have 3.0.8 on MS4W :)
>
> Feedback from our last Winterschool: Some participants wanted to use the
> stack on their windows machines (instead of OSGeoLive). It was so easy
> to setup Mapbender & MapServer with MS4W. Great! They were impressed.
> Thanks for providing MS4W!
>
> https://ms4w.com/
>
> Astrid
>
>
> Am 2019-04-15 14:55, schrieb Jeff McKenna:
>> Hi Rolf,
>>
>> No problem I definitely understand.  Thanks, will re-download.
>>
>> -jeff
>>
>>
>>
>> On 2019-04-15 9:50 AM, Rolf Neuberger wrote:
>>> Hi again Jeff,
>>> regarding the zip archives, we had some unfinshed packaging work on
>>> Friday, and going by the time stamps, it seems you caught an earlier
>>> version of the download where the build hadn't run properly.
>>> The updated zip package now available from
>>> https://mapbender.org/download does contain the bootstrap.php.cache
>>> file you're missing. Please download again.
>>>
>>> The package has been regenerated on Friday 15:42 German summer time.
>>>
>>> Sorry for the inconvenience.
>>>
>>> On 15.04.19 14:39, Jeff McKenna wrote:
>>>> Here is a history of that file being included in past release archives:
>>>>
>>>> - 3.0.8: missing
>>>> - 3.0.7.7: included in /app/bootstrap.php.cache
>>>> - 3.0.6.3: included in /app/bootstrap.php.cache
>>>> - 3.0.6.2: included in /app/bootstrap.php.cache
>>>> - 3.0.6.1: included in /app/bootstrap.php.cache
>>>> - 3.0.5.3: included in /app/bootstrap.php.cache
>>>>
>>>> -jeff
>>>>
>>>>
>>>>
>>>> On 2019-04-15 9:00 AM, Jeff McKenna wrote:
>>>>> For the record here is the new error with 3.0.8:
>>>>>
>>>>> {{{
>>>>> Warning:
>>>>> require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
>>>>> failed to open stream: No such file or directory in
>>>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>>>>>
>>>>> Fatal error: require_once(): Failed opening required
>>>>> 'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
>>>>> (include_path='.;\ms4w\Apache\php') in
>>>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on line 6
>>>>> }}}
>>>>>
>>>>> -jeff
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> On 2019-04-15 8:45 AM, Jeff McKenna wrote:
>>>>>> For example: mapbender3-starter-3.0.7.7.zip contained that missing
>>>>>> file (which I realize is not under version control, but was
>>>>>> packaged in previous releases).
>>>>>>
>>>>>> I have never had to run that command in any previous release.  I
>>>>>> also notice that that command is not part of the Mapbender
>>>>>> installation documentation.
>>>>>>
>>>>>> So my point is, something has changed with that 3.0.8 archive.
>>>>>>
>>>>>> -jeff
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>>>>>>> This is generated code. It's not under version control.
>>>>>>> The file is automatically generated by the bootstrap script in
>>>>>>> the project root, and implicitly also every time a compser
>>>>>>> package is installed or updated.
>>>>>>>
>>>>>>> You can explicitly trigger just the rebuild with a shell command:
>>>>>>> application$ bin/composer run build-bootstrap
>>>>>>>
>>>>>>> HTH,
>>>>>>> -Rolf
>>>>>>>
>>>>>>> On 12.04.19 14:38, Jeff McKenna wrote:
>>>>>>>> The release tags are missing a required file
>>>>>>>> /app/bootstrap.php.cache
>>>>>>>>
>>>>>>>> -jeff
>>>>>>>>
>>>>>>>>
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev
Reply | Threaded
Open this post in threaded view
|

Re: Mapbender 3.0.8 released 2019-04-12

Astrid Emde (WhereGroup)
Wow! Thanks a lot.

Great news!

Astrid

Am 2019-04-17 20:17, schrieb Jeff McKenna:

> Thanks for the great feedback Astrid!
>
> The MS4W 4.0.0 installer now includes Mapbender 3.0.8  https://ms4w.com
>
>
> --
>
> Thank you for using MS4W.
> "MS4W: open doors as well as windows"
>
>
> -jeff
>
>
> --
> Jeff McKenna
> MapServer Consulting and Training Services
> https://gatewaygeomatics.com/
>
>
>
> On 2019-04-17 3:37 AM, Astrid Emde (WhereGroup) wrote:
>> Hello Jeff,
>>
>> thanks for supporting the Mapbender project.
>>
>> Looking forward to have 3.0.8 on MS4W :)
>>
>> Feedback from our last Winterschool: Some participants wanted to use
>> the stack on their windows machines (instead of OSGeoLive). It was so
>> easy to setup Mapbender & MapServer with MS4W. Great! They were
>> impressed. Thanks for providing MS4W!
>>
>> https://ms4w.com/
>>
>> Astrid
>>
>>
>> Am 2019-04-15 14:55, schrieb Jeff McKenna:
>>> Hi Rolf,
>>>
>>> No problem I definitely understand.  Thanks, will re-download.
>>>
>>> -jeff
>>>
>>>
>>>
>>> On 2019-04-15 9:50 AM, Rolf Neuberger wrote:
>>>> Hi again Jeff,
>>>> regarding the zip archives, we had some unfinshed packaging work on
>>>> Friday, and going by the time stamps, it seems you caught an earlier
>>>> version of the download where the build hadn't run properly.
>>>> The updated zip package now available from
>>>> https://mapbender.org/download does contain the bootstrap.php.cache
>>>> file you're missing. Please download again.
>>>>
>>>> The package has been regenerated on Friday 15:42 German summer time.
>>>>
>>>> Sorry for the inconvenience.
>>>>
>>>> On 15.04.19 14:39, Jeff McKenna wrote:
>>>>> Here is a history of that file being included in past release
>>>>> archives:
>>>>>
>>>>> - 3.0.8: missing
>>>>> - 3.0.7.7: included in /app/bootstrap.php.cache
>>>>> - 3.0.6.3: included in /app/bootstrap.php.cache
>>>>> - 3.0.6.2: included in /app/bootstrap.php.cache
>>>>> - 3.0.6.1: included in /app/bootstrap.php.cache
>>>>> - 3.0.5.3: included in /app/bootstrap.php.cache
>>>>>
>>>>> -jeff
>>>>>
>>>>>
>>>>>
>>>>> On 2019-04-15 9:00 AM, Jeff McKenna wrote:
>>>>>> For the record here is the new error with 3.0.8:
>>>>>>
>>>>>> {{{
>>>>>> Warning:
>>>>>> require_once(C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache):
>>>>>> failed to open stream: No such file or directory in
>>>>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on
>>>>>> line 6
>>>>>>
>>>>>> Fatal error: require_once(): Failed opening required
>>>>>> 'C:\ms4w\apps\mapbender-starter-3.0.8\application\web/../app/bootstrap.php.cache'
>>>>>> (include_path='.;\ms4w\Apache\php') in
>>>>>> C:\ms4w\apps\mapbender-starter-3.0.8\application\web\app.php on
>>>>>> line 6
>>>>>> }}}
>>>>>>
>>>>>> -jeff
>>>>>>
>>>>>>
>>>>>>
>>>>>>
>>>>>> On 2019-04-15 8:45 AM, Jeff McKenna wrote:
>>>>>>> For example: mapbender3-starter-3.0.7.7.zip contained that
>>>>>>> missing file (which I realize is not under version control, but
>>>>>>> was packaged in previous releases).
>>>>>>>
>>>>>>> I have never had to run that command in any previous release.  I
>>>>>>> also notice that that command is not part of the Mapbender
>>>>>>> installation documentation.
>>>>>>>
>>>>>>> So my point is, something has changed with that 3.0.8 archive.
>>>>>>>
>>>>>>> -jeff
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>>
>>>>>>> On 2019-04-15 5:31 AM, Rolf Neuberger wrote:
>>>>>>>> This is generated code. It's not under version control.
>>>>>>>> The file is automatically generated by the bootstrap script in
>>>>>>>> the project root, and implicitly also every time a compser
>>>>>>>> package is installed or updated.
>>>>>>>>
>>>>>>>> You can explicitly trigger just the rebuild with a shell
>>>>>>>> command:
>>>>>>>> application$ bin/composer run build-bootstrap
>>>>>>>>
>>>>>>>> HTH,
>>>>>>>> -Rolf
>>>>>>>>
>>>>>>>> On 12.04.19 14:38, Jeff McKenna wrote:
>>>>>>>>> The release tags are missing a required file
>>>>>>>>> /app/bootstrap.php.cache
>>>>>>>>>
>>>>>>>>> -jeff
>>>>>>>>>
>>>>>>>>>
> _______________________________________________
> Mapbender_dev mailing list
> [hidden email]
> https://lists.osgeo.org/mailman/listinfo/mapbender_dev

--
Mit freundlichen Grüßen

Astrid Emde
GIS-Consultant

-----------------------------------
Aufwind durch Wissen!
Qualifizierte Open-Source-Schulungen
bei der www.foss-academy.com
-----------------------------------

   Astrid Emde
   WhereGroup GmbH & Co.KG
   Eifelstraße 7
   53119 Bonn
   Germany

   Fon: +49(0)228 90 90 38 - 22
   Fax: +49(0)228 90 90 38 - 11

   [hidden email]
   www.wheregroup.com

   Folgen Sie der WhereGroup auf twitter:
http://twitter.com/WhereGroup_com

Amtsgericht Bonn, HRA 6788
-------------------------------
Komplementärin:
WhereGroup Verwaltungs GmbH
vertreten durch:
Olaf Knopp, Peter Stamm
-------------------------------
_______________________________________________
Mapbender_dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapbender_dev