Mapbender 2 with PHP7

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Mapbender 2 with PHP7

Verena Diewald
Hi all,


short info about running Mapbender 2 with PHP7:

I checked that combination a few days ago. I had to fix some files
because of deprecated/removed php functions, but afterwards it ran fine.

I fixed the following files:

/data/mapbender2/http/classes/class_RPCEndpoint.php
/data/mapbender2/http/classes/class_wfs_conf.php
/data/mapbender2/http/classes/class.pdf.php
/data/mapbender2/http/include/dyn_php.php
/data/mapbender2/http/include/dyn_css.php
/data/mapbender2/http/php/mod_wfs_gazetteer_server.php


I also noticed that it's better to reduce the php log level so that
notices are not logged. There are logged so many notices that the log
file grows really fast.


Best regards,

Verena

--

_______________________________________________
Mapbender_users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapbender_users