MapServer travis broken?

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

MapServer travis broken?

Daniel Morissette
Hi devs,

Who around here is knowledgeable about the MapServer travis server
setup? I noticed that all travis builds in the last few weeks fail with
the following error:

"The command "sudo apt-get remove postgis libpq5 libpq-dev
postgresql-9.1-postgis postgresql-9.1-postgis-2.2-scripts
postgresql-9.2-postgis postgresql-9.3-postgis postgresql-9.1
postgresql-9.2 postgresql-9.3" failed and exited with 100 during ."

https://travis-ci.org/mapserver/mapserver/builds


--
Daniel Morissette
Mapgears Inc
T: +1 418-696-5056 #201
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: MapServer travis broken?

Even Rouault-2

On mercredi 20 septembre 2017 16:10:35 CEST Daniel Morissette wrote:

> Hi devs,

>

> Who around here is knowledgeable about the MapServer travis server

> setup? I noticed that all travis builds in the last few weeks fail with

> the following error:

>

> "The command "sudo apt-get remove postgis libpq5 libpq-dev

> postgresql-9.1-postgis postgresql-9.1-postgis-2.2-scripts

> postgresql-9.2-postgis postgresql-9.3-postgis postgresql-9.1

> postgresql-9.2 postgresql-9.3" failed and exited with 100 during ."

>

> https://travis-ci.org/mapserver/mapserver/builds

 

Daniel,

 

I've just fixed it per

https://github.com/mapserver/mapserver/commit/fc830fa4d8fbaa1b399998a6b38f41eb0c3f10cd

 

This is due to Travis-CI migrating progressively projects from Precise to Trusty

unless they explicitly say in .travis.yml they want to stick with Precise (which

is what I've done)

 

At some point it would be good to update our .travis.yml, with other needed adjustments

(might impact expected results if underlying libraries have slight behaviour changes),

to migrate to Trusty.

 

Even

 

--

Spatialys - Geospatial professional services

http://www.spatialys.com


_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev
Reply | Threaded
Open this post in threaded view
|

Re: MapServer travis broken?

Daniel Morissette
On 2017-09-20 4:31 PM, Even Rouault wrote:

>
> I've just fixed it per
>
> https://github.com/mapserver/mapserver/commit/fc830fa4d8fbaa1b399998a6b38f41eb0c3f10cd
>
> This is due to Travis-CI migrating progressively projects from Precise
> to Trusty
>
> unless they explicitly say in .travis.yml they want to stick with
> Precise (which
>
> is what I've done)
>

Thank you very much Even. I updated my pull request and the Travis tests
passed this time.

Daniel
--
Daniel Morissette
Mapgears Inc
T: +1 418-696-5056 #201
_______________________________________________
mapserver-dev mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapserver-dev