MapServer + OpenLayers zooming problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

MapServer + OpenLayers zooming problem

Akila.Shashith
I have been developing Web GIS. I cought up with this problem. When i am zooming the image (using openlayers) it giving multiple images rather than zoomed image. this is a picture of it





this is my map file

# Map file created from QGIS project file D:/Project/qgis_OL/lanka_line_boundary.qgs
# Edit this file to customize for your map interface
# http://localhost/cgi-bin/mapserv.exe?map=C:\ms4w\Apache\htdocs\lanka_line_boundary.map&layer14_boundary&mode=map
 
MAP
  NAME "QGIS-MAP"
  # Map image size
  SIZE 400 600
  UNITS meters

  EXTENT -250677.251990 71904.913837 589367.563375 526289.116181
  #FONTSET './fonts/fonts.txt'
  #SYMBOLSET './symbols/symbols.txt'
  PROJECTION
    'proj=longlat'
    'ellps=WGS84'
    'datum=WGS84'
    'no_defs'
  END

  # Background color for the map canvas -- change as desired
  IMAGECOLOR 255 255 255
  IMAGEQUALITY 95
  IMAGETYPE png

  OUTPUTFORMAT
    NAME png
    DRIVER 'GD/PNG'
   # MIMETYPE 'image/png'
    IMAGEMODE RGBA
    EXTENSION 'png'
  END
  # Legend
  LEGEND
      IMAGECOLOR 255 255 255
    STATUS ON
    KEYSIZE 18 12
    LABEL
      TYPE BITMAP
      SIZE MEDIUM
      COLOR 0 0 89
    END
  END

  # Web interface definition. Only the template parameter
  # is required to display a map. See MapServer documentation
  WEB
    # Set IMAGEPATH to the path where MapServer should
    # write its output.
    IMAGEPATH 'C:/ms4w/Apache/htdocs/output'

    # Set IMAGEURL to the url that points to IMAGEPATH
    # as defined in your web server configuration
    IMAGEURL 'http://localhost/output'

    # WMS server settings
    METADATA
      'ows_title'           'QGIS-MAP'
      'ows_onlineresource'  'http://localhost/cgi-bin/mapserv.exe?map=C:/ms4w/Apache/htdocs/lanka_line_boundary.map'
      'ows_srs'             'EPSG:4326'
    END

    #Scale range at which web interface will operate
    # Template and header/footer settings
    # Only the template parameter is required to display a map. See MapServer documentation
    TEMPLATE 'fooOnlyForWMSGetFeatureInfo'
  END

  LAYER
    NAME '14_boundary'
    TYPE LINE
    DUMP true
    TEMPLATE fooOnlyForWMSGetFeatureInfo
  EXTENT -250677.251990 71904.913837 589367.563375 526289.116181
    DATA 'C:/ms4w/Apache/shapefiles/14_boundary.shp'
    METADATA
      'ows_title' '14_boundary'
    END
    STATUS OFF
    TRANSPARENCY 100
    PROJECTION
    'proj=longlat'
    'ellps=WGS84'
    'datum=WGS84'
    'no_defs'
    END
    CLASS
       NAME '14_boundary'
       STYLE
         WIDTH 0.91
         COLOR 1 144 50
       END
    END
  END
END
END




can someone give me a solution to fix this problem ?