[MapProxy] problem starting the test server

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

[MapProxy] problem starting the test server

Thomas Gertin-2

Hello,

I followed the Install directions here: https://mapproxy.org/docs/latest/install.html 

I have an EC-2 server on AWS running Ubuntu 16.04

After the installation I have started the test server with the command 'mapproxy-util serve-develop mapproxy.yaml'

and I get the following output:

[2018-09-11 12:36:01,723] mapproxy.config - INFO - reading: /home/ubuntu/mymapproxy/mapproxy.yaml
[info]  * Running on http://127.0.0.1:8080/ (Press CTRL+C to quit)
[info]  * Restarting with reloader

I am having trouble bringing up the test server on my browser. 

For example, if the IP address of my instance is: xx.xxx.xxx.xxx

and if I go to http://xx.xxx.xxx.xxx:8080/  or http://xx.xxx.xxx.xxx:8080/demo, then nothing shows up. Do you know what I am doing wrong?

Also, can instructions be made for Ubuntu 16.04?

Thanks,

Tom G.







_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy
Reply | Threaded
Open this post in threaded view
|

Re: [MapProxy] problem starting the test server

Travis Kirstine
Try using the bind -b parameter when starting the server

On Thu, Sep 13, 2018 at 12:16 PM Thomas Gertin <[hidden email]> wrote:

Hello,

I followed the Install directions here: https://mapproxy.org/docs/latest/install.html 

I have an EC-2 server on AWS running Ubuntu 16.04

After the installation I have started the test server with the command 'mapproxy-util serve-develop mapproxy.yaml'

and I get the following output:

[2018-09-11 12:36:01,723] mapproxy.config - INFO - reading: /home/ubuntu/mymapproxy/mapproxy.yaml
[info]  * Running on http://127.0.0.1:8080/ (Press CTRL+C to quit)
[info]  * Restarting with reloader

I am having trouble bringing up the test server on my browser. 

For example, if the IP address of my instance is: xx.xxx.xxx.xxx

and if I go to http://xx.xxx.xxx.xxx:8080/  or http://xx.xxx.xxx.xxx:8080/demo, then nothing shows up. Do you know what I am doing wrong?

Also, can instructions be made for Ubuntu 16.04?

Thanks,

Tom G.






_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy

_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy
Reply | Threaded
Open this post in threaded view
|

Re: [MapProxy] problem starting the test server

Thomas Gertin-2
Thank you Travis! It worked: "mapproxy-util serve-develop mapproxy.yaml -b 0.0.0.0"

On Thu, Sep 13, 2018 at 12:24 PM, Travis Kirstine <[hidden email]> wrote:
Try using the bind -b parameter when starting the server

On Thu, Sep 13, 2018 at 12:16 PM Thomas Gertin <[hidden email]> wrote:

Hello,

I followed the Install directions here: https://mapproxy.org/docs/latest/install.html 

I have an EC-2 server on AWS running Ubuntu 16.04

After the installation I have started the test server with the command 'mapproxy-util serve-develop mapproxy.yaml'

and I get the following output:

[2018-09-11 12:36:01,723] mapproxy.config - INFO - reading: /home/ubuntu/mymapproxy/mapproxy.yaml
[info]  * Running on http://127.0.0.1:8080/ (Press CTRL+C to quit)
[info]  * Restarting with reloader

I am having trouble bringing up the test server on my browser. 

For example, if the IP address of my instance is: xx.xxx.xxx.xxx

and if I go to http://xx.xxx.xxx.xxx:8080/  or http://xx.xxx.xxx.xxx:8080/demo, then nothing shows up. Do you know what I am doing wrong?

Also, can instructions be made for Ubuntu 16.04?

Thanks,

Tom G.






_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy


_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy