[MapProxy] MapProxy 1.13.0 + Ubuntu 20.04: PYPROJ Issue

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[MapProxy] MapProxy 1.13.0 + Ubuntu 20.04: PYPROJ Issue

Ken Richardson

Hello,

I have recently rebuilt my Ubuntu Server 20.04 environment from scratch. I am now in the process of re-installing MapProxy 1.13.0.

I'm using Python 3.8.5 in a virtual environment. The installation appeared to go well but when I run MapProxy I'm getting a warning and I'm not sure how to resolve it.


(mapproxy-venv) ken@ubuntu:~/mapproxy-venv$ mapproxy-util --version
Found libproj >=5. Using this library without pyproj is deprecated and not fully supported. Please install pyproj >= 2.
MapProxy 1.13.0
(mapproxy-venv) ken@ubuntu:~/mapproxy-venv$ sudo apt-get install -y python3-pyproj
Reading package lists... Done
Building dependency tree
Reading state information... Done
python3-pyproj is already the newest version (2.5.0+ds-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The problem is this: "Found libproj >=5. Using this library without pyproj is deprecated and not fully supported. Please install pyproj >= 2."

As you can see, I have pyproj 2.5.0 installed. Why am I getting this warning and is it something to be concerned about?

Thanks

Ken


_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy
Reply | Threaded
Open this post in threaded view
|

Re: [MapProxy] MapProxy 1.13.0 + Ubuntu 20.04: PYPROJ Issue

Angelos Tzotsos
Hi,

Are you using UbuntuGIS ppa in your setup?

Best,
Angelos

On 11/22/20 3:58 PM, Ken Richardson wrote:
Hello,

I have recently rebuilt my Ubuntu Server 20.04 environment from scratch. I am now in the process of re-installing MapProxy 1.13.0.

I'm using Python 3.8.5 in a virtual environment. The installation appeared to go well but when I run MapProxy I'm getting a warning and I'm not sure how to resolve it.


(mapproxy-venv) ken@ubuntu:~/mapproxy-venv$ mapproxy-util --version
*Found libproj >=5. Using this library without pyproj is deprecated and not fully supported. Please install pyproj >= 2.**
*MapProxy 1.13.0
(mapproxy-venv) ken@ubuntu:~/mapproxy-venv$ sudo apt-get install -y python3-pyproj
Reading package lists... Done
Building dependency tree
Reading state information... Done
*python3-pyproj is already the newest version (2.5.0+ds-1).**
*0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

The problem is this: "Found libproj >=5. Using this library without pyproj is deprecated and not fully supported. Please install pyproj >= 2."

As you can see, I have pyproj 2.5.0 installed. Why am I getting this warning and is it something to be concerned about?

Thanks

Ken



_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy


-- 
Angelos Tzotsos, PhD
President
Open Source Geospatial Foundation
http://users.ntua.gr/tzotsos

_______________________________________________
MapProxy mailing list
[hidden email]
https://lists.osgeo.org/mailman/listinfo/mapproxy