MapGuide on Ubuntu 12.04.5 Error PHP and PosgreSQL connection

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

MapGuide on Ubuntu 12.04.5 Error PHP and PosgreSQL connection

ElbrusNT
I want install MapGuide Open Source  on  Linux Ubuntu 12.04.5 x86 LTS.
After installation I can not  connect to PostgreSQL 9.3 from PHP script.

I check  

apt-get install php5-pgsql

apt-get install libpq-dev

but  nothing.

I can not load  pgsql.so
Reply | Threaded
Open this post in threaded view
|

Re: MapGuide on Ubuntu 12.04.5 Error PHP and PosgreSQL connection

Jackie Ng
MapGuide uses its own bundled version of PHP.

apt-get of php5-pgsql is most likely for the distro-designated version of PHP. MapGuide's bundled version won't know anything about this extension.

- Jackie
Reply | Threaded
Open this post in threaded view
|

Re: MapGuide on Ubuntu 12.04.5 Error PHP and PosgreSQL connection

ElbrusNT
Thanks for you reply Jackie.

Could you tell me how can I choose the postgresql connection.

Can I change the PHP configure options for rebuild.

Do I have another way for postgresql connection?

Thanks.
Reply | Threaded
Open this post in threaded view
|

Re: MapGuide on Ubuntu 12.04.5 Error PHP and PosgreSQL connection

Jackie Ng
Does your PostgreSQL FDO provider work?

Have you considered using MgFeatureService APIs to your PostgreSQL feature sources for all your data access needs instead of using what PHP offers?

http://themapguyde.blogspot.com.au/2013/01/mapguide-tidbits-mgfeatureservice-is.html

- Jackie