Map Viewer Image

classic Classic list List threaded Threaded
8 messages Options
Reply | Threaded
Open this post in threaded view
|

Map Viewer Image

Bob Nutsch
Hi,

I just finished installing GN 2.1 with no apparent problems.  However, there is no image in the overview map in the upper left of main page.  When I click on the 'Open Map Viewer' link below where the map should be, the map image is also missing.

I am able to add a WMS to the Intermap view by clicking on the green "Add more layers" icon below the map. That image then shows up in the Map Viewer and in the overview map.

Is there supposed to be a default map showing up in a fresh installation and where/how do I set up a default map image?

Thanks, Bob
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

Jeroen Ticheler-3
Hi Bob,
Check if the default map layers configured in ../web/intermap/WEB-INF/
mapServers.xml are pointing to valid map services. the default set of  
layers is configured in that file.
Ciao,
Jeroen

On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:

>
> Hi,
>
> I just finished installing GN 2.1 with no apparent problems.  
> However, there
> is no image in the overview map in the upper left of main page.  
> When I
> click on the 'Open Map Viewer' link below where the map should be,  
> the map
> image is also missing.
>
> I am able to add a WMS to the Intermap view by clicking on the  
> green "Add
> more layers" icon below the map. That image then shows up in the  
> Map Viewer
> and in the overview map.
>
> Is there supposed to be a default map showing up in a fresh  
> installation and
> where/how do I set up a default map image?
>
> Thanks, Bob
>
> --
> View this message in context: http://www.nabble.com/Map-Viewer- 
> Image-tf4509887s18419.html#a12862230
> Sent from the geonetwork-devel mailing list archive at Nabble.com.
>
>
> ----------------------------------------------------------------------
> ---
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at http://sourceforge.net/ 
> projects/geonetwork


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

François-Xavier PRUNAYRE
In reply to this post by Bob Nutsch

Hi Bob, do you have any java exception in the log from geoserver (something
dealing with epsg:4326 code missing somewhere ?)

Cheers. Francois

-----Message d'origine-----
De : [hidden email]
[mailto:[hidden email]] De la part de Jeroen
Ticheler
Envoyé : lundi 24 septembre 2007 15:35
À : Bob Nutsch
Cc : [hidden email]
Objet : Re: [GeoNetwork-devel] Map Viewer Image

Hi Bob,
Check if the default map layers configured in ../web/intermap/WEB-INF/
mapServers.xml are pointing to valid map services. the default set of  
layers is configured in that file.
Ciao,
Jeroen

On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:

>
> Hi,
>
> I just finished installing GN 2.1 with no apparent problems.  
> However, there
> is no image in the overview map in the upper left of main page.  
> When I
> click on the 'Open Map Viewer' link below where the map should be,  
> the map
> image is also missing.
>
> I am able to add a WMS to the Intermap view by clicking on the  
> green "Add
> more layers" icon below the map. That image then shows up in the  
> Map Viewer
> and in the overview map.
>
> Is there supposed to be a default map showing up in a fresh  
> installation and
> where/how do I set up a default map image?
>
> Thanks, Bob
>
> --
> View this message in context: http://www.nabble.com/Map-Viewer- 
> Image-tf4509887s18419.html#a12862230
> Sent from the geonetwork-devel mailing list archive at Nabble.com.
>
>
> ----------------------------------------------------------------------
> ---
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at http://sourceforge.net/ 
> projects/geonetwork


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork







-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

Bob Nutsch
Hello,

Thanks Francois and Jeroen for your helpful info.  Being a new user of GN I am still learning the structure of the system.  Jeroen's email regarding mapServers.xml pointed me to the fix. It is a user-based error on my part.  :-)  

Due to my machine currently having Apache installed with port 8080, to avoid conflicts I elected to change the GN port to 8085 (I do this via GAST and via the System Administration within GN).  I discovered that after making these changes, the port referenced in mapServers.xml was still at 8080.  Once I changed this to 8085 I got the default map that I was expecting.

I changed the two lines from

                        <server url="http://localhost:8080/geoserver/wms"  type="2" >

To

                        <server url="http://localhost:8085/geoserver/wms"  type="2" >


Thank you very much for the information and rapid assistance.

Best regards, Bob
 



> -----Original Message-----
> From: François-Xavier PRUNAYRE [mailto:[hidden email]]
> Sent: Tuesday, September 25, 2007 10:36 AM
> To: Nutsch, Bob D.
> Cc: [hidden email]
> Subject: Re: [GeoNetwork-devel] Map Viewer Image
>
>
> Hi Bob, do you have any java exception in the log from
> geoserver (something dealing with epsg:4326 code missing somewhere ?)
>
> Cheers. Francois
>
> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]] De la
> part de Jeroen Ticheler Envoyé : lundi 24 septembre 2007
> 15:35 À : Bob Nutsch Cc : [hidden email]
> Objet : Re: [GeoNetwork-devel] Map Viewer Image
>
> Hi Bob,
> Check if the default map layers configured in
> ../web/intermap/WEB-INF/ mapServers.xml are pointing to valid
> map services. the default set of layers is configured in that file.
> Ciao,
> Jeroen
>
> On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:
>
> >
> > Hi,
> >
> > I just finished installing GN 2.1 with no apparent problems.  
> > However, there
> > is no image in the overview map in the upper left of main page.  
> > When I
> > click on the 'Open Map Viewer' link below where the map
> should be, the
> > map image is also missing.
> >
> > I am able to add a WMS to the Intermap view by clicking on
> the green
> > "Add more layers" icon below the map. That image then shows
> up in the
> > Map Viewer and in the overview map.
> >
> > Is there supposed to be a default map showing up in a fresh
> > installation and where/how do I set up a default map image?
> >
> > Thanks, Bob
> >
> > --
> > View this message in context: http://www.nabble.com/Map-Viewer- 
> > Image-tf4509887s18419.html#a12862230
> > Sent from the geonetwork-devel mailing list archive at Nabble.com.
> >
> >
> >
> ----------------------------------------------------------------------
> > ---
> > This SF.net email is sponsored by: Microsoft Defy all challenges.
> > Microsoft(R) Visual Studio 2005.
> > http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> > _______________________________________________
> > GeoNetwork-devel mailing list
> > [hidden email]
> > https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> > GeoNetwork OpenSource is maintained at http://sourceforge.net/ 
> > projects/geonetwork
>
>
> --------------------------------------------------------------
> -----------
> This SF.net email is sponsored by: Microsoft Defy all
> challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>
>
>
>
>
>
>
>

-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

hesley.py
In reply to this post by François-Xavier PRUNAYRE
Hi all,

i have the same problem.

I'm using 2.2 on a Win server.

All seems to be good, except the map viewer which displays no image, non map.

When i call http://localhost:8080/intermap i can't see the map too and i can see the message Exception 'Object expected'

Please help
 
François-Xavier PRUNAYRE wrote
Hi Bob, do you have any java exception in the log from geoserver (something
dealing with epsg:4326 code missing somewhere ?)

Cheers. Francois

-----Message d'origine-----
De : geonetwork-devel-bounces@lists.sourceforge.net
[mailto:geonetwork-devel-bounces@lists.sourceforge.net] De la part de Jeroen
Ticheler
Envoyé : lundi 24 septembre 2007 15:35
À : Bob Nutsch
Cc : geonetwork-devel@lists.sourceforge.net
Objet : Re: [GeoNetwork-devel] Map Viewer Image

Hi Bob,
Check if the default map layers configured in ../web/intermap/WEB-INF/
mapServers.xml are pointing to valid map services. the default set of  
layers is configured in that file.
Ciao,
Jeroen

On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:

>
> Hi,
>
> I just finished installing GN 2.1 with no apparent problems.  
> However, there
> is no image in the overview map in the upper left of main page.  
> When I
> click on the 'Open Map Viewer' link below where the map should be,  
> the map
> image is also missing.
>
> I am able to add a WMS to the Intermap view by clicking on the  
> green "Add
> more layers" icon below the map. That image then shows up in the  
> Map Viewer
> and in the overview map.
>
> Is there supposed to be a default map showing up in a fresh  
> installation and
> where/how do I set up a default map image?
>
> Thanks, Bob
>
> --
> View this message in context: http://www.nabble.com/Map-Viewer- 
> Image-tf4509887s18419.html#a12862230
> Sent from the geonetwork-devel mailing list archive at Nabble.com.
>
>
> ----------------------------------------------------------------------
> ---
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> GeoNetwork-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at http://sourceforge.net/ 
> projects/geonetwork


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
GeoNetwork-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork







-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
GeoNetwork-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

Kevin Gunn
Hi All,

Same problem as well, with tomcat 5.5.23 and I have not changed configured ports from defaults. Tomcat is running on default 8080 which should match default config. Here is the exception trace. Is this what others are seeing in regard to this issue?

I'm not able to locate the JAR file that contains this class.

=======================================================
772603 [SEVERE] org.vfny.geoserver.servlets.AbstractService - Service exception
occurred
org.vfny.geoserver.wms.WmsException: Provider de.fzi.dbs.xml.transform.CachingTransformerFactory could not be instantiated: java.lang.NullPointerException
        at org.vfny.geoserver.wms.WmsExceptionHandler.newServiceException(WmsExceptionHandler.java:65)
        at org.vfny.geoserver.servlets.AbstractService.sendError(AbstractService.java:865)
        at org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:528)
        at org.vfny.geoserver.servlets.AbstractService.doGet(AbstractService.java:315)
        at org.geoserver.request.Dispatcher.dispatch(Dispatcher.java:192)
        at org.geoserver.request.Dispatcher.handleRequestInternal(Dispatcher.java:52)
        at org.springframework.web.servlet.mvc.AbstractController.handleRequest(
AbstractController.java:139)
        at org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAdapter.java:44)
        at org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:684)
        at org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:625)
        at org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkServlet.java:392)
        at org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.java:347)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:103)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicatioFilterChain.java:215)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:188)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870)
        at org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.p
rocessConnection(Http11BaseProtocol.java:665)
        at org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:528)
        at org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:81)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadP
ool.java:685)
        at java.lang.Thread.run(Thread.java:595)
Caused by: javax.xml.transform.TransformerFactoryConfigurationError: Provider de
.fzi.dbs.xml.transform.CachingTransformerFactory could not be instantiated: java.lang.NullPointerException
        at javax.xml.transform.TransformerFactory.newInstance(TransformerFactory.java:109)
        at org.geotools.xml.transform.TransformerBase.createTransformer(TransformerBase.java:70)
        at org.vfny.geoserver.wms.responses.helpers.WMSCapsTransformer.createTransformer(WMSCapsTransformer.java:123)
        at org.geotools.xml.transform.TransformerBase$Task.<init>(TransformerBase.java:255)
        at org.geotools.xml.transform.TransformerBase.createTransformTask(TransformerBase.java:144)
        at org.geotools.xml.transform.TransformerBase.transform(TransformerBase.java:125)
        at org.geotools.xml.transform.TransformerBase.transform(TransformerBase.java:105)
        at org.vfny.geoserver.wms.responses.WMSCapabilitiesResponse.execute(WMSCapabilitiesResponse.java:87)
        at org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:516)
        ... 28 more
=======================================================
Kevin Gunn
Software Engineer
Australian Institute of Marine Science
Ph: (07) 47534305
Fax:  (07) 4772 5852
E-mail: [hidden email]
------------------------------------------------------------------------|
 The information contained in this communication is  for the use of the |
 individual  or  entity  to  whom  it  is  addressed, and  may  contain |
 information which is the  subject of legal privilege and/or copyright. |
 If you have received this  communication in  error, please  notify the |
 sender by return E-Mail and delete the transmission, together with any |
 attachments, from your system. Thank you.                              |
------------------------------------------------------------------------|


-----Original Message-----
From: Hesley Py [mailto:[hidden email]]
Sent: Friday, 16 May 2008 06:26 AM
To: [hidden email]
Subject: Re: [GeoNetwork-devel] Map Viewer Image


Hi all,

i have the same problem.

I'm using 2.2 on a Win server.

All seems to be good, except the map viewer which displays no image, non
map.

When i call http://localhost:8080/intermap i can't see the map too and i can
see the message Exception 'Object expected'

Please help
 

François-Xavier PRUNAYRE wrote:

>
>
> Hi Bob, do you have any java exception in the log from geoserver
> (something
> dealing with epsg:4326 code missing somewhere ?)
>
> Cheers. Francois
>
> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]] De la part de
> Jeroen
> Ticheler
> Envoyé : lundi 24 septembre 2007 15:35
> À : Bob Nutsch
> Cc : [hidden email]
> Objet : Re: [GeoNetwork-devel] Map Viewer Image
>
> Hi Bob,
> Check if the default map layers configured in ../web/intermap/WEB-INF/
> mapServers.xml are pointing to valid map services. the default set of  
> layers is configured in that file.
> Ciao,
> Jeroen
>
> On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:
>
>>
>> Hi,
>>
>> I just finished installing GN 2.1 with no apparent problems.  
>> However, there
>> is no image in the overview map in the upper left of main page.  
>> When I
>> click on the 'Open Map Viewer' link below where the map should be,  
>> the map
>> image is also missing.
>>
>> I am able to add a WMS to the Intermap view by clicking on the  
>> green "Add
>> more layers" icon below the map. That image then shows up in the  
>> Map Viewer
>> and in the overview map.
>>
>> Is there supposed to be a default map showing up in a fresh  
>> installation and
>> where/how do I set up a default map image?
>>
>> Thanks, Bob
>>
>> --
>> View this message in context: http://www.nabble.com/Map-Viewer- 
>> Image-tf4509887s18419.html#a12862230
>> Sent from the geonetwork-devel mailing list archive at Nabble.com.
>>
>>
>> ----------------------------------------------------------------------
>> ---
>> This SF.net email is sponsored by: Microsoft
>> Defy all challenges. Microsoft(R) Visual Studio 2005.
>> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
>> _______________________________________________
>> GeoNetwork-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
>> GeoNetwork OpenSource is maintained at http://sourceforge.net/ 
>> projects/geonetwork
>
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>
>
>
>
>
>
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork
>
>

--
View this message in context: http://www.nabble.com/Map-Viewer-Image-tp12862230p17261720.html
Sent from the geonetwork-devel mailing list archive at Nabble.com.





--  
------------------------------------------------------------------------
The information contained in this communication is for the use of the
individual or entity to whom it is addressed, and may contain
information which is the subject of legal privilege and/or copyright.  

If you have received this communication in error, please notify the
sender by return email and delete the transmission, together with any
attachments, from your system. Thank you.
------------------------------------------------------------------------


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

Simon Pigot
In reply to this post by Bob Nutsch
Kevin,

What you are seeing here is due to the config of geoserver in the BlueNET
MEST - your geoserver is trying to pick up the incompatible caching xslt
transformer (based on saxon) that is used in the BlueNet MEST - probably
because you've installed beta5 and kept beta4 configs - it is not a
geonetwork 2.2 problem :-)

Can you please check the email I sent you earlier and look at the
instructions it contains and then contact me directly please if there are
any continuing problems?

Cheers and thanks,
Simon




==============Original message text===============
On Fri, 16 May 2008 12:53:50 +1000 "Kevin Gunn" wrote:

Hi All,

Same problem as well, with tomcat 5.5.23 and I have not changed
configured ports from defaults. Tomcat is running on default 8080 which
should match default config. Here is the exception trace. Is this what
others are seeing in regard to this issue?

I'm not able to locate the JAR file that contains this class.

=======================================================
772603 [SEVERE] org.vfny.geoserver.servlets.AbstractService - Service exception
occurred
org.vfny.geoserver.wms.WmsException: Provider
de.fzi.dbs.xml.transform.CachingTransformerFactory could not be
instantiated: java.lang.NullPointerException
        at
org.vfny.geoserver.wms.WmsExceptionHandler.newServiceException(WmsExceptio
nHandler.java:65)
        at
org.vfny.geoserver.servlets.AbstractService.sendError(AbstractService.java:865)
        at
org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:528)
        at
org.vfny.geoserver.servlets.AbstractService.doGet(AbstractService.java:315)
        at org.geoserver.request.Dispatcher.dispatch(Dispatcher.java:192)
        at
org.geoserver.request.Dispatcher.handleRequestInternal(Dispatcher.java:52)
        at
org.springframework.web.servlet.mvc.AbstractController.handleRequest(
AbstractController.java:139)
        at
org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(
SimpleControllerHandlerAdapter.java:44)
        at
org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherSer
vlet.java:684)
        at
org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServ
let.java:625)
        at
org.springframework.web.servlet.FrameworkServlet.processRequest(FrameworkS
ervlet.java:392)
        at
org.springframework.web.servlet.FrameworkServlet.doGet(FrameworkServlet.ja
va:347)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Applicati
onFilterChain.java:269)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilter
Chain.java:188)
        at
org.vfny.geoserver.filters.SetCharacterEncodingFilter.doFilter(SetCharacte
rEncodingFilter.java:103)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(Applicati
oFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationF
ilterChain.java:188)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.
java:210)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.
java:174)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.ja
va:108)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at
org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:870)
        at
org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.p
rocessConnection(Http11BaseProtocol.java:665)
        at
org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.j
ava:528)
        at
org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollower
WorkerThread.java:81)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadP
ool.java:685)
        at java.lang.Thread.run(Thread.java:595)
Caused by: javax.xml.transform.TransformerFactoryConfigurationError:
Provider de
.fzi.dbs.xml.transform.CachingTransformerFactory could not be
instantiated: java.lang.NullPointerException
        at
javax.xml.transform.TransformerFactory.newInstance(TransformerFactory.java:109)
        at
org.geotools.xml.transform.TransformerBase.createTransformer(TransformerBa
se.java:70)
        at
org.vfny.geoserver.wms.responses.helpers.WMSCapsTransformer.createTransfor
mer(WMSCapsTransformer.java:123)
        at
org.geotools.xml.transform.TransformerBase$Task.<init>(TransformerBase.jav
a:255)
        at
org.geotools.xml.transform.TransformerBase.createTransformTask(Transformer
Base.java:144)
        at
org.geotools.xml.transform.TransformerBase.transform(TransformerBase.java:125)
        at
org.geotools.xml.transform.TransformerBase.transform(TransformerBase.java:105)
        at
org.vfny.geoserver.wms.responses.WMSCapabilitiesResponse.execute(WMSCapabi
litiesResponse.java:87)
        at
org.vfny.geoserver.servlets.AbstractService.doService(AbstractService.java:516)
        ... 28 more
=======================================================
Kevin Gunn
Software Engineer
Australian Institute of Marine Science
Ph: (07) 47534305
Fax:  (07) 4772 5852
E-mail: [hidden email]
------------------------------------------------------------------------|
 The information contained in this communication is  for the use of the |
 individual  or  entity  to  whom  it  is  addressed, and  may  contain |
 information which is the  subject of legal privilege and/or copyright. |
 If you have received this  communication in  error, please  notify the |
 sender by return E-Mail and delete the transmission, together with any |
 attachments, from your system. Thank you.                              |
------------------------------------------------------------------------|


-----Original Message-----
From: Hesley Py [mailto:[hidden email]]
Sent: Friday, 16 May 2008 06:26 AM
To: [hidden email]
Subject: Re: [GeoNetwork-devel] Map Viewer Image


Hi all,

i have the same problem.

I'm using 2.2 on a Win server.

All seems to be good, except the map viewer which displays no image, non
map.

When i call http://localhost:8080/intermap i can't see the map too and i cansee the message Exception 'Object expected'

Please help
 

François-Xavier PRUNAYRE wrote:

>
>
> Hi Bob, do you have any java exception in the log from geoserver
> (something
> dealing with epsg:4326 code missing somewhere ?)
>
> Cheers. Francois
>
> -----Message d'origine-----
> De : [hidden email]
> [mailto:[hidden email]] De la part de
> Jeroen
> Ticheler
> Envoyé : lundi 24 septembre 2007 15:35
> À : Bob Nutsch
> Cc : [hidden email]
> Objet : Re: [GeoNetwork-devel] Map Viewer Image
>
> Hi Bob,
> Check if the default map layers configured in ../web/intermap/WEB-INF/
> mapServers.xml are pointing to valid map services. the default set of  
> layers is configured in that file.
> Ciao,
> Jeroen
>
> On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:
>
>>
>> Hi,
>>
>> I just finished installing GN 2.1 with no apparent problems.  
>> However, there
>> is no image in the overview map in the upper left of main page.  
>> When I
>> click on the 'Open Map Viewer' link below where the map should be,  
>> the map
>> image is also missing.
>>
>> I am able to add a WMS to the Intermap view by clicking on the  
>> green "Add
>> more layers" icon below the map. That image then shows up in the  
>> Map Viewer
>> and in the overview map.
>>
>> Is there supposed to be a default map showing up in a fresh  
>> installation and
>> where/how do I set up a default map image?
>>
>> Thanks, Bob
>>
>> --
>> View this message in context: http://www.nabble.com/Map-Viewer- >> Image-tf4509887s18419.html#a12862230
>> Sent from the geonetwork-devel mailing list archive at Nabble.com.
>>
>>
>> ----------------------------------------------------------------------
>> ---
>> This SF.net email is sponsored by: Microsoft
>> Defy all challenges. Microsoft(R) Visual Studio 2005.
>> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/>> _______________________________________________
>> GeoNetwork-devel mailing list
>> [hidden email]
>> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
>> GeoNetwork OpenSource is maintained at http://sourceforge.net/ >> projects/geonetwork
>
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork>
>
>
>
>
>
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/> _______________________________________________
> GeoNetwork-devel mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at
> http://sourceforge.net/projects/geonetwork>
>
--
View this message in context: http://www.nabble.com/Map-Viewer-Image-tp12862230p17261720.htmlSent from the geonetwork-devel mailing list archive at Nabble.com.





--  
------------------------------------------------------------------------
The information contained in this communication is for the use of the
individual or entity to whom it is addressed, and may contain
information which is the subject of legal privilege and/or copyright.  

If you have received this communication in error, please notify the
sender by return email and delete the transmission, together with any
attachments, from your system. Thank you.
------------------------------------------------------------------------


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
===========End of original message text===========






-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
Reply | Threaded
Open this post in threaded view
|

Re: Map Viewer Image

hesley.py
In reply to this post by François-Xavier PRUNAYRE
Hi Francois,

I have exactly this problem (epsg:4326 code missing ). Can you help me?

thanks

Hesley


François-Xavier PRUNAYRE wrote
Hi Bob, do you have any java exception in the log from geoserver (something
dealing with epsg:4326 code missing somewhere ?)

Cheers. Francois

-----Message d'origine-----
De : geonetwork-devel-bounces@lists.sourceforge.net
[mailto:geonetwork-devel-bounces@lists.sourceforge.net] De la part de Jeroen
Ticheler
Envoyé : lundi 24 septembre 2007 15:35
À : Bob Nutsch
Cc : geonetwork-devel@lists.sourceforge.net
Objet : Re: [GeoNetwork-devel] Map Viewer Image

Hi Bob,
Check if the default map layers configured in ../web/intermap/WEB-INF/
mapServers.xml are pointing to valid map services. the default set of  
layers is configured in that file.
Ciao,
Jeroen

On Sep 24, 2007, at 6:12 PM, Bob Nutsch wrote:

>
> Hi,
>
> I just finished installing GN 2.1 with no apparent problems.  
> However, there
> is no image in the overview map in the upper left of main page.  
> When I
> click on the 'Open Map Viewer' link below where the map should be,  
> the map
> image is also missing.
>
> I am able to add a WMS to the Intermap view by clicking on the  
> green "Add
> more layers" icon below the map. That image then shows up in the  
> Map Viewer
> and in the overview map.
>
> Is there supposed to be a default map showing up in a fresh  
> installation and
> where/how do I set up a default map image?
>
> Thanks, Bob
>
> --
> View this message in context: http://www.nabble.com/Map-Viewer- 
> Image-tf4509887s18419.html#a12862230
> Sent from the geonetwork-devel mailing list archive at Nabble.com.
>
>
> ----------------------------------------------------------------------
> ---
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2005.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> _______________________________________________
> GeoNetwork-devel mailing list
> GeoNetwork-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
> GeoNetwork OpenSource is maintained at http://sourceforge.net/ 
> projects/geonetwork


-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
GeoNetwork-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork







-------------------------------------------------------------------------
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2005.
http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
_______________________________________________
GeoNetwork-devel mailing list
GeoNetwork-devel@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/geonetwork-devel
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork