[MS4W-Users] Problems to install ms4w in windows7 (64bit)

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

[MS4W-Users] Problems to install ms4w in windows7 (64bit)

Jan Tappenbeck
  Hi !

i try to install ms4w in windows7 64bit and there are many problems....

the source is [1] rel. 3.0.3

to install the software i try to run osgeo4w.bat - but the PATH-Variable
will not add automaticlly - so i try manuell.

in the next line there sould be run some bat-files in the folder -
%OSGEO4W%\etc\ini -> the folder etc exists; but ini not - there only is
a folder setup with non-bat-files !!!!

at last i try to run setenv.bat manuell - but sorry the PATH will not
added. in my opion i am missing the drive-letter ...?
set
PATH=\ms4w\Apache\cgi-bin;\ms4w\tools\gdal-ogr;\ms4w\tools\mapserv;\ms4w\tools\shapelib;\ms4w\proj\bin;\ms4w\tools\shp2tile;\ms4w\tools\shpdiff;\ms4w\tools\avce00;\ms4w\python\gdal;%PATH%

next there will be added some other Variables like GDAL_DATA - here i am
missing drive-letters agains and then i try a test by following command:

echo %GDAL_DATA% - but no value will show.

can anyone help me ?

regards Jan

[1] http://www.maptools.org/dl/ms4w/ms4w_3.0.3.zip

regards Jan
_______________________________________________
MS4W-Users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users
Reply | Threaded
Open this post in threaded view
|

Re: Problems to install ms4w in windows7 (64bit)

jmckenna
Administrator
On 12-01-06 7:27 AM, Jan Tappenbeck wrote:

>    Hi !
>
> i try to install ms4w in windows7 64bit and there are many problems....
>
> the source is [1] rel. 3.0.3
>
> to install the software i try to run osgeo4w.bat - but the PATH-Variable
> will not add automaticlly - so i try manuell.
>
> in the next line there sould be run some bat-files in the folder -
> %OSGEO4W%\etc\ini ->  the folder etc exists; but ini not - there only is
> a folder setup with non-bat-files !!!!
>
> at last i try to run setenv.bat manuell - but sorry the PATH will not
> added. in my opion i am missing the drive-letter ...?
> set
> PATH=\ms4w\Apache\cgi-bin;\ms4w\tools\gdal-ogr;\ms4w\tools\mapserv;\ms4w\tools\shapelib;\ms4w\proj\bin;\ms4w\tools\shp2tile;\ms4w\tools\shpdiff;\ms4w\tools\avce00;\ms4w\python\gdal;%PATH%
>
> next there will be added some other Variables like GDAL_DATA - here i am
> missing drive-letters agains and then i try a test by following command:
>
> echo %GDAL_DATA% - but no value will show.
>
> can anyone help me ?
>
> regards Jan
>
> [1] http://www.maptools.org/dl/ms4w/ms4w_3.0.3.zip
>

Hmm.  Your email contains mention of OSGeo4W and MS4W - two different
installers, which, confuses me.

If you are using MS4W - when you use the zip archive (ms4w_3.0.3.zip)
you are forced to extract it at the root of your drive (so you'll have
C:/ms4w for example).  Then setenv.bat will work for you.   However if
you want to install MS4W somewhere other than the drive root, then use
the .exe installer and select the location to install MS4W.

Happy new year :)

-jeff


--
Jeff McKenna
MapServer Consulting and Training Services
http://www.gatewaygeomatics.com/


_______________________________________________
MS4W-Users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users