[MS4W-Users] Problem in image output with mssql2008 + ms4w

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

[MS4W-Users] Problem in image output with mssql2008 + ms4w

Rodrigo Silva de Melo
i have the following Layer:

LAYER
      NAME "estados"
      METADATA
        "wms_title"    "Estados"
      END
      TYPE polygon
      STATUS ON
      CONNECTIONTYPE PLUGIN
      PLUGIN "C:/ms4w/Apache/specialplugins/msplugin_mssql2008.dll"     
      CONNECTION "server=LENNY\DEV2008;port=49222;uid=sa;pwd=Stigeo_1_adm_1;database=teste_geo;Integrated Security=false"
      DATA "GEOM from estados USING UNIQUE OBJECTID USING SRID=4326"     
     
      CLASS
          NAME "estados"   
          STYLE
            COLOR 255 0 0
          END
        END
         
    END   
  END

when  i execute:

shp2img -m c:/ms4w/apps/sintaq/rodovias/example.map -all_debug 5

return this:

msLoadMap(): 0.000s
msDrawMap(): rendering using outputformat named png (AGG/PNG).
msDrawMap(): WMS/WFS set-up and query, 0.000s
msMSSQL2008LayerOpen called datastatement: GEOM from estados USING UNIQUE OBJECTID USING SRID=4326
MSMSSQL2008LayerOpen -- shared connection not available.
msConnPoolRegister(estados,server=I REMOVED IT FROM TEXT,03ABD200)
msMSSQL2008LayerParseData: unique column = OBJECTID, srid='4326', geom_column_name = GEOM, table_name=estados
msMSSQL2008LayerFreeItemInfo called
msMSSQL2008LayerWhichShapes called
query_string_temp:SELECT GEOM.STAsBinary(),convert(varchar(36), OBJECTID) from estados WHERE GEOM.STIntersects(geometry::STGeomFromText('POLYGON((-77.9477842994432 -33.731964,-30.6475117005568 -33.731964,-30.6475117005568 4.9525941,-77.9477842994432 4.9525941,-77.9477842994432 -33.731964))',4326)) = 1
msMSSQL2008LayerFreeItemInfo called
msMSSQL2008LayerClose datastatement: GEOM from estados USING UNIQUE OBJECTID USING SRID=4326
msConnPoolRelease(estados,server=I REMOVED IT FROM TEXT,03ABD200)
msConnPoolClose(server=I REMOVED IT FROM TEXT,03ABD200)
msDrawMap(): Layer 0 (estados), 0.094s
msDrawMap(): Drawing Label Cache, 0.000s
msDrawMap() total time: 0.096s
SaveImage(stdout) total time: 0.053s
msFreeMap(): freeing map at 0216C0A0.
msMSSQL2008LayerClose datastatement: GEOM from estados USING UNIQUE OBJECTID USING SRID=4326
msMSSQL2008LayerClose -- layerinfo is  NULL
freeLayer(): freeing layer at 0216F350.
shp2img total time: 0.152s


the  output image return with no data,
if i execute  the map file in  mapserver url the output is null too.
I can't find any issue about this, anyone can help me?



--
Rodrigo Silva de Melo

_______________________________________________
MS4W-Users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users