MGOS and Oracle WorkSpace Management

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

MGOS and Oracle WorkSpace Management

pcav
Hi all,
AFAICU, MGOS uses the free Oracle driver[0], which has good
performances. Unfortunately, it does not seem support Oracle WorkSpace
Management, which is apparently supported by the non free MG version.
So the question is: is there a solution to this? Would it be possible to
replace King Oracle with a more modern driver, eventually a non free,
even commercial, one, perhaps recompiling MapGuide/FDO against the new
drivers?
All the best, and thanks.
--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users
Reply | Threaded
Open this post in threaded view
|

Re: MGOS and Oracle WorkSpace Management

johnnyT
Hi Paolo
perhaps you could try Autodesk FDO Provider for Oracle (bundled with a trial version of AIMS2015, 2016, etc) that support Read/write access to feature data in an Oracle-based data store, Supports spatial indexing, long transactions, and persistent locking.
It should works because AIMS is based on the same engine of MGOS but you must use the same FDO version (MGOS 2.6 has FDO 3.9.0 like AIMS2015). Copy DLL and modify providers.xml
It's not a free driver but, if it really works, you can contact Autodesk for a quote

http://fdo.osgeo.org/content/products-using-fdo

Best regards
johnnyT
Reply | Threaded
Open this post in threaded view
|

Re: MGOS and Oracle WorkSpace Management

pcav
Il 04/03/2016 21:33, johnnyT ha scritto:

> perhaps you could try Autodesk FDO Provider for Oracle (bundled with a trial
> version of AIMS2015, 2016, etc) that support Read/write access to feature
> data in an Oracle-based data store, Supports spatial indexing, long
> transactions, and persistent locking.
> It should works because AIMS is based on the same engine of MGOS but you
> must use the same FDO version (MGOS 2.6 has FDO 3.9.0 like AIMS2015). Copy
> DLL and modify providers.xml
> It's not a free driver but, if it really works, you can contact Autodesk for
> a quote

Hi JonnyT,
thaks for the hint. Apparently Autodesk do not provide the driver alone.
In any case, we're going for a free/OS solution here.
All the best.

--
Paolo Cavallini - www.faunalia.eu
QGIS & PostGIS courses: http://www.faunalia.eu/training.html
_______________________________________________
mapguide-users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapguide-users