MG2.4 Feature Source FDO Error 559 - Connect Failed

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

MG2.4 Feature Source FDO Error 559 - Connect Failed

geomapper
Greetings,

I am currently running MG Version 2.4 x64 on IIS running PHP, which I have just upgraded to from MG 2.2. My problem is due to a number of data connections which were previously working properly, but now appear to be broken or improperly linked.

Below is the error message given by the log files when I tried to "Test Connection" for an SDF Feature Source in Maestro (I recieve similar messages when trying all other data connection types too):

<2012-07-23T09:26:55> 2016 MapGuide Maestro v4.0.1.6639 127.0.0.1 Administrator
 Error: An exception occurred in FDO component.
        Error occurred in Feature Source (Session:ea537b66-d4e1-11e1-8000-005056b67e2c_en_MTI3LjAuMC4x0AFC0AFB0AFA//8b9df030-9b59-49b5-a02e-f1744f1a87bb.FeatureSource): An exception occurred in FDO component.
        SDF connect failed. File does not exist or cannot be opened in specified access mode.
       
        - MgFdoConnectionManager.Open() line 333 file c:\mg-2.4-x64\mgdev\server\src\common\manager\FdoConnectionManager.cpp
        - MgFdoConnectionManager.CacheFdoConnection() line 1099 file c:\mg-2.4-x64\mgdev\server\src\common\manager\FdoConnectionManager.cpp
        - MgFdoConnectionManager.Open() line 1091 file c:\mg-2.4-x64\mgdev\server\src\common\manager\FdoConnectionManager.cpp
         (Cause: , Root Cause: )
 StackTrace:
  - MgFeatureServiceHandler.ProcessOperation() line 83 file c:\mg-2.4-x64\mgdev\server\src\services\feature\FeatureServiceHandler.cpp
  - MgOpTestFeatureSourceConnection.Execute() line 100 file c:\mg-2.4-x64\mgdev\server\src\services\feature\OpTestFeatureSourceConnection.cpp
  - MgServerFeatureService.TestConnection() line 243 file c:\mg-2.4-x64\mgdev\server\src\services\feature\ServerFeatureService.cpp
  - MgFdoConnectionManager.Open() line 368 file c:\mg-2.4-x64\mgdev\server\src\common\manager\FdoConnectionManager.cpp


From what I understand, my main issue is that the files mentioned in the error message actually do not exist on my computer, as I have been unable to locate them. I have also checked the FDO directory in the MapGuide installation, and all of the correct DLLs appear to be there, as well as the providers.xml document which looks correct. I am presuming either an error on my part when installing MG2.4, or an error with the 2.4 installer on my machine is to blame; although I believe the former to be more possible since I am still new to MGOS. On that note, my apologies if this is a trivial error.

Can anybody please advise me about what the next best steps to take would be?

Sincerely,
Thom
Reply | Threaded
Open this post in threaded view
|

Re: MG2.4 Feature Source FDO Error 559 - Connect Failed

GordonL
are you sure you we not using unmanaged ALIASes for the location of thou sdf files?

you may have to recreate them.

Reply | Threaded
Open this post in threaded view
|

Re: MG2.4 Feature Source FDO Error 559 - Connect Failed

geomapper
Bingo! It turns out I had a typo in my ALIAS locations, all is working as usual now.

Many, many thanks for helping me find my silly mistake.