MB3.0.5.2 app.php HTML-Ansicht

classic Classic list List threaded Threaded
5 messages Options
ivo
Reply | Threaded
Open this post in threaded view
|

MB3.0.5.2 app.php HTML-Ansicht

ivo
Hallo Zusammen,

Ich bin gerade dabei die MB-Version 3.0.5.2 aus zu probieren, auf meinem lokalen Testsystem (PHP 5.4.45) funktioniert alles super, aber auf dem gehostenten Produktivsystem (PHP 5.6.13) wird die Startseite app.php nur als "einfache Html-Darstellung" mit eingeschränkten Funktionen angezeigt (analog wie http://osgeo-org.1560.x6.nabble.com/file/n5221936/app.png ).

In der prod.log sind folgende Einträge:
[2015-11-23 14:24:06] request.CRITICAL: Uncaught PHP Exception Symfony\Component\Process\Exception\RuntimeException: "The Process class relies on proc_open, which is not available on your PHP installation." at /var/www/kd/xxxxxxxxxx/xxxxx/vendor/symfony/symfony/src/Symfony/Component/Process/Process.php line 138 {"exception":"[object] (Symfony\\Component\\Process\\Exception\\RuntimeException(code: 0): The Process class relies on proc_open, which is not available on your PHP installation. at /var/www/kd/ xxxxxxxxxx/xxxxx /vendor/symfony/symfony/src/Symfony/Component/Process/Process.php:138)"} []
[2015-11-23 14:24:06] security.DEBUG: Write SecurityContext in the session [] []

Laut Aussage des Web-Hosters wurde „Die APC Unterstützung mit PHP 5.4.6 eingestellt. Die Alternative ist nun opcache oder xcache.“ (opcache wurde mit freigeschaltet). Ansonsten sind eigentlich alle Komponenten (php5-sqlite, -curl, -intl, -gd, -fileinfo, openssl und mod_rewrite) eingerichtet (außer php5-cli).
Anmerkung: Auf dem Produktivsystem kann ich leider config-php oder app_dev.php nicht aufrufen.  

Kann mir jemand weiterhelfen?
Vielen Dank schon einmal.

Ivo
Reply | Threaded
Open this post in threaded view
|

Re: MB3.0.5.2 app.php HTML-Ansicht

Andreas Schmitz-2
ivo wrote:

Hallo zusammen,

> Ich bin gerade dabei die MB-Version 3.0.5.2 aus zu probieren, auf meinem
> lokalen Testsystem (PHP 5.4.45) funktioniert alles super, aber auf dem
> gehostenten Produktivsystem (PHP 5.6.13) wird die Startseite app.php nur als
> "einfache Html-Darstellung" mit eingeschränkten Funktionen angezeigt (analog
> wie http://osgeo-org.1560.x6.nabble.com/file/n5221936/app.png ).
>
> In der prod.log sind folgende Einträge:
> [2015-11-23 14:24:06] request.CRITICAL: Uncaught PHP Exception
> Symfony\Component\Process\Exception\RuntimeException: "The Process class
> relies on proc_open, which is not available on your PHP installation." at
> /var/www/kd/xxxxxxxxxx/xxxxx/vendor/symfony/symfony/src/Symfony/Component/Process/Process.php
> line 138 {"exception":"[object]
> (Symfony\\Component\\Process\\Exception\\RuntimeException(code: 0): The
> Process class relies on proc_open, which is not available on your PHP
> installation. at /var/www/kd/ xxxxxxxxxx/xxxxx
> /vendor/symfony/symfony/src/Symfony/Component/Process/Process.php:138)"} []
> [2015-11-23 14:24:06] security.DEBUG: Write SecurityContext in the session
> [] []
>
> Laut Aussage des Web-Hosters wurde „Die APC Unterstützung mit PHP 5.4.6
> eingestellt. Die Alternative ist nun opcache oder xcache.“ (opcache wurde
> mit freigeschaltet). Ansonsten sind eigentlich alle Komponenten
> (php5-sqlite, -curl, -intl, -gd, -fileinfo, openssl und mod_rewrite)
> eingerichtet (außer php5-cli).
> Anmerkung: Auf dem Produktivsystem kann ich leider config-php oder
> app_dev.php nicht aufrufen.  
>
> Kann mir jemand weiterhelfen?
> Vielen Dank schon einmal.
könnte sein, dass proc_open per 'disable_functions = proc_open,...' in
der php.ini deaktiviert ist. Mit APC hat das eigentlich nichts zu
tun...

Gruß, Andreas

_______________________________________________
Mapbender_users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapbender_users

signature.asc (188 bytes) Download Attachment
ivo
Reply | Threaded
Open this post in threaded view
|

Re: MB3.0.5.2 app.php HTML-Ansicht

ivo
This post was updated on .
Hallo Andreas,

die deaktivierte PHP-Funktion proc_open scheint ein Problem gewesen zu sein (ist jetzt aktiviert worden), allerdings wird immer noch eine einfache HTML-Darstellung angezeigt und in der prod.log steht folgendes:

[2015-11-24 16:41:23] request.CRITICAL: Uncaught PHP Exception Assetic\Exception\FilterException: "An error occurred while running: '/var/www/kd/xxxxxx/xxxx/app/../vendor/eslider/sasscb/dist/sassc' '--load-path' '/' '--style' 'compressed' '--load-path' '/var/www/kd/xxxxxx/xxxx/app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass' '--load-path' '/var/www/kd/geoportal.lkspn.de/gp_spn_t/app/../vendor/igosuki/compass-mixins/lib' '--load-path' '/var/www/kd/xxxxxx/xxxx/app/../web' '/tmp/assetic_sassPxUKpd'  Error Output: sh: /var/www/kd/xxxxxx/xxxx/app/../vendor/eslider/sasscb/dist/sassc: Permission denied   Input: @import "libs/variables"; @import "libs/mixins"; @import "libs/icons"; @import "element/mbslider"; @import "libs/normalize"; @import "modules/base"; @import "modules/text"; @import "modules/layout"; @import "modules/popup"; @import "modules/input"; @import "modules/button"; @import "modules/seperator"; @import "modules/container"; @import "modules/tabcontainer"; @import "modules/checkbox"; @import "modules/radiobutton"; @import "modules/dropdown"; @import "modules/table"; //$rootPath: "../../../mapbendercore/";       // ------------------------------------------------------- APPLICATIONS .screenshot_upload{     padding: 0px;     position: relative;     min-width: 300px;      .label{         margin: 0px;         padding: 2px;         font-size: 12px;         white-space: nowrap;         position: relative;          .............................(sehr viele Zeilen mit css-elementen)....
............................
!important;}\n}\n at /var/www/kd/xxxxxx/xxxx/vendor/kriswallsmith/assetic/src/Assetic/Exception/FilterException.php:40)"} []
[2015-11-24 16:41:23] security.DEBUG: Write SecurityContext in the session [] []


Gibt es eigentlich ein Script, ähnlich config.php das man auch als nicht localhost ausführen kann, um zu prüfen ob alle erfoderlichen PHP-Einstellungen gesetzt sind?


.... habe gerade gesehen, dass meine Fehlermeldungen genauso wie im Post: http://osgeo-org.1560.x6.nabble.com/Probleme-mit-sassc-Version-3-0-5-2-td5237599.html aussehen und habe mal allen manuell erstellten CSS Code aus den Anwendungen entfernt - leider ohne Erfolg.

Vielen Dank im Voraus.
Gruß Ivo
 
Reply | Threaded
Open this post in threaded view
|

Re: MB3.0.5.2 app.php HTML-Ansicht

Andreas Schmitz-2
ivo wrote:

Hi,

> die deaktivierte PHP-Funktion /proc_open/ scheint ein Problem gewesen zu
> sein (ist jetzt aktiviert worden), allerdings wird immer noch eine einfache
> HTML-Darstellung angezeigt und in der prod.log steht folgendes:
>
> [2015-11-24 16:41:23] request.CRITICAL: Uncaught PHP Exception
> Assetic\Exception\FilterException: "An error occurred while running:
> '/var/www/kd/xxxxxx/xxxx/app/../vendor/eslider/sasscb/dist/sassc'
> '--load-path' '/' '--style' 'compressed' '--load-path'
> '/var/www/kd/xxxxxx/xxxx/app/../mapbender/src/Mapbender/CoreBundle/Resources/public/sass'
> '--load-path'
> '/var/www/kd/geoportal.lkspn.de/gp_spn_t/app/../vendor/igosuki/compass-mixins/lib'
> '--load-path' '/var/www/kd/xxxxxx/xxxx/app/../web' '/tmp/assetic_sassPxUKpd'
> Error Output: sh:
> /var/www/kd/xxxxxx/xxxx/app/../vendor/eslider/sasscb/dist/sassc: Permission
> denied   Input: @import "libs/variables"; @import "libs/mixins"; @import
> "libs/icons"; @import "element/mbslider"; @import "libs/normalize"; @import
> "modules/base"; @import "modules/text"; @import "modules/layout"; @import
> "modules/popup"; @import "modules/input"; @import "modules/button"; @import
> "modules/seperator"; @import "modules/container"; @import
> "modules/tabcontainer"; @import "modules/checkbox"; @import
> "modules/radiobutton"; @import "modules/dropdown"; @import "modules/table";
> //$rootPath: "../../../mapbendercore/";       //
> ------------------------------------------------------- APPLICATIONS
> .screenshot_upload{     padding: 0px;     position: relative;     min-width:
> 300px;      .label{         margin: 0px;         padding: 2px;        
> font-size: 12px;         white-space: nowrap;         position: relative;        
> .............................(sehr viele Zeilen mit css-elementen)....
> ............................
> !important;}\n}\n at
> /var/www/kd/xxxxxx/xxxx/vendor/kriswallsmith/assetic/src/Assetic/Exception/FilterException.php:40)"}
> []
> [2015-11-24 16:41:23] security.DEBUG: Write SecurityContext in the session
> [] []
das wird wohl daran liegen, dass die Datei
/var/www/kd/xxxxxx/xxxx/app/../vendor/eslider/sasscb/dist/sassc nicht
ausführbar ist. Ein chmod 755 sassc solle Abhilfe schaffen.

> Gibt es eigentlich ein Script, ähnlich config.php das man auch als nicht
> localhost ausführen kann, um zu prüfen ob alle erfoderlichen
> PHP-Einstellungen gesetzt sind?

Hm, das gibt es meines Wissens leider nicht.

Gruß, Andreas

_______________________________________________
Mapbender_users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/mapbender_users

signature.asc (188 bytes) Download Attachment
ivo
Reply | Threaded
Open this post in threaded view
|

Re: MB3.0.5.2 app.php HTML-Ansicht

ivo
Hi,

die Kombination proc_open zu aktivieren und chmod 755 auf sassc hat die Lösung gebracht, jetzt funktioniert es :)
Danke für die Hilfe!!!!

LG Ivo