Lizmap - editores

classic Classic list List threaded Threaded
12 messages Options
Reply | Threaded
Open this post in threaded view
|

Lizmap - editores

Pedro
Olá,

Ando aqui de volta com uns projectos em Lizmap e há uma série de situações que não consigo fazer em condições.
São várias situações mas vou agrupar tudo no mesmo tópico.

Antes de mais o projecto principal está em QGIS 2.6, o Lizmap que utilizo é a versão 2.10. Os dados são originários do Postgis (vistas) e a máquina onde está tudo alojado tem Windows Server 2008 R2, 64bits.

1. No Lizmap ao editar um objecto aparece sempre no final o  campo geometry que tem as coordenadas dos vértices (no QGIS não tenho nada disso).
Isto sucede-me com dados em Postgis ou shape. Fazem ideia como esconder este atributo?





2.Tenho no QGIS um atributo definido no Edit Widget como "valor do mapa" onde defino os valores que pretendo e quando chamo o editor no QGIS aparece como esperado:



- No Lizmap quando chamo esse editor aparece-me apenas o valor que está na base de dados (1,2,3,4).


- Curiosamente quando coloco essa camada como editável no Lizmap (para fazer alterações) o editor que me aparece já vai buscar a "legenda" dos valores de mapa.


 dá a sensação que num lado vai à base de dados e no outro vai ao qgis...

obrigado,
Pedro


Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
Pedro wrote
Olá,

Ando aqui de volta com uns projectos em Lizmap e há uma série de situações que não consigo fazer em condições.
São várias situações mas vou agrupar tudo no mesmo tópico.

Antes de mais o projecto principal está em QGIS 2.6, o Lizmap que utilizo é a versão 2.10. Os dados são originários do Postgis (vistas) e a máquina onde está tudo alojado tem Windows Server 2008 R2, 64bits.

1. No Lizmap ao editar um objecto aparece sempre no final o  campo geometry que tem as coordenadas dos vértices (no QGIS não tenho nada disso).
Isto sucede-me com dados em Postgis ou shape. Fazem ideia como esconder este atributo?
Para memória futura fica a solução deste problema.
Tal como esperado não é nada de transcendental basta nas Propriedades do Projecto | Servidor OWS retirar a opção "Adicionar geometria ao elemento de resposta"


Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
Ainda sobre os editores, algo que me apercebi e que para mim não faz muito sentido no lado do Lizmap.

No Lizmap as camadas podem ter permissões apenas de Consulta ou também de Actualização.

Quando no Lizmap chamamos o editor de Consulta ele vai buscar os atributos conforme estão definidos na Base de Dados, se a camada também tiver permissões de Actualização vai buscar os dados tal como foram definidos no projecto no Qgis (que acho que é o que deveria suceder também no editor de consulta).

Deixo umas imagens para se perceber melhor:






Não sei se é um bug mas parece.
Há uma forma de contornar isto que é criar no QGIS dentro do plugin do Lizmap um popup personalizado com os campos que se pretenda mas é algo que é trabalhoso e que não devia ser necessário.

Não sei se alguém que utiliza o Lizmap já se apercebeu disto.

Pedro
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Giovanni Manghi-2
> Não sei se alguém que utiliza o Lizmap já se apercebeu disto.


resumindo:

com pelo menos a edit widget "hidden" do QGIS o LM funciona de forma
coerente non form de edição dos atributos mas não no form de
visualização dos mesmos, certo?

se sim

1) experimenta LM master

2) se o bug continuar aparecer abre um ticket no bugtracker/github do LM

Ciao!

--
Giovanni Manghi
Faunalia.pt
Sistemas de Informação Geográfica Open Source
Portugal

Web: http://www.faunalia.pt
Email & Jabber: [hidden email]
PGP Key available
Tel. + 351 96 7058216
--
_______________________________________________
QGIS-pt mailing list
[hidden email]
http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-pt
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
Giovanni Manghi-2 wrote
> Não sei se alguém que utiliza o Lizmap já se apercebeu disto.


resumindo:

com pelo menos a edit widget "hidden" do QGIS o LM funciona de forma
coerente non form de edição dos atributos mas não no form de
visualização dos mesmos, certo?

se sim

1) experimenta LM master

2) se o bug continuar aparecer abre um ticket no bugtracker/github do LM

Ciao!

--
Giovanni Manghi
Sim Giovanni é isso.

Com o Lizmap Master dá-me um erro 500 que não consigo resolver (daí ter optado pelo Lizmap 2.10).

Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Giovanni Manghi-2
> Sim Giovanni é isso.
>
> Com o Lizmap Master dá-me um erro 500 que não consigo resolver (daí ter
> optado pelo Lizmap 2.10).
> <http://osgeo-org.1560.x6.nabble.com/file/n5174253/error.png>

isso já expliquei como se corrige: no LM master faltam strings ao
ficheiro de tradução pt_pt, eu já fiz a patch mas esta não foi
ainda incluida no codigo fonte. É suficiente ir buscar os ficheiros da
mina patch e os usar para substituir os do Lm master actual.

Já abriste o ticket?





--
Giovanni Manghi
Faunalia.pt
Sistemas de Informação Geográfica Open Source
Portugal

Web: http://www.faunalia.pt
Email & Jabber: [hidden email]
PGP Key available
Tel. + 351 96 7058216
--
_______________________________________________
QGIS-pt mailing list
[hidden email]
http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-pt
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
Acabei de abrir um Issue no Github

vou então ver se encontro o teu patch
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Giovanni Manghi-2
On Fri, Nov 21, 2014 at 5:58 PM, Pedro <[hidden email]> wrote:
> Acabei de abrir um Issue no Github
>
> vou então ver se encontro o teu patch


https://github.com/3liz/lizmap-web-client/pull/99




--
Giovanni Manghi
Faunalia.pt
Sistemas de Informação Geográfica Open Source
Portugal

Web: http://www.faunalia.pt
Email & Jabber: [hidden email]
PGP Key available
Tel. + 351 96 7058216
--
_______________________________________________
QGIS-pt mailing list
[hidden email]
http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-pt
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
This post was updated on .
Giovanni Manghi-2 wrote
On Fri, Nov 21, 2014 at 5:58 PM, Pedro <[hidden email]> wrote:
> Acabei de abrir um Issue no Github
>
> vou então ver se encontro o teu patch


https://github.com/3liz/lizmap-web-client/pull/99
Fiz isso e realmente consigo entrar nos projectos Demo (antes não o conseguia), mas depois de entrar com o user admin e quando tento editar a "Configuração Lizmap" na aplicação (por exemplo para criar repositórios) devolve-me o tal erro 500

"Error 500. A technical error has occured. Sorry for this trouble."




no ficheiro lizmapConfig.ini.php alterei para:
wmsServerURL="http://127.0.0.1/qgis/qgis_mapserv.fcgi.exe"
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Giovanni Manghi-2

Fiz isso e realmente consigo entrar nos projectos Demo (antes não o
conseguia), mas depois de entrar com o user admin e quando tento editar a
"Configuração Lizmap" na aplicação (por exemplo para criar repositórios)
devolve-me o tal erro 500


quer dizer que há mais strings para traduzir

se experimentas e acrescentas

&lang=en


provavelmente funciona (e iria confirmar o problema das strings não traduzidas).


 


--
Giovanni Manghi
Faunalia.pt
Sistemas de Informação Geográfica Open Source
Portugal

Web: http://www.faunalia.pt
Email & Jabber: [hidden email]
PGP Key available
Tel. + 351 96 7058216
--

_______________________________________________
QGIS-pt mailing list
[hidden email]
http://lists.osgeo.org/cgi-bin/mailman/listinfo/qgis-pt
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
Sim acrescentando  &lang=en   funciona
Reply | Threaded
Open this post in threaded view
|

Re: Lizmap - editores

Pedro
Embora funcionando sucede o mesmo que no 2.10
(com pelo menos a edit widget "hidden" do QGIS o LM funciona de forma
coerente non form de edição dos atributos mas não no form de
visualização dos mesmos)

Outra coisa que sucede no Lizmap (não sei se a causa será a mesma) é o facto de quando eu tenho Vistas do Postgis que são editáveis e no final faço Guardar aplicação não faz nada...
Se forem Tabelas do Postgis faço as alterações no Lizmap e o Guardar funciona como esperado.


Pedro