Java Mapscript problem

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Java Mapscript problem

Jesse Rosalia
I am using MS4W v1.5.5 and Tomcat 5.5.9 (bundled with Netbeans 5.0), and Im trying to use Java Mapscript within a web application.  I followed the tutorial on the mapserver web site for setting up java mapscript with Tomcat 5.5, but cant seem to get around the following runtime error (occurs when it tries to load the dll):

"java.lang.UnsatisfiedLinkError: C:\javamapscript\mapscript.dll: The specified procedure could not be found"

I have mapscript.dll and supporting dlls (verified using the Microsoft dependency walker utility) in the c:\javamapscript directory, and that directory is in my system path.  I also installed mapscript.jar into the tomcat common\lib directory.  I even tried compiling and running the MapTest.java/MapThread.java tests distributed with the map server source...still no dice.  I cant seem to figure out what Im doing wrong here. 

Thanks in advance for your help

-Jesse




_______________________________________________
ms4w-users mailing list
[hidden email]
http://lists.maptools.org/mailman/listinfo/ms4w-users