Issues with OpenLayers 2.12RCs and Google Maps v3

classic Classic list List threaded Threaded
6 messages Options
Reply | Threaded
Open this post in threaded view
|

Issues with OpenLayers 2.12RCs and Google Maps v3

Jefferson Heard
Google seems to have changed its backend API again. Google's base maps no longer zoom with the rest of the layers I have; rather, my vector and WMS layers zoom first and then google "catches up". 

Is there also a recommended maximum zoom level for Google? At a certain point, the satellite and hybrid map types switch to a 3/4ths view of the world instead of EPSG:900913. Is that meant to happen, or am I using the wrong layer type IDs for creating the layers?

Here is my layer code:


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Issues with OpenLayers 2.12RCs and Google Maps v3

Bart van den Eijnden
Can you clarify if you are talking about the 2.12 RC's or the 2.13 RC's?

Best regards,
Bart

-- 
Bart van den Eijnden
OpenGeo - http://opengeo.org
Expert service straight from the developers.



On Jun 12, 2013, at 6:05 PM, Jeff Heard <[hidden email]> wrote:

Google seems to have changed its backend API again. Google's base maps no longer zoom with the rest of the layers I have; rather, my vector and WMS layers zoom first and then google "catches up". 

Is there also a recommended maximum zoom level for Google? At a certain point, the satellite and hybrid map types switch to a 3/4ths view of the world instead of EPSG:900913. Is that meant to happen, or am I using the wrong layer type IDs for creating the layers?

Here is my layer code:

_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Issues with OpenLayers 2.12RCs and Google Maps v3

Jefferson Heard
2.13RC's, but the 2.12 release exhibits the same behavior.


On Wed, Jun 12, 2013 at 2:34 PM, Bart van den Eijnden <[hidden email]> wrote:
Can you clarify if you are talking about the 2.12 RC's or the 2.13 RC's?

Best regards,
Bart

-- 
Bart van den Eijnden
OpenGeo - http://opengeo.org
Expert service straight from the developers.



On Jun 12, 2013, at 6:05 PM, Jeff Heard <[hidden email]> wrote:

Google seems to have changed its backend API again. Google's base maps no longer zoom with the rest of the layers I have; rather, my vector and WMS layers zoom first and then google "catches up". 

Is there also a recommended maximum zoom level for Google? At a certain point, the satellite and hybrid map types switch to a 3/4ths view of the world instead of EPSG:900913. Is that meant to happen, or am I using the wrong layer type IDs for creating the layers?

Here is my layer code:

_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users



_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Issues with OpenLayers 2.12RCs and Google Maps v3

Jefferson Heard
Also, this is my <script> tag for the Google Maps API.



On Wed, Jun 12, 2013 at 2:41 PM, Jeff Heard <[hidden email]> wrote:
2.13RC's, but the 2.12 release exhibits the same behavior.


On Wed, Jun 12, 2013 at 2:34 PM, Bart van den Eijnden <[hidden email]> wrote:
Can you clarify if you are talking about the 2.12 RC's or the 2.13 RC's?

Best regards,
Bart

-- 
Bart van den Eijnden
OpenGeo - http://opengeo.org
Expert service straight from the developers.



On Jun 12, 2013, at 6:05 PM, Jeff Heard <[hidden email]> wrote:

Google seems to have changed its backend API again. Google's base maps no longer zoom with the rest of the layers I have; rather, my vector and WMS layers zoom first and then google "catches up". 

Is there also a recommended maximum zoom level for Google? At a certain point, the satellite and hybrid map types switch to a 3/4ths view of the world instead of EPSG:900913. Is that meant to happen, or am I using the wrong layer type IDs for creating the layers?

Here is my layer code:

_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users




_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Issues with OpenLayers 2.12RCs and Google Maps v3

Andor Borsos
Jeff Heard <jefferson.r.heard@...> writes:

>
>
> Also, this is my <script> tag for the Google Maps API.
>
> <script src="http://maps.google.com/maps/api/js?v=3&sensor=false">
</script>
>
>
>
> On Wed, Jun 12, 2013 at 2:41 PM, Jeff Heard <jefferson.r.heard <at>
gmail.com> wrote:
> 2.13RC's, but the 2.12 release exhibits the same behavior.
>
>
>
> On Wed, Jun 12, 2013 at 2:34 PM, Bart van den Eijnden <bartvde-
[hidden email]> wrote:Can you clarify if you are
talking about the 2.12 RC's or the 2.13 RC's?

>
>
>
>
> Best regards,
> Bart
>
>
>
>
>
> -- Bart van den EijndenOpenGeo - http://opengeo.orgExpert service straight
from the developers.
>
>
>
>
> On Jun 12, 2013, at 6:05 PM, Jeff Heard <jefferson.r.heard <at> gmail.com>
wrote:
>
>
>
> Google seems to have changed its backend API again. Google's base maps no
longer zoom with the rest of the layers I have; rather, my vector and WMS
layers zoom first and then google "catches up". 
>
>
>
>
>
>
> Is there also a recommended maximum zoom level for Google? At a certain
point, the satellite and hybrid map types switch to a 3/4ths view of the
world instead of EPSG:900913. Is that meant to happen, or am I using the
wrong layer type IDs for creating the layers?

>
>
>
>
>
> Here is my layer code:
>
>
> http://pastebin.com/ksqCrEVC
>
>
> _______________________________________________Users mailing listUsers-
[hidden email]://lists.osgeo.org/mailman/lis
tinfo/openlayers-users

>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
> _______________________________________________
> Users mailing list
> Users@...
> http://lists.osgeo.org/mailman/listinfo/openlayers-users
>
Hi,

I have the same issue with zooming in Release 2.13.1. in Google Maps Layer.
If I switch back to "Release 2.13 dev" the zoom works normaly.
The issue is present only whith Google Maps Layer, when the base layer is
switched to OSM Layer the zoom works fine.

Is there a solution or workaround for the problem?

Thanks in advance,
Andor Borsos

_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users
Reply | Threaded
Open this post in threaded view
|

Re: Issues with OpenLayers 2.12RCs and Google Maps v3

Bart van den Eijnden
IIRC this was fixed in master a month ago: https://github.com/openlayers/openlayers/commit/58e345039f904cf5477f65c30e70cefeb3187a76

Best regards,
Bart

-- 
Bart van den Eijnden
OpenGeo - http://opengeo.org
Expert service straight from the developers.



On Sep 12, 2013, at 7:07 PM, Andor Borsos <[hidden email]> wrote:

Jeff Heard <jefferson.r.heard@...> writes:



Also, this is my <script> tag for the Google Maps API.

<script src="http://maps.google.com/maps/api/js?v=3&sensor=false">
</script>



On Wed, Jun 12, 2013 at 2:41 PM, Jeff Heard <jefferson.r.heard <at>
gmail.com> wrote:
2.13RC's, but the 2.12 release exhibits the same behavior.



On Wed, Jun 12, 2013 at 2:34 PM, Bart van den Eijnden <bartvde-
[hidden email]> wrote:Can you clarify if you are
talking about the 2.12 RC's or the 2.13 RC's?




Best regards,
Bart





-- Bart van den EijndenOpenGeo - http://opengeo.orgExpert service straight
from the developers.




On Jun 12, 2013, at 6:05 PM, Jeff Heard <jefferson.r.heard <at> gmail.com>
wrote:



Google seems to have changed its backend API again. Google's base maps no
longer zoom with the rest of the layers I have; rather, my vector and WMS
layers zoom first and then google "catches up". 






Is there also a recommended maximum zoom level for Google? At a certain
point, the satellite and hybrid map types switch to a 3/4ths view of the
world instead of EPSG:900913. Is that meant to happen, or am I using the
wrong layer type IDs for creating the layers?





Here is my layer code:


http://pastebin.com/ksqCrEVC


_______________________________________________Users mailing listUsers-
[hidden email]://lists.osgeo.org/mailman/lis
tinfo/openlayers-users















_______________________________________________
Users mailing list
Users@...
http://lists.osgeo.org/mailman/listinfo/openlayers-users

Hi,

I have the same issue with zooming in Release 2.13.1. in Google Maps Layer.
If I switch back to "Release 2.13 dev" the zoom works normaly.
The issue is present only whith Google Maps Layer, when the base layer is
switched to OSM Layer the zoom works fine.

Is there a solution or workaround for the problem?

Thanks in advance,
Andor Borsos

_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users


_______________________________________________
Users mailing list
[hidden email]
http://lists.osgeo.org/mailman/listinfo/openlayers-users