Issues after upgrade

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Issues after upgrade

Andreas Böhme
Hi guys,
I recently updated from 3.6 to 3.10.2.
I had some issues with our editor, but thanks to some guys I noticed it
had something to do with new schemas and our external data directory.
(https://github.com/geonetwork/core-geonetwork/issues/4556)
After that I tried to implement the INSPRE GEMET Thesaurus from the
given Link in the Inspire Registry (as integrated in the geonetwork
classification config). After that I had the same issue with the editor
again, it was not working properly and just showing a blank page like in
the above mentioned issue. After I deleted the Thesaurs all went smooth
again. I have attached a screenshot of my Logfile which shows the error
in more detail. I also checked my data directory and the rdf-File is
actually there. What went wrong there and how can I get this thesaurus
to work?

Another thing is when I search for metadata. I type in my search term
and the autocomplete gives me a suggestion of a title, but when I click
on the search button no results are shown. I am logged in as an
administrator and have full rights. Any ideas on that ?

I also recognized, that after the upgrade I can not log out under
certain circumstances I yet have not figured out. Our GN is connected to
our LDAP and I recognized that there are some differences between the
old LDAP-config file (config-security.properties) and the new one. In
the Old file it says:

"logout.success.url=/*home*?node=@@nodeId@@" whereas in the new one
"logout.success.url=/?node=@@nodeId@@" so the word "home" is missing
there. Is that an issue ?

I still have the issue with the zoom level on our map viewer as the zoom
level is way to high and the whole world is shown many times. Can this
also has something to do with eternal data directory like with the schemas?

Many thanks for your answers. Have a nice weekend.
Cheers
Andreas

------------------------------------------------


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issues after upgrade

Andreas Böhme
Sorry, I forgot the screenshot....

Am 15.05.2020 um 16:20 schrieb Andreas Böhme:

> Hi guys,
> I recently updated from 3.6 to 3.10.2.
> I had some issues with our editor, but thanks to some guys I noticed
> it had something to do with new schemas and our external data
> directory. (https://github.com/geonetwork/core-geonetwork/issues/4556)
> After that I tried to implement the INSPRE GEMET Thesaurus from the
> given Link in the Inspire Registry (as integrated in the geonetwork
> classification config). After that I had the same issue with the
> editor again, it was not working properly and just showing a blank
> page like in the above mentioned issue. After I deleted the Thesaurs
> all went smooth again. I have attached a screenshot of my Logfile
> which shows the error in more detail. I also checked my data directory
> and the rdf-File is actually there. What went wrong there and how can
> I get this thesaurus to work?
>
> Another thing is when I search for metadata. I type in my search term
> and the autocomplete gives me a suggestion of a title, but when I
> click on the search button no results are shown. I am logged in as an
> administrator and have full rights. Any ideas on that ?
>
> I also recognized, that after the upgrade I can not log out under
> certain circumstances I yet have not figured out. Our GN is connected
> to our LDAP and I recognized that there are some differences between
> the old LDAP-config file (config-security.properties) and the new one.
> In the Old file it says:
>
> "logout.success.url=/*home*?node=@@nodeId@@" whereas in the new one
> "logout.success.url=/?node=@@nodeId@@" so the word "home" is missing
> there. Is that an issue ?
>
> I still have the issue with the zoom level on our map viewer as the
> zoom level is way to high and the whole world is shown many times. Can
> this also has something to do with eternal data directory like with
> the schemas?
>
> Many thanks for your answers. Have a nice weekend.
> Cheers
> Andreas
>
> ------------------------------------------------
>
>
> _______________________________________________
> GeoNetwork-users mailing list
> [hidden email]
> https://lists.sourceforge.net/lists/listinfo/geonetwork-users
> GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork
--
--------------------------------------------------------------------------------------------
                                               
Andreas Böhme
Techniker/Technician
Landschaftsökologie/Computational Landscape Ecology
                               
Helmholtz-Zentrum für Umweltforschung GmbH - UFZ
Helmholtz Centre for Environmental Research GmbH - UFZ
Permoserstraße 15, 04318 Leipzig, Germany
Phone +49 341 235 1058
[hidden email], www.ufz.de

Sitz der Gesellschaft/Registered Office: Leipzig
Registergericht/Registration Office: Amtsgericht Leipzig
Handelsregister Nr./Trade Register Nr.: B 4703
Vorsitzender des Aufsichtsrats/Chairman of the Supervisory Board: N.N.
Wissenschaftlicher Geschäftsführer/Scientific Managing Director:
Prof. Dr. Georg Teutsch
Administrative Geschäftsführerin/Administrative Managing Director:
Dr. Sabine König

Vermeiden Sie unnötige Ausdrucke./Think before printing.

Informationen aus der Wissenschaft (z.B. Veranstaltungshinweise, Projektangaben, Publikationen,
Bücher)

--------------------------------------------------------------------------------------------



_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork

2020-05-12 12_35_54-Geonetwork_Live - root@geonetwork99_ _var_log_tomcat8 - Xshell 6 (Free for Home_.png (333K) Download Attachment
smime.p7s (7K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: Issues after upgrade

Jeff Campbell
In reply to this post by Andreas Böhme
Hi Andreas,

Yesterday, we upgraded from 3.4.2 to 3.10.2. Our main lesson was to be careful with Postgres and PostGIS versions since some versions of PostGIS had to be in the public schema while others allowed it to be in its own schema (postgis in our case).

We had some strange formatting of the screens. That was fixed by clearing the caches. There was also an index rebuild.
If you have any ISO 19115-3.2014 records they will not be visible in 3.10.2 because that schema is 19115-3.2018.
We had two solutions:
  • Export the 19115-3.2014 records as xml, run the transform to 19115-3.2018, import those records.  Wwe kept the uuid since it was the same data. Since we exported the original 19115-3 xml we could import that again if we need to restore later).
OR
  • Rebuild the geonetwork war and Include the 19115-3.2014 schema so they are indexed and can be displayed.
    • This would also allow you to go to the Edit Board and choose the 19115-3 facet option to see how many and which records are in that format.
  •  
We only had a few -3 records, so we exported, transformed in Oxygen, and imported.

Jeff



On 5/15/2020 10:20 AM, Andreas Böhme wrote:
Hi guys,
I recently updated from 3.6 to 3.10.2.
I had some issues with our editor, but thanks to some guys I noticed it had something to do with new schemas and our external data directory. (https://github.com/geonetwork/core-geonetwork/issues/4556)
After that I tried to implement the INSPRE GEMET Thesaurus from the given Link in the Inspire Registry (as integrated in the geonetwork classification config). After that I had the same issue with the editor again, it was not working properly and just showing a blank page like in the above mentioned issue. After I deleted the Thesaurs all went smooth again. I have attached a screenshot of my Logfile which shows the error in more detail. I also checked my data directory and the rdf-File is actually there. What went wrong there and how can I get this thesaurus to work?

Another thing is when I search for metadata. I type in my search term and the autocomplete gives me a suggestion of a title, but when I click on the search button no results are shown. I am logged in as an administrator and have full rights. Any ideas on that ?

I also recognized, that after the upgrade I can not log out under certain circumstances I yet have not figured out. Our GN is connected to our LDAP and I recognized that there are some differences between the old LDAP-config file (config-security.properties) and the new one. In the Old file it says:

"logout.success.url=/*home*?node=@@nodeId@@" whereas in the new one "logout.success.url=/?node=@@nodeId@@" so the word "home" is missing there. Is that an issue ?

I still have the issue with the zoom level on our map viewer as the zoom level is way to high and the whole world is shown many times. Can this also has something to do with eternal data directory like with the schemas?

Many thanks for your answers. Have a nice weekend.
Cheers
Andreas

------------------------------------------------


_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork




_______________________________________________
GeoNetwork-users mailing list
[hidden email]
https://lists.sourceforge.net/lists/listinfo/geonetwork-users
GeoNetwork OpenSource is maintained at http://sourceforge.net/projects/geonetwork